Aggiornare MIB Live Gnome 2009.1

Area dedicata alle MIB-Live DVD e alle ISO Mandriva aggiornate dal MIB
Post Reply
User avatar
nonnogs
Utente
Utente
Posts: 221
Joined: 13 October 2008, 17:43

Aggiornare MIB Live Gnome 2009.1

Post by nonnogs »

Ho provato numerose volte ma non ci riesco. L'applet segnala nuovi aggiornamenti,provo da terminale

[root@localhost giorgio]# urpmi --auto-update
(non ho copiato quì in mezzo ci sono gli aggiornamenti dei supporti)
Alcuni dei pacchetti richiesti non possono essere installati:
miro-2.5.2-69.4mib2009.1.i686 (per conservare miro-2.5.2-69.1mib2009.1.i686)
vlc-plugin-arts-0.9.8a-5mdv2009.1.i586 (per conservare vlc-plugin-arts-0.9.8a-5plf2009.1.i586)
vlc-plugin-esd-0.9.8a-5mdv2009.1.i586 (per conservare vlc-plugin-esd-0.9.8a-5plf2009.1.i586)
Continuo comunque l'Installazione? (S/n) S
Per soddisfare le dipendenze, saranno installati i seguenti pacchetti:
Pacchetto Versione Release Arch.
(supporto "MIB-FREE_i686")
firefox 3.5.3 69.1mib2009.1 i686
firefox-it 3.5.3 69.1mib2009.1 i686
libnspr4 4.8 1mib2009.1 i686
libxulrunner1.9.1.3 1.9.1.3 69.1mib2009.1 i686
vlc 1.0.2 69.1plf.mib2> i686
vlc-plugin-schroedinger 1.0.2 69.1plf.mib2> i686
xulrunner 1.9.1.3 69.1mib2009.1 i686
(supporto "Main Updates")
epiphany 2.26.1 1.5mdv2009.1 i586
glib2.0-common 2.20.1 1.1mdv2009.1 i586
gnome-python-gtkmozembed 2.25.3 3.5mdv2009.1 i586
libglib2.0_0 2.20.1 1.1mdv2009.1 i586
libxulrunner1.9 1.9.0.14 0.1mdv2009.1 i586
yelp 2.26.0 3.4mdv2009.1 i586
(supporto "Contrib")
libxcb-util-devel 0.3.3 1mdv2009.1 i586
(supporto "PLF Free")
libfreetype6 2.3.9 1.2plf2009.1 i586
Altri 34MB di spazio disco saranno utilizzati.
verranno scaricati 26MB di pacchetti.
Procedo con l'installazione di 15 pacchetti? (S/n) S

installazione di libnspr4-4.8-1mib2009.1.i686.rpm firefox-3.5.3-69.1mib2009.1.i686.rpm libglib2.0_0-2.20.1-1.1mdv2009.1.i586.rpm epiphany-2.26.1-1.5mdv2009.1.i586.rpm libxulrunner1.9-1.9.0.14-0.1mdv2009.1.i586.rpm libfreetype6-2.3.9-1.2plf2009.1.i586.rpm xulrunner-1.9.1.3-69.1mib2009.1.i686.rpm libxcb-util-devel-0.3.3-1mdv2009.1.i586.rpm yelp-2.26.0-3.4mdv2009.1.i586.rpm firefox-it-3.5.3-69.1mib2009.1.i686.rpm gnome-python-gtkmozembed-2.25.3-3.5mdv2009.1.i586.rpm libxulrunner1.9.1.3-1.9.1.3-69.1mib2009.1.i686.rpm glib2.0-common-2.20.1-1.1mdv2009.1.i586.rpm da /var/cache/urpmi/rpms
Installazione fallita:
libxulrunner1.9 = 1.9.0.13 necessario a (installato) miro-69:2.5.2-69.1mib2009.1.i686

installazione di vlc-plugin-schroedinger-1.0.2-69.1plf.mib2009.1.i686.rpm vlc-1.0.2-69.1plf.mib2009.1.i686.rpm da /var/cache/urpmi/rpms
Installazione fallita:
libxcb-keysyms.so.0 necessario a vlc-1.0.2-69.1plf.mib2009.1.i686
vlc = 0.9.8a necessario a (installato) vlc-plugin-arts-0.9.8a-5plf2009.1.i586
vlc = 0.9.8a necessario a (installato) vlc-plugin-esd-0.9.8a-5plf2009.1.i586
Installazione fallita:
libxulrunner1.9 = 1.9.0.13 necessario a (installato) miro-69:2.5.2-69.1mib2009.1.i686
libxcb-keysyms.so.0 necessario a vlc-1.0.2-69.1plf.mib2009.1.i686
vlc = 0.9.8a necessario a (installato) vlc-plugin-arts-0.9.8a-5plf2009.1.i586
vlc = 0.9.8a necessario a (installato) vlc-plugin-esd-0.9.8a-5plf2009.1.i586
[root@localhost giorgio]#

Allora provo da MCC -> Aggiorna il sistema.
Viene l'elenco dei pacchetti da installare,clic su Aggiorna,la prima risposta è la seguente :
Spiacente, questi pacchetti non possono essere selezionati:
- vlc-1.0.2-69.1plf.mib2009.1.i686 (perché non è soddisfatto libxcb-keysyms.so.0)
- vlc-plugin-schroedinger-1.0.2-69.1plf.mib2009.1.i686

Va bene,andiamo avanti.Si apre la finestra degli aggiornamenti :
Questi 12 pacchetti stanno per essere installati:

- epiphany-2.26.1-1.5mdv2009.1.i586
- firefox-3.5.3-69.1mib2009.1.i686
- firefox-it-3.5.3-69.1mib2009.1.i686
- glib2.0-common-2.20.1-1.1mdv2009.1.i586
- gnome-python-gtkmozembed-2.25.3-3.5mdv2009.1.i586
- libfreetype6-2.3.9-1.2plf2009.1.i586
- libglib2.0_0-2.20.1-1.1mdv2009.1.i586
- libnspr4-4.8-1mib2009.1.i686
- libxulrunner1.9-1.9.0.14-0.1mdv2009.1.i586
- libxulrunner1.9.1.3-1.9.1.3-69.1mib2009.1.i686
- xulrunner-1.9.1.3-69.1mib2009.1.i686
- yelp-2.26.0-3.4mdv2009.1.i586

Altri 28MB di spazio disco saranno utilizzati.

Saranno scaricati 21MB di pacchetti.

Vuoi proseguire? Si.
Finestra successiva
1 transazioni dell'installazione fallite

Si è verificato un problema durante l'installazione:

libxulrunner1.9 = 1.9.0.13 necessario a (installato) miro-69:2.5.2-69.1mib2009.1.i686
Mi scuso di averla fatta tanto lunga,ho voluto copiare perchè altrimenti sarebbe stato difficile farmi capire.Sono diversi giorni che faccio questo giro vizioso e la dentro c'è Firefox 3.5.3,abbastanza importante.Si può fare qualcosa?

User avatar
NicCo
Amministratore
Amministratore
Posts: 4739
Joined: 6 December 2007, 19:54

Re: Aggiornare MIB Live Gnome 2009.1

Post by NicCo »

Per iniziare mi sembra di capire che Miro,
blocchi tutto perche si rifiuta di far aggiornare la libxulrunnerche occorre a numerosi programmi

In questo caso la prima cosa da fare è rimuovere momentaneamente il pacchetto che fa ostacolo

Code: Select all

urpme miro
tentare di fare gli aggiornamenti nuovamente, se non ci sono altri ostacoli verranno fatti tutti!
altrimenti individuare e rimuover l'altro ostacolo, prendendo appunto di ciò che si è rimosso

Code: Select all

urpme ostacolo2
e riprovare di nuovo a fare gli gli aggiornamenti

Code: Select all

urpmi -auto-select
alla fine si reinstallano nuovamente i pacchetti che facevano ostacolo e che sono stati rimossi

Code: Select all

urpmi miro

Code: Select all

urpmi ostacolo2
E tutto così sara aggiornato e nulla sarà perso!


ATTENZIONE
- vlc-1.0.2-69.1plf.mib2009.1.i686 (perché non è soddisfatto libxcb-keysyms.so.0)
questo indica che hai i repository non configurati correttamente:
probabilmente non hai attivato i repo backports ed esattamente sono 5

main backports
contrib backports
non-free backports

plf-free backports
plf-nonfree backports

puoi farlo da Centro di Controllo, Gestione Software,
devi far si che controlli via web ogni singolo repo che deve essere attivato
e poi devi far in modo che appaia l'icona di spunta a sinistra (Abilitato)



ciao
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
nonnogs
Utente
Utente
Posts: 221
Joined: 13 October 2008, 17:43

Re: Aggiornare MIB Live Gnome 2009.1

Post by nonnogs »

Grazie NicCo,sono andati quasi tutti dopo aver rimosso miro che ho reinstallato. Ho detto quasi tutti perchè da terminale me dava 18 installati su 20 ma aggiorna il sistema di MCC me ne ha dati altri 8 (perchè?).Ho dovuto disinstallarne degli orfani e non so se ho fatto bene.Tu ti pronunciasti a sfavore della disinstallazion degli orfani.Ti posto il terminale così vedi:

18/20: yelp #############################################

http://plf.zarb.org/mirrors/2009.1.i586.list: media/../../../../2009.1/free/backports/binary/i586/vlc-1.0.1-1plf2009.1.i586.rpm
installazione di vlc-1.0.1-1plf2009.1.i586.rpm libxcb-util-devel-0.3.3-1mdv2009.1.i586.rpm da /var/cache/urpmi/rpms
Installazione fallita:
vlc = 0.9.8a necessario a (installato) vlc-plugin-arts-0.9.8a-5plf2009.1.i586
vlc = 0.9.8a necessario a (installato) vlc-plugin-schroedinger-0.9.8a-5plf2009.1.i586
vlc = 0.9.8a necessario a (installato) vlc-plugin-esd-0.9.8a-5plf2009.1.i586
Installazione fallita:
vlc = 0.9.8a necessario a (installato) vlc-plugin-arts-0.9.8a-5plf2009.1.i586
vlc = 0.9.8a necessario a (installato) vlc-plugin-schroedinger-0.9.8a-5plf2009.1.i586
vlc = 0.9.8a necessario a (installato) vlc-plugin-esd-0.9.8a-5plf2009.1.i586
[root@localhost giorgio]# urpme --auto-orphans
writing /var/lib/rpm/installed-through-deps.list
Per soddisfare le dipendenze, saranno rimossi i seguenti 9 pacchetti (28MB):

(pacchetti orfani)
libice6-devel-1.0.5-1mdv2009.1.i586
libpthread-stubs-0.1-5mdv2009.1.i586
libsm6-devel-1.1.0-1mdv2009.1.i586
libx11_6-devel-1.2.1-1.2mdv2009.1.i586
libxau6-devel-1.0.4-1mdv2009.1.i586
libxcb-devel-1.2-1.2mdv2009.1.i586
libxdmcp6-devel-1.0.2-6mdv2009.1.i586
libxt6-devel-1.0.5-4mdv2009.1.i586
x11-proto-devel-7.4-16mdv2009.1.i586
Rimuovo 9 pacchetti? (s/N) s
rimozione di libice6-devel-1.0.5-1mdv2009.1.i586 libpthread-stubs-0.1-5mdv2009.1.i586 libsm6-devel-1.1.0-1mdv2009.1.i586 libx11_6-devel-1.2.1-1.2mdv2009.1.i586 libxau6-devel-1.0.4-1mdv2009.1.i586 libxcb-devel-1.2-1.2mdv2009.1.i586 libxdmcp6-devel-1.0.2-6mdv2009.1.i586 libxt6-devel-1.0.5-4mdv2009.1.i586 x11-proto-devel-7.4-16mdv2009.1.i586
rimozione del pacchetto libpthread-stubs-0.1-5mdv2009.1.i586
rimozione del pacchetto libxdmcp6-devel-1.0.2-6mdv2009.1.i586
rimozione del pacchetto x11-proto-devel-7.4-16mdv2009.1.i586
rimozione del pacchetto libsm6-devel-1.1.0-1mdv2009.1.i586
rimozione del pacchetto libx11_6-devel-1.2.1-1.2mdv2009.1.i586
rimozione del pacchetto libxau6-devel-1.0.4-1mdv2009.1.i586
rimozione del pacchetto libxt6-devel-1.0.5-4mdv2009.1.i586
rimozione del pacchetto libice6-devel-1.0.5-1mdv2009.1.i586
rimozione del pacchetto libxcb-devel-1.2-1.2mdv2009.1.i586
[root@localhost giorgio]# urpmi miro
Per soddisfare le dipendenze, saranno installati i seguenti pacchetti:
Pacchetto Versione Release Arch.
(supporto "Main")
python-pyrex 0.9.8.5 2mdv2009.1 noarch
(supporto "Main Updates")
gnome-python-gtkmozembed 2.25.3 3.5mdv2009.1 i586
(supporto "Contrib Backports")
miro 2.5.2 5mdv2009.1 i586
Altri 29MB di spazio disco saranno utilizzati.
verranno scaricati 4.5MB di pacchetti.
Procedo con l'installazione di 3 pacchetti? (S/n) S

$MIRRORLIST: media/main/release/python-pyrex-0.9.8.5-2mdv2009.1.noarch.rpm
$MIRRORLIST: media/contrib/backports/miro-2.5.2-5mdv2009.1.i586.rpm
installazione di python-pyrex-0.9.8.5-2mdv2009.1.noarch.rpm gnome-python-gtkmozembed-2.25.3-3.5mdv2009.1.i586.rpm miro-2.5.2-5mdv2009.1.i586.rpm da /var/cache/urpmi/rpms
In preparazione... #############################################
1/3: gnome-python-gtkmozembed
#############################################
2/3: python-pyrex #############################################
3/3: miro #############################################
[root@localhost giorgio]#

Ti chiedo : quei vlc che mi trovo sempre tra i piedi è normale che siano così? Non ricordo di essere mai riuscito ad installarli. C'è una ragione?

Per quanto riguarda i supporti sono tutti attivati. Nella mia disperazione tanto per non sbagliare,li ho attivati tutti e credo che sia inutile,se ben ricordo una affermazione di Symbianflo. Puoi chiarirmi l'idee,per favore?

Ciao e grazie. ( è quasi un'altra lenzuolata,come direbbe il buon Bersani!)

User avatar
NicCo
Amministratore
Amministratore
Posts: 4739
Joined: 6 December 2007, 19:54

Re: Aggiornare MIB Live Gnome 2009.1

Post by NicCo »

Installazione fallita:
vlc = 0.9.8a necessario a (installato) vlc-plugin-arts-0.9.8a-5plf2009.1.i586
vlc = 0.9.8a necessario a (installato) vlc-plugin-schroedinger-0.9.8a-5plf2009.1.i586
vlc = 0.9.8a necessario a (installato) vlc-plugin-esd-0.9.8a-5plf2009.1.i586
Quei tre plugins adesso non si usano piu e vanno a bloccare tutto:
dovresti proprio disinstallarli

Code: Select all

urpme vlc-plugin-arts vlc-plugin-schroedinger vlc-plugin-esd
e poi continuare con l'aggiornamento!


Ciao
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
SymbianFlo
Utente sostenitore
Utente sostenitore
Posts: 1493
Joined: 7 December 2007, 20:07
OpenMandriva: 2010.1 x86_64
Kernel: 2.6.33.5-nrj-69mib
Desktop: kde4.5.rc1
Location: Pordenone
Contact:

Re: Aggiornare MIB Live Gnome 2009.1

Post by SymbianFlo »

hmmmm
i plugin non in uso ovvero quelli che vlc nn li sviluppa piu si dovevano compilare come obsoletes sullo spec , ma cercando nel feature-list di vlc 1.0.1-1 ( http://www.videolan.org/vlc/features.html ) non ce nulla anzi la versione linux e la piu completa, migliore di quella windows .
E nemmeno nel diff :

Code: Select all

Changes between 1.0.1 and 1.0.2:

   2 --------------------------------

   3 

   4 Decoders:

   5  * Native support for WMA Professional, without the use of the Win32 dlls

   6  * Fix issues in subtitles, especially SSA ones

   7  * Various fixes on theora and ogg

   8 

   9 Demuxers:

  10  * Various fixes for EPG support in MPEG-TS demuxer

  11  * Fixes for potential stack overflow in .avi, .mp4 and .asf demuxers

  12 

  13 Access:

  14  * Fixes for v4l2 devices

  15  * Fixes for dvb-c channels-scanning

  16 

  17 Qt Interface:

  18  * Fix some playlist sorting issues

  19 

  20 Mac OS X Interface:

  21  * Fixed a crash when updating VLC

  22  * Fixed a crash related to QTKit when opening video files (10.6 only)

  23  * Added the ability to play 2nd media in sync to the primary item (input-slave)

  24  * Added the "Quit after Playback" feature

  25 

  26 Mac OS X Port:

  27  * The "Delete Preferences" script is now delivered as a Universal Binary

  28    with native code for PowerPC, Intel and Intel 64bit

  29  * Full 64bit runtime compatibility on both Mac OS X 10.5 and 10.6

  30    - no support for Goom and SDL

  31    - limited text rendering support

  32    - This port is still considered as EXPERIMENTAL despite its binary release.

  33 

  34 Encoders:

  35  * MPEG2 transrate stream output removed

  36  * x264 default-values closer to x264.exe defaults.

  37  * x264 rc-behaviour fixes:

  38    - if user defines qp-value, CQP-mode is used

  39    - otherwise if user defines vb=0, CRF-mode is used

  40    - otherwise ABR-mode is used

  41  * x264 set vbv-bufsize/vbv-maxsize better if user hasn't defined these:

  42    - ABR mode set vbv-max-bitrate=bitrate

  43    - vbv-bufsize is bitrate * seconds between keyframes (keyint/fps)

  44 

  45 

  46 Playlist:

  47  * Lua scripts for Mpora and Vimeo playback

  48 

  49 Unix builds:

  50  * Various fixes to enable 1.0 to build on Solaris and OpenBSD

  51 

  52 Translations:

  53  * New Kazakh and Croatian translations

  54  * Lithunanian translation is available on Windows

  55  * Galician, Korean, Nepali, Vietnamese, Ukrainian, Brazilian, Arabic and French translation updates

  56 
http://git.videolan.org/?p=vlc.git;a=bl ... 3f73048c13

non lo so ma mi viene il dubbio che mdv ha fatto un'altra delle sue ......
se e cosi rega sarà guerra ....
per vlc questo e altro .... :cry:
:D ciao ciao SymbianFlo :D
Image
Linus Torvalds only has to enter a room, and every Windows computer in it segfaults instantly.
http://video.linuxfoundation.org/video/1057

Post Reply