[tuto]kernel >= 3.5.4 usb gspca webcam does not work

Guides, tutorials & docs
Post Reply
User avatar
promeneur
Utente senior
Utente senior
Posts: 547
Joined: 6 February 2009, 17:47
ROSA: -
OpenMandriva: 2010.3 i586
Kernel: 3.5.7 nrj dsktp pae
Desktop: MIB kde 4.8.4
country: France

[tuto]kernel >= 3.5.4 usb gspca webcam does not work

Post by promeneur »

see here the pb viewtopic.php?f=20&t=3578

see here the solution comment 16 https://bugzilla.kernel.org/show_bug.cgi?id=49591

i joined the driver 2.15.18 and 2.15.18-fixed

with some kernel as 3.4.11 2.15.18 version compiles without pband i check 2.15.18 works well with webcam

with some kernel as 3.6.5 2.15.18 does not compile then use 2.15.18-fixed and i check it works well with webcam

why using 2.15.18 if you have no pb with 2.14 one included in your kernel as for example kernel 3.4.11 ?
because the speed and the image is better (contrast, light) and automatical management of contrast, light works better

i can't join the files. i can send you by mail if you ask it for me
Last edited by promeneur on 19 November 2012, 11:43, edited 1 time in total.
Asus M2N, AMD Athlon 64 X2 5000+, 8 GB, Asus Nvidia 210 silent, Linksys WMP600N, Plugable USB-BT4LE Bluetooth 4.0 Adapter, lecteur multicarte Addonics AEIDDSAU, HP LaserJet 1220

User avatar
NicCo
Amministratore
Amministratore
Posts: 4739
Joined: 6 December 2007, 19:54

Re: [tuto]kernel >= 3.5.4 usb gspca webcam does not work

Post by NicCo »

promeneur wrote: i can join the files. i can send you by mail if you ask it for me
Ok, send me...

if you have a patch to fix only the problem with your webcam model module I could add in the patchset,
if you can ask the developer who found the solution with the changed code you can ask him for a patch

but I cant use an older gspca version only to fix one single module problem
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
promeneur
Utente senior
Utente senior
Posts: 547
Joined: 6 February 2009, 17:47
ROSA: -
OpenMandriva: 2010.3 i586
Kernel: 3.5.7 nrj dsktp pae
Desktop: MIB kde 4.8.4
country: France

Re: [tuto]kernel >= 3.5.4 usb gspca webcam does not work

Post by promeneur »

if you read
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=677533
https://bugs.mageia.org/show_bug.cgi?id=6596
https://bugzilla.kernel.org/show_bug.cgi?id=49591

you see there are several type of gspca which are concerned : gspca_stv06xx, gspca_vc032x, gspca_zc3xx

reading http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=677533 you see :
- the pb is in gspca_main
- jf moine (dev of gspca_main) supplies 2.15.18
- jf moine with the user indicates what to fix according to compile without error the driver

reading https://bugzilla.kernel.org/show_bug.cgi?id=49591 you see
after compiling
- i had to build the *.ko.gz with gzip
- i failed to install 2.15.18 with su -c"make install"", i had to manualy replace the *.ko.gz in /lib/modules/<kernel>/..../gspca/

using with 3.6.5 it works but in syslog i have this message :
kernel: [ 8837.246279] gspca_main: alt 1 - bandwidth not wide enough - trying again

perhaps in http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=677533 there is some fixes i didn't see about bandwidth


ok i send you :
- 2.15.18 whose compilation works with for example 3.4.11
- 2.15.18-fixed whose compilation works with for example 3.6.5
Asus M2N, AMD Athlon 64 X2 5000+, 8 GB, Asus Nvidia 210 silent, Linksys WMP600N, Plugable USB-BT4LE Bluetooth 4.0 Adapter, lecteur multicarte Addonics AEIDDSAU, HP LaserJet 1220

User avatar
promeneur
Utente senior
Utente senior
Posts: 547
Joined: 6 February 2009, 17:47
ROSA: -
OpenMandriva: 2010.3 i586
Kernel: 3.5.7 nrj dsktp pae
Desktop: MIB kde 4.8.4
country: France

Re: [tuto]kernel >= 3.5.4 usb gspca webcam does not work

Post by promeneur »

i don't find how to join file with PM !
Asus M2N, AMD Athlon 64 X2 5000+, 8 GB, Asus Nvidia 210 silent, Linksys WMP600N, Plugable USB-BT4LE Bluetooth 4.0 Adapter, lecteur multicarte Addonics AEIDDSAU, HP LaserJet 1220

User avatar
NicCo
Amministratore
Amministratore
Posts: 4739
Joined: 6 December 2007, 19:54

Re: [tuto]kernel >= 3.5.4 usb gspca webcam does not work

Post by NicCo »

in the Blog, at the MIB About, you can find my email

I dont understand one thing:
if he is the maintainer of the gspca why all that is not yet in the offcial kernel as an official fix patch...?
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
promeneur
Utente senior
Utente senior
Posts: 547
Joined: 6 February 2009, 17:47
ROSA: -
OpenMandriva: 2010.3 i586
Kernel: 3.5.7 nrj dsktp pae
Desktop: MIB kde 4.8.4
country: France

Re: [tuto]kernel >= 3.5.4 usb gspca webcam does not work

Post by promeneur »

i remember i read somewhere the new 2.15.18 will be ported in kernel 3.7 (i am not sure)
Asus M2N, AMD Athlon 64 X2 5000+, 8 GB, Asus Nvidia 210 silent, Linksys WMP600N, Plugable USB-BT4LE Bluetooth 4.0 Adapter, lecteur multicarte Addonics AEIDDSAU, HP LaserJet 1220

User avatar
promeneur
Utente senior
Utente senior
Posts: 547
Joined: 6 February 2009, 17:47
ROSA: -
OpenMandriva: 2010.3 i586
Kernel: 3.5.7 nrj dsktp pae
Desktop: MIB kde 4.8.4
country: France

Re: [tuto]kernel >= 3.5.4 usb gspca webcam does not work

Post by promeneur »

now there is a better solution
for kernel >= 3.6.8 the mib kernel contains a patch

for kernel >= 3.5 and < 3.6.8

the former main dev of gspca driver (JF Moine) created a fixed source for gspca_stv06xx

get http://moinejf.free.fr/gspca-2.15.20.tar.gz

uncompress it
then
compile it :

open a user console
go to ...../gspca-2.15.20/
execute command :

make

you must have something like this

[xy@localhost gspca-2.15.20]$ make
make -C /lib/modules/3.5.4-nrj-desktop-pae-1mib/build M=/home/roubach/rpmd/gspca/gspca-2.15.20/build modules
make[1]: entrant dans le répertoire « /usr/src/linux-3.5.4-nrj-desktop-pae-1mib »
CC [M] /home/roubach/rpmd/gspca/gspca-2.15.20/build/stv06xx/stv06xx.o
CC [M] /home/roubach/rpmd/gspca/gspca-2.15.20/build/stv06xx/stv06xx_vv6410.o
CC [M] /home/roubach/rpmd/gspca/gspca-2.15.20/build/stv06xx/stv06xx_hdcs.o
CC [M] /home/roubach/rpmd/gspca/gspca-2.15.20/build/stv06xx/stv06xx_pb0100.o
CC [M] /home/roubach/rpmd/gspca/gspca-2.15.20/build/stv06xx/stv06xx_st6422.o
LD [M] /home/roubach/rpmd/gspca/gspca-2.15.20/build/stv06xx/gspca_stv06xx.o
Building modules, stage 2.
MODPOST 1 modules
CC /home/roubach/rpmd/gspca/gspca-2.15.20/build/stv06xx/gspca_stv06xx.mod.o
LD [M] /home/roubach/rpmd/gspca/gspca-2.15.20/build/stv06xx/gspca_stv06xx.ko
make[1]: quittant le répertoire « /usr/src/linux-3.5.4-nrj-desktop-pae-1mib »
[xy@localhost gspca-2.15.20]$

you must not have any error. if this is the case the compilation stops and the new driver gspca_stv06xx is not created

then
go to .../gspca-2.15.20/build/stv06xx/
then
execute command

gzip *.ko
then
as root copy the file .../gspca-2.15.20/build/stv06xx/gspca_stv06xx.ko.gz
to /lib/modules/<your running kernel>/kernel/drivers/media/video/gspca/stv06xx/
then
restart your pc

enjoy !
Asus M2N, AMD Athlon 64 X2 5000+, 8 GB, Asus Nvidia 210 silent, Linksys WMP600N, Plugable USB-BT4LE Bluetooth 4.0 Adapter, lecteur multicarte Addonics AEIDDSAU, HP LaserJet 1220

User avatar
NicCo
Amministratore
Amministratore
Posts: 4739
Joined: 6 December 2007, 19:54

Re: [tuto]kernel >= 3.5.4 usb gspca webcam does not work

Post by NicCo »

I could prepare a new updated kernel 3.5.7

with
- final ext4 fix patch
- these patches for gspca

What do you think about? Could be useful?
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
promeneur
Utente senior
Utente senior
Posts: 547
Joined: 6 February 2009, 17:47
ROSA: -
OpenMandriva: 2010.3 i586
Kernel: 3.5.7 nrj dsktp pae
Desktop: MIB kde 4.8.4
country: France

Re: [tuto]kernel >= 3.5.4 usb gspca webcam does not work

Post by promeneur »

for me i keep 2012.2 i586 till about march next year, a fixed kernel is always useful.

today i use 3.5.7-1
Asus M2N, AMD Athlon 64 X2 5000+, 8 GB, Asus Nvidia 210 silent, Linksys WMP600N, Plugable USB-BT4LE Bluetooth 4.0 Adapter, lecteur multicarte Addonics AEIDDSAU, HP LaserJet 1220

Post Reply