[How to] Skype 4.1.0.20 with libxfixes3-5.0-4

Guides, tutorials & docs
Post Reply
User avatar
viking
Utente junior
Utente junior
Posts: 80
Joined: 26 July 2012, 18:43
ROSA: Desktop Fresh R7 x64
OpenMandriva: -
Kernel: 4.1.18-nrjQL-desktop
Desktop: KDE Plasma 5.5.4
country: Serbia

[How to] Skype 4.1.0.20 with libxfixes3-5.0-4

Post by viking »

Please note: This is only tested on Rosa 2012.1 RC x64

Skype 4.0.8 installed with get-skype might stop working if you update libxfixes3 to the latest version libxfixes3-5.0-4-rosa2012.1.i586.rpm

Then you will see a error like this:

Code: Select all

/usr/share/skype/skype: symbol lookup error: /usr/lib/libXfixes.so.3: undefined symbol: _XGetRequest
Here is a quick solution until we get new get-skype package:

0. If you already installed get-skype package, you have to remove it first.
Be sure that you do not have none of those folders /opt/skypelibs nor /usr/share/skype.
You also need to remove this file /usr/bin/skype

1. Go to http://www.skype.com/intl/en-us/get-sky ... ter/linux/ and download dynamic package.

2. Unpack to folder of your preference, for example /opt/skype

3. Install latest packages needed to run dynamic version:

Code: Select all

urpmi libqtwebkit4
urpmi libqtdbus4 
urpmi libalsa-plugins-pulseaudio
urpmi libxscrnsaver1
4. Add to path or made a shortcut if you need it (or both)

Enjoy using latest Skype for Linux! :D

User avatar
NicCo
Amministratore
Amministratore
Posts: 4739
Joined: 6 December 2007, 19:54

Re: [How to] Skype 4.1.0.20 with libxfixes3-5.0-4

Post by NicCo »

Thanks for your usefull Guide!

I forwarded this to rosa-devel

Denis Silakov has prepared a 32bit rpm
http://mirror.rosalinux.com/rosa/rosa20 ... 1.i586.rpm


In x86_64 installation, enabling temporarely the 32bit repositories, that rpm should install fine and work, so let's try soon!



bye, NicCo
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
NicCo
Amministratore
Amministratore
Posts: 4739
Joined: 6 December 2007, 19:54

Re: [How to] Skype 4.1.0.20 with libxfixes3-5.0-4

Post by NicCo »

First step:
we need to add 32bit repositories, to satisfate some compatibility 32bit libs

Code: Select all

urpmi.addmedia main_rel_32 http://abf.rosalinux.ru/downloads/rosa2012.1/repository/i586/media/main/release/
urpmi.addmedia main_upd_32 http://abf.rosalinux.ru/downloads/rosa2012.1/repository/i586/media/main/updates/
urpmi.addmedia contrib_rel_32 http://abf.rosalinux.ru/downloads/rosa2012.1/repository/i586/media/contrib/release/
urpmi.addmedia contrib_upd_32 http://abf.rosalinux.ru/downloads/rosa2012.1/repository/i586/media/contrib/updates/
urpmi.addmedia non-free_rel_32 http://abf.rosalinux.ru/downloads/rosa2012.1/repository/i586/media/non-free/release/
urpmi.addmedia non-free_upd_32 http://abf.rosalinux.ru/downloads/rosa2012.1/repository/i586/media/non-free/updates/
urpmi.addmedia restricted_rel_32 http://abf.rosalinux.ru/downloads/rosa2012.1/repository/i586/media/restricted/release/
urpmi.addmedia restricted_upd_32 http://abf.rosalinux.ru/downloads/rosa2012.1/repository/i586/media/restricted/updates/
#
[/size]

Second step:
if previous skype stop the new install, you need to uninstall the previous version, then install new skype. like below

Code: Select all

[root@localhost ~]# urpmi http://mirror.rosalinux.com/rosa/rosa2012.1/repository/i586/non-free/release/get-skype-4.1.0.20-1-rosa2012.1.i586.rpm

IT WONT INSTALL, so I must remove old Skype 4.0

[root@localhost ~]# urpme skype
I seguenti pacchetti contengono skype: 
get-skype-4.0.0.8-5-rosa2012.1.x86_64

[root@localhost ~]# urpme -a skype
rimozione di get-skype-4.0.0.8-5-rosa2012.1.x86_64
In preparazione...               #############################################################
rimozione del pacchetto get-skype-4.0.0.8-5.x86_64
writing /var/lib/rpm/installed-through-deps.list

I try to install Skype 4.1 again, and this time seems all ok!

root@localhost ~]# urpmi http://mirror.rosalinux.com/rosa/rosa2012.1/repository/i586/non-free/release/get-skype-4.1.0.20-1-rosa2012.1.i586.rpm
Per soddisfare le dipendenze, saranno installati i seguenti pacchetti:
  gnome-desktop3-3.6.2-1-rosa2012.1.x86_64
  gnome-python-2.28.1-5-rosa2012.1.x86_64
  gnome-python-bonobo-2.28.1-5-rosa2012.1.x86_64
  gnome-python-canvas-2.28.1-5-rosa2012.1.x86_64
  gnome-python-desktop-2.32.0-8-rosa2012.1.x86_64
  hunspell-1.3.2-4-rosa2012.1.x86_64
  kernel-nrjQL-desktop-3.6.7-69rosa-1-1-rosa2012.1.x86_64
  kernel-nrjQL-desktop-devel-3.6.7-69rosa-1-1-rosa2012.1.x86_64
  lib64IDL2_0-0.8.14-8-rosa2012.1.x86_64
  lib64ORBit-imodule2_0-2.14.19-7-rosa2012.1.x86_64
  lib64avfilter2-0.11.1-4-rosa2012.1.x86_64
  lib64cpufreq0-008-4-rosa2012.1.x86_64
  lib64gnome-desktop-2_17-2.32.1-8-rosa2012.1.x86_64
  lib64gnomeui2_0-2.24.5-5-rosa2012.1.x86_64
  lib64packagekit-glib14-0.7.6-7-rosa2012.1.x86_64
  lib64xulrunner14.0.1-14.0.1-0.1-rosa2012.1.x86_64
  lib64xulrunner15.0-15.0-1-rosa2012.1.x86_64
  libz1-1.2.7-3-rosa2012.1.x86_64
  pyorbit-2.24.0-7-rosa2012.1.x86_64
  python-cups-1.9.57-3-rosa2012.1.x86_64
  python-curl-7.19.0-9-rosa2012.1.x86_64
  python-liblzma-0.5.3-3-rosa2012.1.x86_64
  python-libxml2-2.9.0-1-rosa2012.1.x86_64
  python-smbc-1.0.10-3-rosa2012.1.x86_64
  smart-1.4.1-9-rosa2012.1.x86_64
  system-config-printer-libs-1.3.12-9-rosa2012.1.x86_64
  system-config-printer-udev-1.3.12-9-rosa2012.1.x86_64
  uclibc-lib64dbus-1_3-1.6.8-2-rosa2012.1.x86_64
  webkit3.0-1.10.0-4-rosa2012.1.x86_64
sono ora orfani, se desideri rimuoverli, puoi eseguire il comando "urpme --auto-orphans"
[root@localhost ~]# urpmi http://mirror.rosalinux.com/rosa/rosa2012.1/repository/i586/non-free/release/get-skype-4.1.0.20-1-rosa2012.1.i586.rpm
Per soddisfare le dipendenze, saranno installati i seguenti pacchetti:
 Pacchetto                      Versione     Release       Dist  DEpoch Arch. 
(supporto "main_rel_32")
 libalsa-plugins                1.0.26       1             rosa  2012.1 i586 (suggerito)
 libalsa-plugins-pulseaudio     1.0.26       1             rosa  2012.1 i586 (suggerito)
 libasound2                     1.0.26       2             rosa  2012.1 i586 
 libasyncns0                    0.8          4             rosa  2012.1 i586 
 libcap2                        2.22         2             rosa  2012.1 i586 
 libcelt0_2                     0.11.3       2             rosa  2012.1 i586 (suggerito)
 libdbus-1_3                    1.6.8        3             rosa  2012.1 i586 
 libdri-drivers                 9.0.1        1             rosa  2012.1 i586 (suggerito)
 libdricore1                    9.0.1        1             rosa  2012.1 i586 (suggerito)
 libdrm2                        2.4.40       1             rosa  2012.1 i586 (suggerito)
 libdrm_intel1                  2.4.40       1             rosa  2012.1 i586 (suggerito)
 libdrm_nouveau2                2.4.40       1             rosa  2012.1 i586 (suggerito)
 libdrm_radeon1                 2.4.40       1             rosa  2012.1 i586 (suggerito)
 libexpat1                      2.1.0        2             rosa  2012.1 i586 (suggerito)
 libffi5                        3.0.9        6.1           rosa  2012.1 i586 
 libflac8                       1.2.1        13            rosa  2012.1 i586 
 libfontconfig1                 2.10.1       3             rosa  2012.1 i586 
 libfreetype6                   2.4.10       4plf          plf   2012.1 i586 
 libgl1                         9.0.1        1             rosa  2012.1 i586 (suggerito)
 libglapi0                      9.0.1        1             rosa  2012.1 i586 (suggerito)
 libglib2.0_0                   2.34.3       1             rosa  2012.1 i586 
 libgobject2.0_0                2.34.3       1             rosa  2012.1 i586 
 libgsm1                        1.0.13       6             rosa  2012.1 i586 (suggerito)
 libgthread2.0_0                2.34.3       1             rosa  2012.1 i586 
 libice6                        1.0.8        3             rosa  2012.1 i586 
 libjbig1                       2.0          9             rosa  2012.1 i586 
 libjpeg8                       1.2.1        1             rosa  2012.1 i586 
 libjson0                       0.9          2             rosa  2012.1 i586 
 liblcms1                       1.19         7             rosa  2012.1 i586 
 libllvm3.1                     3.1          2             rosa  2012.1 i586 (suggerito)
 liblzma5                       5.0.4        2             rosa  2012.1 i586 
 libmng1                        1.0.10       15            rosa  2012.1 i586 
 libogg0                        1.3.0        3             rosa  2012.1 i586 
 libopenjpeg5                   1.5.1        3             rosa  2012.1 i586 (suggerito)
 libopenssl1.0.0                1.0.1c       1             rosa  2012.1 i586 
 liborc0.4_0                    0.4.16       2             rosa  2012.1 i586 (suggerito)
 libpciaccess0                  0.13.1       2             rosa  2012.1 i586 (suggerito)
 libpcre1                       8.31         4             rosa  2012.1 i586 
 libpng15                       1.5.13       1             rosa  2012.1 i586 
 libpulseaudio0                 2.1          4             rosa  2012.1 i586 
 libpulsecommon2.1              2.1          4             rosa  2012.1 i586 
 libqtcore4                     4.8.4        1             rosa  2012.1 i586 
 libqtdbus4                     4.8.4        1             rosa  2012.1 i586 
 libqtgui4                      4.8.4        1             rosa  2012.1 i586 
 libqtnetwork4                  4.8.4        1             rosa  2012.1 i586 
 libqtsvg4                      4.8.4        1             rosa  2012.1 i586 
 libqtxml4                      4.8.4        1             rosa  2012.1 i586 
 libsamplerate0                 0.1.8        3             rosa  2012.1 i586 (suggerito)
 libschroedinger1.0_0           1.0.10       6             rosa  2012.1 i586 (suggerito)
 libsm6                         1.2.1        1             rosa  2012.1 i586 
 libsndfile1                    1.0.25       5             rosa  2012.1 i586 
 libspeex1                      1.2          0.rc1.7       rosa  2012.1 i586 (suggerito)
 libtheoradec1                  1.1.1        6             rosa  2012.1 i586 (suggerito)
 libtheoraenc1                  1.1.1        6             rosa  2012.1 i586 (suggerito)
 libtiff5                       4.0.3        1             rosa  2012.1 i586 
 libv4l-wrappers                0.8.8        2             rosa  2012.1 i586 
 libv4l0                        0.8.8        2             rosa  2012.1 i586 
 libva1                         1.1.0        1             rosa  2012.1 i586 (suggerito)
 libvorbis0                     1.3.3        3             rosa  2012.1 i586 
 libvorbisenc2                  1.3.3        3             rosa  2012.1 i586 
 libvpx1                        1.1.0        1             rosa  2012.1 i586 (suggerito)
 libwrap0                       7.6          44            rosa  2012.1 i586 
 libx11_6                       1.5.0        2             rosa  2012.1 i586 
 libxau6                        1.0.7        3             rosa  2012.1 i586 
 libxavs1                       0.1.55       2             rosa  2012.1 i586 (suggerito)
 libxcb-dri2_0                  1.9          1             rosa  2012.1 i586 (suggerito)
 libxcb-glx0                    1.9          1             rosa  2012.1 i586 (suggerito)
 libxcb1                        1.9          1             rosa  2012.1 i586 
 libxdamage1                    1.1.3        4             rosa  2012.1 i586 (suggerito)
 libxdmcp6                      1.1.1        2             rosa  2012.1 i586 
 libxext6                       1.3.1        2             rosa  2012.1 i586 
 libxfixes3                     5.0          4             rosa  2012.1 i586 (suggerito)
 libxinerama1                   1.1.2        2             rosa  2012.1 i586 
 libxml2_2                      2.9.0        1             rosa  2012.1 i586 
 libxrandr2                     1.4.0        1             rosa  2012.1 i586 
 libxrender1                    0.9.7        2             rosa  2012.1 i586 
 libxscrnsaver1                 1.2.2        2             rosa  2012.1 i586 
 libxtst6                       1.2.1        2             rosa  2012.1 i586 
 libxv1                         1.0.7        2             rosa  2012.1 i586 
 libxxf86vm1                    1.1.2        1             rosa  2012.1 i586 (suggerito)
(supporto "restricted_rel_32")
 libavutil51                    1.0.1        2plf          plf   2012.1 i586 (suggerito)
 libffmpeg54                    1.0.1        2plf          plf   2012.1 i586 (suggerito)
 liblame0                       3.99.5       2             plf   2012.1 i586 (suggerito)
 libopencore-amr0               0.1.3        2             plf   2012.1 i586 (suggerito)
 libvo-aacenc0                  0.1.2        1             rosa  2012.1 i586 (suggerito)
 libvo-amrwbenc0                0.1.2        1             rosa  2012.1 i586 (suggerito)
 libx264_120                    0.120        0.20111212.2  plf   2012.1 i586 (suggerito)
 libxvid4                       1.3.2        6             plf   2012.1 i586 (suggerito)
(riga di comando)
 get-skype                      4.1.0.20     1             rosa  2012.1 i586 
Altri 111MB di spazio disco saranno utilizzati.
verranno scaricati 112MB di pacchetti.
Procedo con l'installazione di 89 pacchetti? (S/n) s
[/size]

Third step:
if you launching Skype does not starts, and in konsole typing skype you can read

Code: Select all

[piero@localhost ~]$ skype 
/usr/share/skype/skype: error while loading shared libraries: libQtWebKit.so.4: cannot open shared object file: No such file or directory
[/size]

You need to install also another missing requires library:

Code: Select all

[root@localhost ~]# urpmi libqtwebkit4
Per soddisfare le dipendenze, saranno installati i seguenti pacchetti:
 Pacchetto                      Versione     Release       Dist  DEpoch Arch. 
(supporto "main_rel_32")
 libqtwebkit4                   4.8.4        1             rosa  2012.1 i586 
 libsqlite3_0                   3.7.14.1     1             rosa  2012.1 i586 
Altri 23MB di spazio disco saranno utilizzati.
verranno scaricati 23MB di pacchetti.
Procedo con l'installazione di 2 pacchetti? (S/n) s
[/size]

Now skype should work also to You, like now is working fine to me!

Let me know...
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
NicCo
Amministratore
Amministratore
Posts: 4739
Joined: 6 December 2007, 19:54

Re: [How to] Skype 4.1.0.20 with libxfixes3-5.0-4

Post by NicCo »

Denis Silakov wrote:Ah, ok, I've added libqtwebkit4 requirement and moved back the Obsoletes tag (dropped it unexpectedly with the previous commit...)
now SKype has been updated to release -2, so the file now is

Code: Select all

urpmi http://mirror.rosalinux.com/rosa/rosa2012.1/repository/i586/non-free/release/get-skype-4.1.0.20-1-rosa2012.1.i586.rpm
you need to change the link in the upper msg from 4.1.0.20-1 to 4.1.0.20-2



Mandrva 2010?
Trying in Mandriva 2010.2 x86_64, to update from skype 4.0 to 4.1
first I had to download the rpm into my local folder /home/utente/Scaricati, then I'm trying

Code: Select all

rpm -Uvh /home/utente/Scaricati/get-skype-4.1.0.20-2-rosa2012.1.i586.rpm --nodeps --nosignature
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
ninarello19
Utente
Utente
Posts: 222
Joined: 4 March 2009, 15:56
OpenMandriva: 2010.2
Kernel: 2.6.38.2-desktop-nrj
Desktop: KDE 4.5.5

Re: [How to] Skype 4.1.0.20 with libxfixes3-5.0-4

Post by ninarello19 »

Finalmente risultano convivere TeamWiewer e Skype
Sono riuscito ad installare Skype 4.1.0.20 seguendo le istruzioni ma ho messo quello di Suse perchè quella di Rosa mi dava errore

Code: Select all

Skype-4.1.0.20-suse.i586.rpm
Tutto OK
Sono riuscito ad installare anche TeamWiewer versione 8.0.16485 anche questo di Suse

Code: Select all

Teamviewer_linux_suse32.rpm
Tutto OK i due software funzionano perfettamente e convivono.
Bravo Nicco
Ma io come si vede ho dovuto cambiare qualcosa
Risultato tutto funziona benissimo
ninarello 19
ninarello19
=========
RosaDesktop.Fresh 2012.1 R1 - arch. x86_64 - KDE 4.10.4 MIB - Kernel 3.10.15-nrjQL-desktop-69rosa #1 SMP PREEMPT
O.S. alternativi su VMware workstation 10.0.0>>> Ubuntu, Windows XP Pro, Windows Seven e Mac come Macchine VIrtuali

User avatar
viking
Utente junior
Utente junior
Posts: 80
Joined: 26 July 2012, 18:43
ROSA: Desktop Fresh R7 x64
OpenMandriva: -
Kernel: 4.1.18-nrjQL-desktop
Desktop: KDE Plasma 5.5.4
country: Serbia

Re: [How to] Skype 4.1.0.20 with libxfixes3-5.0-4

Post by viking »

I just tested latest test package on Rosa 2012.0 x64 and it works just fine! :D

I always have Main_32_release, Main_32_updates and Main_32_backports repositories enabled on x64, and I also had some 32bit QT libraries already installed, so I guess I had to install less packages then other users.

I will also test this on Rosa 2012.1 x64 little later (when I get access to another laptop) and let you know the results.

I will copy only most important parts from console.

Code: Select all

[viking@delta ~]$ uname -a
Linux delta 3.4.11-nrj-netbook-1rosa.lts #1 SMP PREEMPT Sun Sep 16 02:16:36 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Code: Select all

[viking@delta ~]$ sudo urpme skype -a
removing get-skype-4.0.0.8-3-rosa.lts2012.0.x86_64
Preparing...                     #############################################
removing package get-skype-4.0.0.8-3.x86_64

Code: Select all

[viking@delta ~]$ sudo urpmi http://mirror.rosalinux.com/rosa/rosa2012.1/repository/i586/non-free/release/get-skype-4.1.0.20-2-rosa2012.1.i586.rpm
To satisfy dependencies, the following packages are going to be installed:
 Package                        Version      Release       Dist  DEpoch Arch 
(medium "Main_32_release")
 libxscrnsaver1                 1.2.1        5             rosa> 2012.0 i586 
 libxv1                         1.0.6        3             rosa> 2012.0 i586 
(medium "Main_32_updates")
 libv4l-wrappers                0.8.5        3             rosa> 2012.0 i586 
 libv4l0                        0.8.5        3             rosa> 2012.0 i586 
(command line)
 get-skype                      4.1.0.20     2             rosa  2012.1 i586 
286KB of additional disk space will be used.
323KB of packages will be retrieved.
Proceed with the installation of the 5 packages? (Y/n) y

Code: Select all

[viking@delta ~]$ skype

[viking@delta ~]$ 
As you can see it doesn't give any warring.

User avatar
viking
Utente junior
Utente junior
Posts: 80
Joined: 26 July 2012, 18:43
ROSA: Desktop Fresh R7 x64
OpenMandriva: -
Kernel: 4.1.18-nrjQL-desktop
Desktop: KDE Plasma 5.5.4
country: Serbia

Re: [How to] Skype 4.1.0.20 with libxfixes3-5.0-4

Post by viking »

Testing get-skype-4.1.0.20 on clean install of Rosa 2012.1 x64 RC.

I use those mirrors for now (I usually use other mirrors that are much faster for me, but they do not have 2012.1 repositories yet):

Code: Select all

sudo urpmi.removemedia -a
sudo urpmi.addmedia Main_64_release http://mirror.yandex.ru/rosa/rosa2012.1/repository/x86_64/media/main/release/
sudo urpmi.addmedia --update Main_64_updates http://mirror.yandex.ru/rosa/rosa2012.1/repository/x86_64/media/main/updates/
sudo urpmi.addmedia Contrib_64_release http://mirror.yandex.ru/rosa/rosa2012.1/repository/x86_64/media/contrib/release/
sudo urpmi.addmedia --update Contrib_64_updates http://mirror.yandex.ru/rosa/rosa2012.1/repository/x86_64/media/contrib/updates/
sudo urpmi.addmedia NonFree_64_release http://mirror.yandex.ru/rosa/rosa2012.1/repository/x86_64/media/non-free/release/
sudo urpmi.addmedia --update NonFree_64_updates http://mirror.yandex.ru/rosa/rosa2012.1/repository/x86_64/media/non-free/updates/
sudo urpmi.addmedia Restricted_64_release http://mirror.yandex.ru/rosa/rosa2012.1/repository/x86_64/media/restricted/release/
sudo urpmi.addmedia --update Restricted_64_updates http://mirror.yandex.ru/rosa/rosa2012.1/repository/x86_64/media/restricted/updates/
sudo urpmi.addmedia --update MIB-basic_64 http://mib.pianetalinux.org/MIB/rosa2012.1/64/basic/
sudo urpmi.addmedia --raw --update MIB-experts_64 http://mib.pianetalinux.org/MIB/rosa2012.1/64/experts/
#
sudo urpmi.addmedia Main_32_release http://mirror.yandex.ru/rosa/rosa2012.1/repository/i586/media/main/release/
sudo urpmi.addmedia --update Main_32_updates http://mirror.yandex.ru/rosa/rosa2012.1/repository/i586/media/main/updates/
sudo urpmi.addmedia --raw Contrib_32_release http://mirror.yandex.ru/rosa/rosa2012.1/repository/i586/media/contrib/release/
sudo urpmi.addmedia --raw --update Contrib_32_updates http://mirror.yandex.ru/rosa/rosa2012.1/repository/i586/media/contrib/updates/
sudo urpmi.addmedia --raw NonFree_32_release http://mirror.yandex.ru/rosa/rosa2012.1/repository/i586/media/non-free/release/
sudo urpmi.addmedia --raw --update NonFree_32_updates http://mirror.yandex.ru/rosa/rosa2012.1/repository/i586/media/non-free/updates/
sudo urpmi.addmedia --raw Restricted_32_release http://mirror.yandex.ru/rosa/rosa2012.1/repository/i586/media/restricted/release/
sudo urpmi.addmedia --raw --update Restricted_32_updates http://mirror.yandex.ru/rosa/rosa2012.1/repository/i586/media/restricted/updates/
sudo urpmi.addmedia --raw --update MIB-basic_32 http://mib.pianetalinux.org/MIB/rosa2012.1/32/basic/
#
As you can see only two 32bit repositories are enabled Main_32 and Main_32_updates, all others are added but disabled.

I updated everything first.

Code: Select all

[viking@tatooine ~]$ sudo urpmi --auto-update --auto
Let's check what I use.

Code: Select all

[viking@tatooine ~]$ cat /etc/release 
ROSA Desktop release 2012.1 (Desktop) for x86_64
Let's test the package.

Code: Select all

[viking@tatooine ~]$ sudo urpmi http://mirror.rosalinux.com/rosa/rosa2012.1/repository/i586/non-free/release/get-skype-4.1.0.20-2-rosa2012.1.i586.rpm
To satisfy dependencies, the following packages are going to be installed:
 Package                        Version      Release       Dist  DEpoch Arch 
(medium "Main_64_release")
 libgcc1                        4.7.3_2012.> 3.1           rosa  2012.1 x86_64 
 libstdc++6                     4.7.3_2012.> 3.1           rosa  2012.1 x86_64 
 libz1                          1.2.7        3             rosa  2012.1 x86_64 
(medium "Main_32_release")
 libalsa-plugins                1.0.26       1             rosa  2012.1 i586 (suggested)
 libalsa-plugins-pulseaudio     1.0.26       1             rosa  2012.1 i586 (suggested)
 libasound2                     1.0.26       2             rosa  2012.1 i586 
 libasyncns0                    0.8          4             rosa  2012.1 i586 
 libavutil51                    1.0.1        2             rosa  2012.1 i586 (suggested)
 libcap2                        2.22         2             rosa  2012.1 i586 
 libcelt0_2                     0.11.3       2             rosa  2012.1 i586 (suggested)
 libdbus-1_3                    1.6.8        3             rosa  2012.1 i586 
 libdri-drivers                 9.0.1        1             rosa  2012.1 i586 (suggested)
 libdricore1                    9.0.1        1             rosa  2012.1 i586 (suggested)
 libdrm2                        2.4.40       1             rosa  2012.1 i586 (suggested)
 libdrm_intel1                  2.4.40       1             rosa  2012.1 i586 (suggested)
 libdrm_nouveau2                2.4.40       1             rosa  2012.1 i586 (suggested)
 libdrm_radeon1                 2.4.40       1             rosa  2012.1 i586 (suggested)
 libexpat1                      2.1.0        2             rosa  2012.1 i586 (suggested)
 libffi5                        3.0.9        6.1           rosa  2012.1 i586 
 libffmpeg54                    1.0.1        2             rosa  2012.1 i586 (suggested)                                                                        
 libflac8                       1.2.1        13            rosa  2012.1 i586    
 libfontconfig1                 2.10.1       3             rosa  2012.1 i586    
 libfreetype6                   2.4.10       4plf          plf   2012.1 i586    
 libgl1                         9.0.1        1             rosa  2012.1 i586 (suggested)
 libglapi0                      9.0.1        1             rosa  2012.1 i586 (suggested)
 libglib2.0_0                   2.34.3       1             rosa  2012.1 i586 
 libgobject2.0_0                2.34.3       1             rosa  2012.1 i586 
 libgsm1                        1.0.13       6             rosa  2012.1 i586 (suggested)
 libgthread2.0_0                2.34.3       1             rosa  2012.1 i586 
 libice6                        1.0.8        3             rosa  2012.1 i586 
 libjbig1                       2.0          9             rosa  2012.1 i586 
 libjpeg8                       1.2.1        1             rosa  2012.1 i586 
 libjson0                       0.9          2             rosa  2012.1 i586 
 liblcms1                       1.19         7             rosa  2012.1 i586 
 libllvm3.1                     3.1          2             rosa  2012.1 i586 (suggested)
 liblzma5                       5.0.4        2             rosa  2012.1 i586 
 libmng1                        1.0.10       15            rosa  2012.1 i586 
 libogg0                        1.3.0        3             rosa  2012.1 i586 
 libopenjpeg5                   1.5.1        3             rosa  2012.1 i586 (suggested)
 libopenssl1.0.0                1.0.1c       1             rosa  2012.1 i586 
 liborc0.4_0                    0.4.16       2             rosa  2012.1 i586 (suggested)
 libpciaccess0                  0.13.1       2             rosa  2012.1 i586 (suggested)
 libpcre1                       8.31         4             rosa  2012.1 i586 
 libpng15                       1.5.13       1             rosa  2012.1 i586 
 libpulseaudio0                 2.1          4             rosa  2012.1 i586 
 libpulsecommon2.1              2.1          4             rosa  2012.1 i586 
 libqtcore4                     4.8.4        1             rosa  2012.1 i586 
 libqtdbus4                     4.8.4        1             rosa  2012.1 i586 
 libqtgui4                      4.8.4        1             rosa  2012.1 i586 
 libqtnetwork4                  4.8.4        1             rosa  2012.1 i586 
 libqtsvg4                      4.8.4        1             rosa  2012.1 i586 
 libqtwebkit4                   4.8.4        1             rosa  2012.1 i586 
 libqtxml4                      4.8.4        1             rosa  2012.1 i586 
 libsamplerate0                 0.1.8        3             rosa  2012.1 i586 (suggested)
 libschroedinger1.0_0           1.0.10       6             rosa  2012.1 i586 (suggested)
 libsm6                         1.2.1        1             rosa  2012.1 i586 
 libsndfile1                    1.0.25       5             rosa  2012.1 i586 
 libspeex1                      1.2          0.rc1.7       rosa  2012.1 i586 (suggested)
 libsqlite3_0                   3.7.14.1     1             rosa  2012.1 i586 
 libtheoradec1                  1.1.1        6             rosa  2012.1 i586 (suggested)
 libtheoraenc1                  1.1.1        6             rosa  2012.1 i586 (suggested)
 libtiff5                       4.0.3        1             rosa  2012.1 i586 
 libv4l-wrappers                0.8.8        2             rosa  2012.1 i586 
 libv4l0                        0.8.8        2             rosa  2012.1 i586 
 libva1                         1.1.0        1             rosa  2012.1 i586 (suggested)
 libvorbis0                     1.3.3        3             rosa  2012.1 i586 
 libvorbisenc2                  1.3.3        3             rosa  2012.1 i586 
 libvpx1                        1.1.0        1             rosa  2012.1 i586 (suggested)
 libwrap0                       7.6          44            rosa  2012.1 i586 
 libx11_6                       1.5.0        2             rosa  2012.1 i586 
 libxau6                        1.0.7        3             rosa  2012.1 i586 
 libxavs1                       0.1.55       2             rosa  2012.1 i586 (suggested)
 libxcb-dri2_0                  1.9          1             rosa  2012.1 i586 (suggested)
 libxcb-glx0                    1.9          1             rosa  2012.1 i586 (suggested)
 libxcb1                        1.9          1             rosa  2012.1 i586 
 libxdamage1                    1.1.3        4             rosa  2012.1 i586 (suggested)
 libxdmcp6                      1.1.1        2             rosa  2012.1 i586 
 libxext6                       1.3.1        2             rosa  2012.1 i586 
 libxfixes3                     5.0          4             rosa  2012.1 i586 (suggested)
 libxinerama1                   1.1.2        2             rosa  2012.1 i586 
 libxml2_2                      2.9.0        1             rosa  2012.1 i586 
 libxrandr2                     1.4.0        1             rosa  2012.1 i586 
 libxrender1                    0.9.7        2             rosa  2012.1 i586 
 libxscrnsaver1                 1.2.2        2             rosa  2012.1 i586 
 libxtst6                       1.2.1        2             rosa  2012.1 i586 
 libxv1                         1.0.7        2             rosa  2012.1 i586 
 libxxf86vm1                    1.1.2        1             rosa  2012.1 i586 (suggested)
(command line)
 get-skype                      4.1.0.20     2             rosa  2012.1 i586 
133MB of additional disk space will be used.
134MB of packages will be retrieved.
Proceed with the installation of the 88 packages? (Y/n) y
Installs just fine.

Let's start skype.

Code: Select all

[viking@tatooine ~]$ skype
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.

[viking@tatooine ~]$ 
There is just font config error, that is unrelated to skype.

Skype works fine, but there is a dark blue background and black text when you select some contact. Here is the screenshot.

EDIT:

In 2012.0 this can be solved very easy by adding few packages in order to make all 32bit apps look exactly the same as 64bit apps.

For some reason after installing those packages in 2012.1 there is no libpixmap.so anywhere. I copied the one from another Linux and everything work same as in 2012.0, but I need to find appropriate package and to install libpixmap.so properly.

I will update this last step and remove this note when I find appropriate package which contain this lib. I will also post the pic how this look after fix.

Post Reply