[How to] Install Skype 4.1 in 64bit ROSA Desktop.Fresh 2012

Guides, tutorials & docs
Post Reply
User avatar
NicCo
Amministratore
Amministratore
Posts: 4739
Joined: 6 December 2007, 19:54

[How to] Install Skype 4.1 in 64bit ROSA Desktop.Fresh 2012

Post by NicCo »

When we use a 64bit distro, sometimes we need to install some apps that are not available in 64bit but only in 32:
then we have two possibilities:
1> renounce to those apps finding other similar per functions
2> add 32bit repositories to install 32bit apps and related libs

If you can't easily renounce to some of these apps, for example, if you need to install skype, wine, teamviewer
that are programs only available for 32bit, then exists a solution

You can solve using the chance 2>, and below the needed command strings to add all the 32bit repositories
I suggest to add these repositories, install apps that you need, then you can disable or remove the 32bit repos

From a konsole / terminal - login as root, then execute:

Code: Select all

urpmi.addmedia main32 http://mirror.rosalab.ru/rosa2012.1/repository/i586/media/main/release/
urpmi.addmedia --update main32_updates http://mirror.rosalab.ru/rosa2012.1/repository/i586/media/main/updates/
urpmi.addmedia contrib32 http://mirror.rosalab.ru/rosa2012.1/repository/i586/media/contrib/release/
urpmi.addmedia --update contrib32_updates http://mirror.rosalab.ru/rosa2012.1/repository/i586/media/contrib/updates/
urpmi.addmedia non-free32 http://mirror.rosalab.ru/rosa2012.1/repository/i586/media/non-free/release/
urpmi.addmedia --update non-free32_updates http://mirror.rosalab.ru/rosa2012.1/repository/i586/media/non-free/updates/
urpmi.addmedia restricted32 http://mirror.rosalab.ru/rosa2012.1/repository/i586/media/restricted/release/
urpmi.addmedia --update restricted32_updates http://mirror.rosalab.ru/rosa2012.1/repository/i586/media/restricted/updates/
#

If you have already installed Skype, you may need to uninstall the old version, as is shown in the command below

Code: Select all

urpme -a skype ; urpmi skype

If when you try installing Skype, it proposes you an old version, like in the example below (4.0.x)
you may need to specify more precisely the version number of Skype

Code: Select all

[root@localhost ~]# urpme -a skype ; urpmi skype-4.1    
Per soddisfare le dipendenze, saranno installati i seguenti pacchetti:
 Pacchetto                      Versione     Release       Dist  DEpoch Arch. 
(supporto "main (Desktop2012.1-1)")
 libz1                          1.2.7        3             rosa  2012.1 x86_64 
(supporto "non-free (Desktop2012.1-5)")
 get-skype                      4.0.0.8      5             rosa  2012.1 x86_64 
Altri 29MB di spazio disco saranno utilizzati.
verranno scaricati 30MB di pacchetti.
Procedo con l'installazione di 2 pacchetti? (S/n) N
Finally you should succeed to install new Skype (now is version 4.1.0.20)
You may need to specify version number (4.1.x), to override the old versioned installation
if you have already installed Skype, you may need to uninstall the old version, as is shown

Code: Select all

[root@localhost ~]# urpme -a skype ; urpmi skype-4.1
Per soddisfare le dipendenze, saranno installati i seguenti pacchetti:
 Pacchetto                      Versione     Release       Dist  DEpoch Arch. 
(supporto "main (Desktop2012.1-1)")
 libgcc1                        4.7.3_2012.> 3.1           rosa  2012.1 x86_64 
 libstdc++6                     4.7.3_2012.> 3.1           rosa  2012.1 x86_64 
 libz1                          1.2.7        3             rosa  2012.1 x86_64 
(supporto "main32")
 libalsa-plugins                1.0.26       1             rosa  2012.1 i586 (suggerito)
 libalsa-plugins-pulseaudio     1.0.26       1             rosa  2012.1 i586 (suggerito)
 libasound2                     1.0.26       2             rosa  2012.1 i586 
 libasyncns0                    0.8          4             rosa  2012.1 i586 
 libcap2                        2.22         2             rosa  2012.1 i586 
 libcelt0_2                     0.11.3       2             rosa  2012.1 i586 (suggerito)
 libdbus-1_3                    1.6.8        3             rosa  2012.1 i586 
 libdri-drivers                 9.0.1        1             rosa  2012.1 i586 (suggerito)
 libdricore1                    9.0.1        1             rosa  2012.1 i586 (suggerito)
 libdrm2                        2.4.40       1             rosa  2012.1 i586 (suggerito)
 libdrm_intel1                  2.4.40       1             rosa  2012.1 i586 (suggerito)
 libdrm_nouveau2                2.4.40       1             rosa  2012.1 i586 (suggerito)
 libdrm_radeon1                 2.4.40       1             rosa  2012.1 i586 (suggerito)
 libexpat1                      2.1.0        2             rosa  2012.1 i586 (suggerito)
 libffi5                        3.0.9        6.1           rosa  2012.1 i586 
 libflac8                       1.2.1        13            rosa  2012.1 i586 
 libfontconfig1                 2.10.1       3             rosa  2012.1 i586 
 libfreetype6                   2.4.10       4plf          plf   2012.1 i586 
 libgl1                         9.0.1        1             rosa  2012.1 i586 (suggerito)
 libglapi0                      9.0.1        1             rosa  2012.1 i586 (suggerito)
 libglib2.0_0                   2.34.3       1             rosa  2012.1 i586 
 libgobject2.0_0                2.34.3       1             rosa  2012.1 i586 
 libgsm1                        1.0.13       6             rosa  2012.1 i586 (suggerito)
 libgthread2.0_0                2.34.3       1             rosa  2012.1 i586 
 libice6                        1.0.8        3             rosa  2012.1 i586 
 libjbig1                       2.0          9             rosa  2012.1 i586 
 libjpeg8                       1.2.1        1             rosa  2012.1 i586 
 libjson0                       0.9          2             rosa  2012.1 i586 
 liblcms1                       1.19         7             rosa  2012.1 i586 
 libllvm3.1                     3.1          2             rosa  2012.1 i586 (suggerito)
 liblzma5                       5.0.4        2             rosa  2012.1 i586 
 libmng1                        1.0.10       15            rosa  2012.1 i586 
 libogg0                        1.3.0        3             rosa  2012.1 i586 
 libopenjpeg5                   1.5.1        3             rosa  2012.1 i586 (suggerito)
 libopenssl1.0.0                1.0.1c       1             rosa  2012.1 i586 
 liborc0.4_0                    0.4.16       2             rosa  2012.1 i586 (suggerito)
 libpciaccess0                  0.13.1       2             rosa  2012.1 i586 (suggerito)
 libpcre1                       8.31         4             rosa  2012.1 i586 
 libpng15                       1.5.13       1             rosa  2012.1 i586 
 libpulseaudio0                 2.1          4             rosa  2012.1 i586 
 libpulsecommon2.1              2.1          4             rosa  2012.1 i586 
 libqtcore4                     4.8.4        1             rosa  2012.1 i586 
 libqtdbus4                     4.8.4        1             rosa  2012.1 i586 
 libqtgui4                      4.8.4        1             rosa  2012.1 i586 
 libqtnetwork4                  4.8.4        1             rosa  2012.1 i586 
 libqtsvg4                      4.8.4        1             rosa  2012.1 i586 
 libqtwebkit4                   4.8.4        1             rosa  2012.1 i586 
 libqtxml4                      4.8.4        1             rosa  2012.1 i586 
 libsamplerate0                 0.1.8        3             rosa  2012.1 i586 (suggerito)
 libschroedinger1.0_0           1.0.10       6             rosa  2012.1 i586 (suggerito)
 libsm6                         1.2.1        1             rosa  2012.1 i586 
 libsndfile1                    1.0.25       5             rosa  2012.1 i586 
 libspeex1                      1.2          0.rc1.7       rosa  2012.1 i586 (suggerito)
 libsqlite3_0                   3.7.14.1     1             rosa  2012.1 i586 
 libtheoradec1                  1.1.1        6             rosa  2012.1 i586 (suggerito)
 libtheoraenc1                  1.1.1        6             rosa  2012.1 i586 (suggerito)
 libtiff5                       4.0.3        1             rosa  2012.1 i586 
 libv4l-wrappers                0.8.8        2             rosa  2012.1 i586 
 libv4l0                        0.8.8        2             rosa  2012.1 i586 
 libva1                         1.1.0        1             rosa  2012.1 i586 (suggerito)
 libvorbis0                     1.3.3        3             rosa  2012.1 i586 
 libvorbisenc2                  1.3.3        3             rosa  2012.1 i586 
 libvpx1                        1.1.0        1             rosa  2012.1 i586 (suggerito)
 libwrap0                       7.6          44            rosa  2012.1 i586 
 libx11_6                       1.5.0        2             rosa  2012.1 i586 
 libxau6                        1.0.7        3             rosa  2012.1 i586 
 libxavs1                       0.1.55       2             rosa  2012.1 i586 (suggerito)
 libxcb-dri2_0                  1.9          1             rosa  2012.1 i586 (suggerito)
 libxcb-glx0                    1.9          1             rosa  2012.1 i586 (suggerito)
 libxcb1                        1.9          1             rosa  2012.1 i586 
 libxdamage1                    1.1.3        4             rosa  2012.1 i586 (suggerito)
 libxdmcp6                      1.1.1        2             rosa  2012.1 i586 
 libxext6                       1.3.1        2             rosa  2012.1 i586 
 libxfixes3                     5.0          4             rosa  2012.1 i586 (suggerito)
 libxinerama1                   1.1.2        2             rosa  2012.1 i586 
 libxml2_2                      2.9.0        1             rosa  2012.1 i586 
 libxrandr2                     1.4.0        1             rosa  2012.1 i586 
 libxrender1                    0.9.7        2             rosa  2012.1 i586 
 libxscrnsaver1                 1.2.2        2             rosa  2012.1 i586 
 libxtst6                       1.2.1        2             rosa  2012.1 i586 
 libxv1                         1.0.7        2             rosa  2012.1 i586 
 libxxf86vm1                    1.1.2        1             rosa  2012.1 i586 (suggerito)
(supporto "non-free32")
 get-skype                      4.1.0.20     2             rosa  2012.1 i586 
(supporto "restricted32")
 libavutil51                    1.0.1        2plf          plf   2012.1 i586 (suggerito)
 libffmpeg54                    1.0.1        2plf          plf   2012.1 i586 (suggerito)
 liblame0                       3.99.5       2             plf   2012.1 i586 (suggerito)
 libopencore-amr0               0.1.3        2             plf   2012.1 i586 (suggerito)
 libvo-aacenc0                  0.1.2        1             rosa  2012.1 i586 (suggerito)
 libvo-amrwbenc0                0.1.2        1             rosa  2012.1 i586 (suggerito)
 libx264_120                    0.120        0.20111212.2  plf   2012.1 i586 (suggerito)
 libxvid4                       1.3.2        6             plf   2012.1 i586 (suggerito)
Altri 136MB di spazio disco saranno utilizzati.
verranno scaricati 136MB di pacchetti.
Procedo con l'installazione di 94 pacchetti? (S/n) S

and now: Good SKYPING!

bye, NicCo
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
rugyada
Amministratore
Amministratore
Posts: 1542
Joined: 14 July 2008, 22:58
ROSA: ROSA.Fresh R8 64bit
OpenMandriva: OMLx 4.1 64bit
Kernel: kernel-relea current
Desktop: KDE tutta la vita
country: Italy

Re: [How to] Install Skype 4.1 in 64bit ROSA Desktop.Fresh 2

Post by rugyada »

Eseguita la guida adesso. Tutto ok.

E' veramente a prova di tonto :P
Grazie.
Image
ciauu ciauu, ruru

MIB... e le stelle stanno a guardare.
«I grandi spiriti hanno sempre incontrato violenta opposizione da parte delle menti mediocri.»
(Albert Einstein)

User avatar
Alexander83
Utente
Utente
Posts: 248
Joined: 10 April 2012, 14:50
ROSA: -
OpenMandriva: -
Kernel: -
Desktop: Kde
country: Italy

Re: [How to] Install Skype 4.1 in 64bit ROSA Desktop.Fresh 2

Post by Alexander83 »

Guida utilissima, grazie NicCo! ;)
Desktop A: Kubuntu 32bit
Desktop B: Kubuntu 64bit
Notebook Asus X53SD-SX191V: Kubuntu 64bit
Linux 4 Ever

User avatar
Ghost
Utente
Utente
Posts: 126
Joined: 7 December 2007, 14:44
OpenMandriva: 2011.0 x86_64
Kernel: 3.0.3-desktop-nrj.69
Desktop: Kde 4.6.5
country: Italia
Contact:

Re: [How to] Install Skype 4.1 in 64bit ROSA Desktop.Fresh 2

Post by Ghost »

Ottima guida per installare skype, tuttavia l'audio per me è pessimo. Ci sta qualche parametro che dovrei dare in input?
Mandriva 2010 x86_64

User avatar
NicCo
Amministratore
Amministratore
Posts: 4739
Joined: 6 December 2007, 19:54

Re: [How to] Install Skype 4.1 in 64bit ROSA Desktop.Fresh 2

Post by NicCo »

Ghost wrote:Ottima guida per installare skype, tuttavia l'audio per me è pessimo. Ci sta qualche parametro che dovrei dare in input?
1>Innanzitutto devi provare a regolare i volumi attraverso la tool di Pulse, che puoi avviare con

Code: Select all

pavucontrol
2>Leggi gli Errata, c'è un suggerimento importante da provare nei casi di audio pessimo con Skype
http://wiki.rosalab.ru/en/index.php/Err ... sktop_2012
Cracking sound in Skype

On some hardware configurations, one can get a crackling sound in Skype. To solve this issue, open file

Code: Select all

/etc/pulse/default.pa
with root privileges and find the following line:

Code: Select all

load-module module-udev-detect 
replace it with:

Code: Select all

load-module module-udev-detect tsched=0
Save changes and reboot. For more information, see #288
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

Post Reply