Page 1 of 1

Installare KDE 4.2.1 su Mandriva 2009.0 i586 & X86_64

Posted: 5 March 2009, 14:53
by NicCo
Guida scritta inizialmente da Tony Evo
Ultime modifiche e integrazioni: NicCo e rugyada


Ultimo aggiornamento: 10 mar 2009.0: ore 11:15
Per la x86_64, occorre aggiungere anche il repository di kde4.2.1 i586, per risolvere dipendenze con le librerie di compatibilità a 32bit: Questo risolve il problema di alcuni programmi segnalati altrimenti non piu funzionati, come Skype.




Come installare anche sulla nostra amata Mandriva 2009.0 il nuovissimo KDE 4.2.1 con le QT 4.5!

E' semplicissimo basta aggiungere i supporti adatti alla propria architettura, che sono due:
1>Aprite una Konsole o Terminale, e loggatevi come Root o Amministratore.
2>Cliccate su "Seleziona tutto" e copiate il testo sulla konsole con il Copia/Incolla.
3>Premete ENTER o INVIO sulla konsole alla fine di ogni gruppo di stringhe inserito.

Parte riguardante unicamente Mandriva 2009.0 - 32bit - i586/i686

Code: Select all

urpmi.addmedia --update kde4.2.1-i586 http://mi.mirror.garr.it/mirrors/KDE/stable/4.2.1/Mandriva/2009.0/RPMS/i586/ with media_info/synthesis.hdlist.cz

urpmi.addmedia --update kde4.2.1-noarch http://mi.mirror.garr.it/mirrors/KDE/stable/4.2.1/Mandriva/2009.0/RPMS/noarch with media_info/synthesis.hdlist.cz
Premere adesso il tasto INVIO (o ENTER)

Parte riguardante unicamente Mandriva 2009.0 - 64bit - x86_64

Code: Select all

urpmi.addmedia --update kde4.2.1-x86_64 http://mi.mirror.garr.it/mirrors/KDE/stable/4.2.1/Mandriva/2009.0/RPMS/x86_64/ with media_info/synthesis.hdlist.cz

urpmi.addmedia --update kde4.2.1-noarch http://mi.mirror.garr.it/mirrors/KDE/stable/4.2.1/Mandriva/2009.0/RPMS/noarch with media_info/synthesis.hdlist.cz

urpmi.addmedia --update kde4.2.1-i586 http://mi.mirror.garr.it/mirrors/KDE/stable/4.2.1/Mandriva/2009.0/RPMS/i586/ with media_info/synthesis.hdlist.cz
Premere adesso il tasto INVIO (o ENTER)



Ecco adesso la parte di procedura in comune valida sia 32 che 64bit:
Una volta aggiunto,sempre da root in una konsole,digitate questo

Code: Select all

urpmi --auto-update --auto-select --keep
Premere adesso il tasto INVIO (o ENTER)

Il sistema vi chiedera' prima questo:
Per soddisfare le dipendenze di "libicalss.so.0" serve uno dei seguenti pacchetti:
1- libical0-0.31-2mdv2009.0.i586: Files for developing applications that use libical (da installare)
2- libicalss0-0.43-1mdv2009.0.i586: Files for developing applications that use libical (da installare)
Quale scegli? (1-2) 2[/code]

Scegliete dunque l'opzione nr. 2 ovvero libicalss0-0.43-1

Poi Il sistema vi chiedera' questo:
Per soddisfare le dipendenze di "qt4-database-plugin-mysql" serve uno dei seguenti pacchetti:
1- qt4-database-plugin-mysql-lib-4.4.3-1mdv2009.0.i586: Database plugin for mysql Qt support (da installare)
2- qt4-database-plugin-mysql-4.5.0-1mdv2009.0.i586: Database plugin for mysql Qt support (da installare)
Quale scegli? (1-2) 2

Scegliete dunque l'opzione nr. 2 ovvero plugin-mysql-4.5.0

Se il sistema vi comunica che alcuni pacchetti non possono essere installati, come nell'esempio:
Alcuni dei pacchetti richiesti non possono essere installati:
kde4-audiocd-4.2.1-1mdv2009.0.i586 (perché non è soddisfatto kdemultimedia4-core[== 3:4.2.1])
kdemultimedia4-core-4.2.1-1mdv2009.0.i586 (per conservare tellico-1.3.4-2mdv2009.0.i586)
kdepim4-4.2.1-1mdv2009.0.i586 (per conservare libkdepim2-common-3.5.10-1mdv2009.0.i586)
kdepim4-core-4.2.1-1mdv2009.0.i586 (per conservare tellico-1.3.4-2mdv2009.0.i586)
kleopatra-4.1.2-2mdv2009.0.i586 (per conservare kleopatra-4.1.3-2.1mdv2009.0.i586)
kscd-4.1.2-1mdv2009.0.i586 (per conservare kscd-4.1.3-1.1mdv2009.0.i586)
kscd-4.2.1-1mdv2009.0.i586 (per conservare tellico-1.3.4-2mdv2009.0.i586)
libgwsoap4-4.2.1-1mdv2009.0.i586 (per conservare libkdepim2-common-3.5.10-1mdv2009.0.i586)
miro-2.0.1-1.1mib.plf2009.0.i686 (perché non è soddisfatto libxulrunner1.9[== 1.9.0.5])
Continuo comunque l'istallazione? (S/n) s

Rispondete di SI con il tasto S e andate avanti lo stesso

Ripetere una seconda volta:
A volte vengono installati dei files, che non sono stati installati con il primo aggiornamento, e cosi':

Code: Select all

urpmi --auto-select --keep
Premere adesso il tasto INVIO (o ENTER)

In questa fase, potrebbe accadere che una parte dei files rimanga ancora bloccata come in ostaggio, perche' qualche programma di importanza minore e che magari non usate mai, blocca qualche dipendenza.

Mi e' accaduto per esempio, che il programma tellico, bloccasse circa 60 rpm, per cui ho prima provveduto a rimuoverlo:
urpme tellico
poi ho rieseguito nuovamente

Code: Select all

urpmi --auto-select --keep
Premere adesso il tasto INVIO (o ENTER)

alla fine ho potuto anche reinstallare il programma precedentemente disinstallato
urpmi tellico
senza alcun problema, e tutte le tessere del mosaico sono cosi' andate al loro posto!



Per il pacchetto linguistico italiano inserire la stringa:

Code: Select all

urpmi kde4-l10n-it
Premere adesso il tasto INVIO (o ENTER)



Image
1> Se nella cartella nascosta /home/<utente>/.kde4 avete dati importanti come: configurazione di programmi, email, calendario, appuntamenti, playlist di amarok, eccetera, fate un backup della cartella rinominandola in " kde4_old ", in modo da poter successivamente recuperare i dati esistenti.

2> Cancellare adesso la cartella nascosta /home/<utente>/.kde4 che contiene le configurazioni del precedente Kde 4 per far sì che il nuovo ambiente possa ben configurarsi con nuovi i parametri di default, senza che vengano usati vecchi parametri che nel nuovo sistema potrebbero anche causare dei piccoli ma fastidiosi problemi.

3> Se alla fine, viene segnalato di eseguire
urpme --auto-orphans
con il quale il sistema vorrebbe cancellare degli rpm orfani, e secondo lui non piu' utili al sistema:
E' assolutamente sconsigliato eseguire tale procedura, in quanto spesso esagera nel considerare orphan programmi che non lo sono affatto e cosi eliminare parti utili se non indispensabili al sistema, che possono poi provocare dei mal funzionamenti.

Lo stesso dicasi per il comando simile
rpmorphans

Direte voi, allora perche' ci sono questi comandi?
Tali comandi sarebbero parecchio utili per far un po' di pulizia, ma di tanto in tanto dei pacchettizzatori si dimenticano di inserire quegli rpm come dipendenze, e cosi' il sistema ritiene erroneamente di poter rimuovere quei file senza problemi

Trovo pero' che per adesso Mandriva dovrebbe eliminare la comparsa del consiglio di eseguire tale procedura, alla fine degli aggiornamenti, almeno fino a che' sara' messa a punto con 2009.1 oppure 2010.0:
NON UTILIZZATE QUESTI COMANDI, PER ADESSO !!!



Riavviare il PC:
Ed ecco il nuovo fiammante Kde 4.2.1, pronto ad essere personalizzato secondo i Vostri gusti!



======================================================================
FINE GUIDA
======================================================================



Link: per saperne di piu'
ftp://ftp.kde.org/pub/kde/stable/4.2.1/Mandriva/2009.0/README
L'aggiornamento proviene dal Mandriva Team brasiliano, esattamente da:
Helio Chissini de Castro <helio at mandriva dot com > Mandriva KDE Team >KDE Project

Si tratta certamente di un porting fatto molto bene, ma:
- e' da considerarsi non un aggiornamento ufficiale, e come tale esso
- e' poi unsupported, e cioe' non e' supportato da Mandriva ufficialmente.

L'integrazione ed il build con le nuovissime librerie QT 4.5 finali e' una cosa molto positiva per la stabilita',
l'aspetto grafico, e soprattutto per le prestazioni generali del DE.

NON CI RITENIAMO RESPONSABILI COMUNQUE PER EVENTUALI DANNI PROVOCATI DALL'INSTALLAZIONE !



P.S.: Si pregano gli utenti che lo proveranno di segnalare qui il loro feedback
.

Re: Installare KDE 4.2.1 su Mandriva 2009.0 i586 & X86_64

Posted: 5 March 2009, 18:58
by SymbianFlo
qt4 4.5 hmmm
in 64 python-qt e python -pimentar non le hanno portate , e a noi servono le python ...ho installato con le qt4 4.3
pazienza...

Re: Installare KDE 4.2.1 su Mandriva 2009.0 i586 & X86_64

Posted: 5 March 2009, 19:19
by MauRice
Hi,

Le update's per KDE 4.2.1 anche auto.....

Code: Select all

urpmi.addmedia --update kde4.2.1-arch ...... 
urpmi.addmedia --update kde4.2.1-noarch ......


Dopo pocchi minuti ti avvisa automatico il update's.
Oltre 300 - 400 RPM's

Giao,
MauRice

Re: Installare KDE 4.2.1 su Mandriva 2009.0 i586 & X86_64

Posted: 6 March 2009, 1:35
by NicCo
MauRice wrote:Hi,

Le update's per KDE 4.2.1 anche auto.....

Code: Select all

urpmi.addmedia --update kde4.2.1-arch ...... 
urpmi.addmedia --update kde4.2.1-noarch ......


Dopo pocchi minuti ti avvisa automatico il update's.
Oltre 300 - 400 RPM's

Giao,
MauRice


Ok, I've updated the Guide, adding --update: Thanks!

Re: Installare KDE 4.2.1 su Mandriva 2009.0 i586 & X86_64

Posted: 7 March 2009, 13:20
by NicCo
AGGIORNAMENTO:
Per la x86_64, occorre aggiungere anche il repository di kde4.2.1 i586, per risolvere eventuali dipendenze con le librerie di compatibilità a 32bit:
Questo risolve il problema di alcuni programmi segnalati altrimenti non piu funzionati, come Skype.

P.S. E' stato quindi aggiunto alla GUIDA sopra, sul codice riguardante la procedura x 64bit, il repository 32bit necessario.



Si ringrazia Little Shadow, per aver segnalato sul Blog, esattamente qui la soluzione:
http://mib.pianetalinux.org/miblight/20 ... mment-3800

Riporto anche qui il testo:
@Nicco
Abilitando anche il repository i586 Skype si installa con le dipendenze che gli servono.

Re: Installare KDE 4.2.1 su Mandriva 2009.0 i586 & X86_64

Posted: 8 March 2009, 15:47
by SymbianFlo
mah almeno per quello che riguarda skype io uso la static di skype .....poi in 64 non so in quanti usano il rpm 586 di mandriva , appunto perche avendo i repo sia 32 che 64 ti ritroverai con tanti di doppioni che alla fine avrai solo conflitti .....
e che vi devo dire , ci sono pro e contro ....

Re: Installare KDE 4.2.1 su Mandriva 2009.0 i586 & X86_64

Posted: 11 March 2009, 22:21
by nonnogs
E' arcinoto che sono un imbranato ma stavolta ho seguito a puntino la guida selezionando,copiando e incollando e l'unico risultato o meglio i due risultati : al boot è apparsa una dicitura " Mandriva 2009 spring" e al login,tra le opzioni di apertura c'è KDE4 che selezionato mi riporta pari pari alla Mandriva precedente,prima cioè dell'installazione di Kde 4.2.1.La tentata installazione,visto com'è andata.La cosa mi è sembrata subito un po stranina ; solo 23 pacchetti?! Quando la installai sulla 2009.0 me ne scaricò almeno 300,forse più.Ma i pacchetti che vedevo scaricare portavano la dicitura KDE4 e quindi,anche se un po allarmato mi sono detto che tutto andava per il meglio. Poi non c'è stata le richiesta di scegliere tra i pacchetti,non ci sono stati pacchetti orfani,insomma tutto diverso dall'altra volta e i risultati si vedono o meglio non si vedono.Posso avere la vostra opinione?grazie
Ciao.

Re: Installare KDE 4.2.1 su Mandriva 2009.0 i586 & X86_64

Posted: 11 March 2009, 22:45
by MauRice
nonnogs wrote:E' arcinoto che sono un imbranato ma stavolta ho seguito a puntino la guida selezionando,copiando e incollando e l'unico risultato o meglio i due risultati : al boot è apparsa una dicitura " Mandriva 2009 spring" e al login,tra le opzioni di apertura c'è KDE4 che selezionato mi riporta pari pari alla Mandriva precedente,prima cioè dell'installazione di Kde 4.2.1.La tentata installazione,visto com'è andata.La cosa mi è sembrata subito un po stranina ; solo 23 pacchetti?! Quando la installai sulla 2009.0 me ne scaricò almeno 300,forse più.Ma i pacchetti che vedevo scaricare portavano la dicitura KDE4 e quindi,anche se un po allarmato mi sono detto che tutto andava per il meglio. Poi non c'è stata le richiesta di scegliere tra i pacchetti,non ci sono stati pacchetti orfani,insomma tutto diverso dall'altra volta e i risultati si vedono o meglio non si vedono.Posso avere la vostra opinione?grazie
Ciao.

Nonnogs,

Oggi ci sono dei "update's" per Mandriva 2009.0 KDE 4.2.1.
Se non mi sbaglio erano una ventina.

Mandriva 2009.1 Spring RC1 e gia con KDE 4.2.1

Ciao,
MauRice

Re: Installare KDE 4.2.1 su Mandriva 2009.0 i586 & X86_64

Posted: 12 March 2009, 10:19
by fabio75
Mandriva 2009 32bit
Stamattina nuovi aggiornamenti per kde4.2.1..tra ieri sera e oggi si sta aggiornando l'intero kde4.2.1 ..quasi..

Re: Installare KDE 4.2.1 su Mandriva 2009.0 i586 & X86_64

Posted: 12 March 2009, 18:02
by nonnogs
Ho rifatto la procedura,sono stati aggiornati i supporti,i pacchetti sono risultati 29,li ho scaricati,non mi sembra ce ne fossero targati Kde 4.2.1,ho ripetuto urpmi --auto-update --auto-select --keep,l'ho ripetuto per sicurezza come consiglia Nicco,ho riavviato,ho selezionato Kde4 al login,risultato : non ci entro. Preciso che ho,a suo tempo,scaricato la Mandriva 2009.1 Beta;può influenzare ? Altro strano fenomeno : lo screen si apre con il pinguino che nuota e va così fino al login.Fatto il login lo screen passa a quello vecchio di Mandriva 2009 con il cielo stellato e i pinguini sulla riva e così durante il caricamento, quindi torna al pinguino che nuota mentre per un attimo sullo schermo appaiono i punti luminosi caratteristici del KDE4 . Ma siamo già alla versione precedente di Mandriva.E' folle!

Re: Installare KDE 4.2.1 su Mandriva 2009.0 i586 & X86_64

Posted: 13 March 2009, 23:23
by superino
Ho installato seguendo la guida nitida
io continuo ad avere problemi con l'audio di skype non va!

Altra cosa finendo l'installazione di kde4.2.1 i repository dell'architettura i586 bisogna disattivarli ?

Re: Installare KDE 4.2.1 su Mandriva 2009.0 i586 & X86_64

Posted: 14 March 2009, 1:08
by SymbianFlo
superino
usi il rpm 586 di mandriva ?
hai levato le pulse ?
hai provato la skype static ufficiale dal sito ?

Re: Installare KDE 4.2.1 su Mandriva 2009.0 i586 & X86_64

Posted: 14 March 2009, 12:05
by superino
Non uso arch.i586 ma seguendo la guida è specificato che per le macchine x86_64 bisogna aggiungere i repo i586
volevo sapere se dopo l'installazione si possono eliminare?

Per quanto riguarda le pulse ancora non ho provato a disattivarle.

provo a scaricare skype static dal sito

Re: Installare KDE 4.2.1 su Mandriva 2009.0 i586 & X86_64

Posted: 14 March 2009, 12:29
by superino
Togliendo le pulse l'audio si riesce a configurarlo
questa volta funziona

grazie SymbianFlo x la dritta delle pulse audio.

:lol: :D :lol: :D :lol: