Mesa 7.9

Richieste di programmi e di intervento del MIB
User avatar
steros
Utente junior
Utente junior
Posts: 59
Joined: 10 December 2009, 10:29
ROSA: 2012.1
OpenMandriva: -
Kernel: 3.10.21-nrjQL
Desktop: Kde 4
country: Italy

Mesa 7.9

Post by steros »

Ho installato il KDE 4.5.3 e sul pc con la scheda grafica ATI funziona tutto alla perfezione. Su un portatile con scheda grafica Intel, invece si inchioda la grafica ogni volta che si applicano delle modifiche da systemsetting. Su https://bugs.kde.org/show_bug.cgi?id=241402 ho trovato la soluzione, ovvero installare Mesa 7.9.
E' possibile?
Steros - Mdv Rosa 2012.1 x86_64 - KDE 4

User avatar
astragalo
Collaboratore
Collaboratore
Posts: 647
Joined: 7 December 2007, 18:29
ROSA: Rosa R11.1
OpenMandriva: -
Kernel: 4.15.xx
Desktop: Plasma5
country: Italia

Re: Mesa 7.9

Post by astragalo »

Ciao li puoi trovare nel repo di testing:

http://mib.pianetalinux.org/2010.1/32/testing/

o se usi una 64 bit

http://mib.pianetalinux.org/2010.1/64/testing/

Facci sapere come va, io lo uso da qualche giorno ma ho ancora il kde 4.4.3.

Astragalo.
L'erba cattiva non muore mai!!! ;)
:D :D :D

User avatar
GvMariani
Collaboratore
Collaboratore
Posts: 610
Joined: 27 July 2009, 11:31
ROSA: 2016.1 Fresh R10
OpenMandriva: -
Kernel: 4.19.13-nrj-desktop
Desktop: Plasma 5
country: Italy
Location: Cologno Monzese (MI) - Italia

Re: Mesa 7.9

Post by GvMariani »

astragalo wrote:Ciao li puoi trovare nel repo di testing:
http://mib.pianetalinux.org/2010.1/32/testing/
o se usi una 64 bit
http://mib.pianetalinux.org/2010.1/64/testing/
Facci sapere come va, io lo uso da qualche giorno ma ho ancora il kde 4.4.3.
Attenzione che per il funzionamento servono anche le libdrm e libdri (o lib64drm e lib64dri secondo l'arch che hai) presenti nelle dir indicate da Astragalo e il libpixman / lib64pixman presente nei Main/Backports...

GvM

User avatar
steros
Utente junior
Utente junior
Posts: 59
Joined: 10 December 2009, 10:29
ROSA: 2012.1
OpenMandriva: -
Kernel: 3.10.21-nrjQL
Desktop: Kde 4
country: Italy

Re: Mesa 7.9

Post by steros »

Grazie mille per le info.

Tanto per la cronaca, ho aggiornato i seguenti pacchetti:

Code: Select all

- mesa-demos-7.8.1-6mdv2010.1.x86_64
- lib64dri-drivers-7.9-69.1mib2010.1.x86_64
- lib64drm-devel-2.4.22-69.1mib2010.1.x86_64
- lib64drm2-2.4.22-69.1mib2010.1.x86_64
- lib64drm_intel1-2.4.22-69.1mib2010.1.x86_64
- lib64drm_nouveau1-2.4.22-69.1mib2010.1.x86_64
- lib64drm_radeon1-2.4.22-69.1mib2010.1.x86_64
- lib64kms1-2.4.22-69.1mib2010.1.x86_64
- lib64mesagl1-7.9-69.1mib2010.1.x86_64
- lib64mesagl1-devel-7.9-69.1mib2010.1.x86_64
- lib64mesaglu1-7.9-69.1mib2010.1.x86_64
- lib64mesaglu1-devel-7.9-69.1mib2010.1.x86_64
- lib64mesaglut3-7.9-69.1mib2010.1.x86_64
- lib64mesaglut3-devel-7.9-69.1mib2010.1.x86_64
- lib64mesaglw1-7.9-69.1mib2010.1.x86_64
- lib64mesaglw1-devel-7.9-69.1mib2010.1.x86_64
- mesa-7.9-69.1mib2010.1.x86_64
Ho riavviato e sembra tutto ok (forse, a occhio, anche un po' più reattivo).
L' "applica" sul systemsettings si è risolto per tutti i casi fuorché quando si cambia lo stile delle applicazioni: in questi casi va sempre sbloccato disattivando il compositing (SHIFT-ALT-F12) e riattivandolo.

Se avete qualche idea è ben accetta...
Ciao.
Steros - Mdv Rosa 2012.1 x86_64 - KDE 4

User avatar
GvMariani
Collaboratore
Collaboratore
Posts: 610
Joined: 27 July 2009, 11:31
ROSA: 2016.1 Fresh R10
OpenMandriva: -
Kernel: 4.19.13-nrj-desktop
Desktop: Plasma 5
country: Italy
Location: Cologno Monzese (MI) - Italia

Re: Mesa 7.9

Post by GvMariani »

steros wrote:Grazie mille per le info.
Tanto per la cronaca, ho aggiornato i seguenti pacchetti:
[...]
Ho riavviato e sembra tutto ok (forse, a occhio, anche un po' più reattivo).
L' "applica" sul systemsettings si è risolto per tutti i casi fuorché quando si cambia lo stile delle applicazioni: in questi casi va sempre sbloccato disattivando il compositing (SHIFT-ALT-F12) e riattivandolo.
Se avete qualche idea è ben accetta...
Hai installato anche il pixman 0.20? O hai ancora il default 0.19.6? (Questo c'entra direttamente con il modo con cui vengono visualizzate le immagini...)

Non c'entra col tuo problema, ma della lista delle cose installate ti manca glxinfo (ora sta in un pacchetto a sé e non è più compreso nelle mesa-demos).

GvM

User avatar
steros
Utente junior
Utente junior
Posts: 59
Joined: 10 December 2009, 10:29
ROSA: 2012.1
OpenMandriva: -
Kernel: 3.10.21-nrjQL
Desktop: Kde 4
country: Italy

Re: Mesa 7.9

Post by steros »

Di pixman avevo già la 0.20.0, mentre di glxinfo avevo già la 7.8.1 che sembra essere l'ultima versione.
Steros - Mdv Rosa 2012.1 x86_64 - KDE 4

User avatar
GvMariani
Collaboratore
Collaboratore
Posts: 610
Joined: 27 July 2009, 11:31
ROSA: 2016.1 Fresh R10
OpenMandriva: -
Kernel: 4.19.13-nrj-desktop
Desktop: Plasma 5
country: Italy
Location: Cologno Monzese (MI) - Italia

Re: Mesa 7.9

Post by GvMariani »

Quando ti si pianta, nel file .xsession-errors (che sta "nascosto" nella tua dir home...) appare qualche messaggio particolare di errore? E nel file di log di Xserver (Xorg.0.log)?

Se non trovi niente del tutto o nulla di abbastanza significativo (che so: qualche tipo di "X Error..."...), allora bisogna cercare di circoscrivere il più possibile il problema...
quando si cambia lo stile delle applicazioni
Cioè utilizzando SystemSettings - ApplicationAppearance - Style?
Hai provato a selezionare qualche altro "widget style"? Lo fa con tutti o solo con alcuni?

Un altro tentativo che potresti fare (un po' lungo, però, in assenza di indicazioni particolari da messaggi di errore...) potrebbe essere quello di disabilitare uno alla volta gli effetti grafici di Kwin che hai attualmente abilitati (SystemSettings - Desktop Effects - Linguetta "All Effects"), alla ricerca di quello/i che causano il blocco...

GvM

User avatar
astragalo
Collaboratore
Collaboratore
Posts: 647
Joined: 7 December 2007, 18:29
ROSA: Rosa R11.1
OpenMandriva: -
Kernel: 4.15.xx
Desktop: Plasma5
country: Italia

Re: Mesa 7.9

Post by astragalo »

Proprio ieri sera ho preparato pixman 0.21.2 poi lo passo a Nicco per metterlo sul server. :D

Astragalo
L'erba cattiva non muore mai!!! ;)
:D :D :D

User avatar
steros
Utente junior
Utente junior
Posts: 59
Joined: 10 December 2009, 10:29
ROSA: 2012.1
OpenMandriva: -
Kernel: 3.10.21-nrjQL
Desktop: Kde 4
country: Italy

Re: Mesa 7.9

Post by steros »

Allora, ho fatto qualche prova e il cambio dello stile (da SystemSettings - ApplicationAppearance - Style) provoca lo stesso blocco con tutti gli stili. In più si blocca quando cambio gli effetti 3D da "Effetti del desktop" e anche eseguendo manualmente "qdbus org.kde.kwin /KWin reconfigure" (che, a questo punto, penso sia la radice del problema).
Ho provato a disabilitare ad uno ad uno tutti gli effetti 3D ma il problema persiste: sembrerebbe legato al solo compositing.
Inoltre né in "Xorg.0.log" né in ".xsession-errors" trovo messaggi illuminanti: sia che applichi le modifiche col compositing attivato sia che le applichi col compositing disattivato dà gli stessi messaggi che però sono solo warning interni delle Qt che non sembrano in alcun modo legati al problema (probabilmente sono solo inesattezze negli stili).
Steros - Mdv Rosa 2012.1 x86_64 - KDE 4

User avatar
GvMariani
Collaboratore
Collaboratore
Posts: 610
Joined: 27 July 2009, 11:31
ROSA: 2016.1 Fresh R10
OpenMandriva: -
Kernel: 4.19.13-nrj-desktop
Desktop: Plasma 5
country: Italy
Location: Cologno Monzese (MI) - Italia

Re: Mesa 7.9

Post by GvMariani »

steros wrote:Allora, ho fatto qualche prova e il cambio dello stile (da SystemSettings - ApplicationAppearance - Style) provoca lo stesso blocco con tutti gli stili. In più si blocca quando cambio gli effetti 3D da "Effetti del desktop" e anche eseguendo manualmente "qdbus org.kde.kwin /KWin reconfigure" (che, a questo punto, penso sia la radice del problema).
Ho provato a disabilitare ad uno ad uno tutti gli effetti 3D ma il problema persiste: sembrerebbe legato al solo compositing.
Inoltre né in "Xorg.0.log" né in ".xsession-errors" trovo messaggi illuminanti: sia che applichi le modifiche col compositing attivato sia che le applichi col compositing disattivato dà gli stessi messaggi che però sono solo warning interni delle Qt che non sembrano in alcun modo legati al problema (probabilmente sono solo inesattezze negli stili).
Puzza di problema di driver...
Se gli dici di usare Xrender invece di OpenGL, cambia qualcosa (a parte la lentezza, ovvio...)?

GvM

User avatar
steros
Utente junior
Utente junior
Posts: 59
Joined: 10 December 2009, 10:29
ROSA: 2012.1
OpenMandriva: -
Kernel: 3.10.21-nrjQL
Desktop: Kde 4
country: Italy

Re: Mesa 7.9

Post by steros »

Eh, si. Come ho specificato nel messaggio di apertura del thread sulla scheda ATI ha funzionato subito senza problemi.
Sulla Intel ti confermo che utilizzando XRender al posto di OpenGL funziona.
Sono d'accordo che il problema è legato al driver, ma quello che non capisco è cos'è cambiato rispetto al Kde 4.4 che invece andava.
Steros - Mdv Rosa 2012.1 x86_64 - KDE 4

User avatar
GvMariani
Collaboratore
Collaboratore
Posts: 610
Joined: 27 July 2009, 11:31
ROSA: 2016.1 Fresh R10
OpenMandriva: -
Kernel: 4.19.13-nrj-desktop
Desktop: Plasma 5
country: Italy
Location: Cologno Monzese (MI) - Italia

Re: Mesa 7.9

Post by GvMariani »

steros wrote: Sono d'accordo che il problema è legato al driver, ma quello che non capisco è cos'è cambiato rispetto al Kde 4.4 che invece andava.
KDE 4.5.x, rispetto al suo diretto antecedente 4.4.x, utilizza in modo molto più pesante e pervasivo
alcune caratteristiche OpenGL (con l'idea che, essendo diversi anni che le specifiche sono in giro, ormai i driver e Mesa dovrebbero essersi adeguati a supportarle... ma non è così):
di conseguenza, per vari utenti, il passaggio 4.4.x => 4.5.x ha comportato la "sorpresa" che cose che prima funzionavano tranquillamente improvvisamente non lo facevano più o lo facevano male (se cerchi in rete troverai sicuramente delle discussioni a questo proposito...).

Nel mio caso era l'effetto "blur", non adeguatamente supportato dal driver Radeon open: allungava a dismisura i tempi del logout da KDE e dava messaggi di errore...

Una eventuale soluzione è quella di aggiornare il più possibile l'intero stack video di basso livello (drm nel kernel - quindi il kernel all'ultima versione disponibile -, drm userspace, mesa e driver video), magari in occasione dei rilasci di qualcuna delle varie componenti: chissà che il problema non venga progressivamente eliminato (con l'ultimo kernel 2.6.36.x, p.es., il driver Radeon open ha guadagnato l'effettivo supporto del color tiling per le schede R600+, che era già disponibile nelle nuove libdrm, Mesa e ati driver stabili...).
Sconsiglierei, a meno di non essere molto esperti e disperati, l'installazione delle attuali versioni di sviluppo: si può letteralmente disastrare il sistema grafico e, almeno per Mdv, non c'è un modo semplice di installarli come rpm (a meno che non siano già presenti in Cooker).

GvM

User avatar
steros
Utente junior
Utente junior
Posts: 59
Joined: 10 December 2009, 10:29
ROSA: 2012.1
OpenMandriva: -
Kernel: 3.10.21-nrjQL
Desktop: Kde 4
country: Italy

Re: Mesa 7.9

Post by steros »

Mi sa che aspetterò un aggiornamento risolutivo perché il computer in questione è quello che uso per lavoro e quindi non è il caso di andare in testing empirico... ;)
Tanto più che un paio d'anni fa mi ero messo a testare il driver proprietario ATI e mi aveva fatto passare la voglia di toccare i driver grafici. :lol:
Grazie per l'aiuto.
Steros - Mdv Rosa 2012.1 x86_64 - KDE 4

User avatar
NicCo
Amministratore
Amministratore
Posts: 4740
Joined: 6 December 2007, 19:54

Re: Mesa 7.9

Post by NicCo »

astragalo wrote:Proprio ieri sera ho preparato pixman 0.21.2 poi lo passo a Nicco per metterlo sul server. :D

Astragalo
È sul server, solita cartella /testing, e le liste sono aggiornate

Ciao, NicCo
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
steros
Utente junior
Utente junior
Posts: 59
Joined: 10 December 2009, 10:29
ROSA: 2012.1
OpenMandriva: -
Kernel: 3.10.21-nrjQL
Desktop: Kde 4
country: Italy

Re: Mesa 7.9

Post by steros »

Sembra che ci sia solo sul repo a 32 bit. Ci sono piani per il 64?
Steros - Mdv Rosa 2012.1 x86_64 - KDE 4

Post Reply