Page 1 of 2

digikam et kipi-plugins 1.1.0 manque exiv2 0.19,kexiv2 1.0.0

PostPosted: 14 February 2010, 18:31
by promeneur
digikam et kipi-plugins utilisent exiv2 et kexiv2

sans mise à jour de ces 2 derniers il y a des disfonctionnements
notamment impossible de paramétrer les métadata nepomuk, iptc, xmp

merci de procurer les dernières versions de exiv2 (les différents paquets util, doc, devel, lib etc) et kexiv2(les différents paquets)

Re: digikam et kipi-plugins 1.1.0 merci mais manque

PostPosted: 15 February 2010, 15:50
by promeneur
les versions exactes nécessaires sont :

exiv2 0.19 (libexiv2_6)
libkexiv2 1.0.0 (libkexiv2_8)

merci

P.S. ce sont les versions installées pour la cooker 2010.1 donc sans doutes les sources sont dispos dans le dossier SRPMS de la cooker

Re: digikam et kipi-plugins 1.1.0 manque exiv2 0.19,kexiv2 1.0.0

PostPosted: 19 February 2010, 12:47
by Dago68
Bonjour promeneur,

je m'en occupe ce weekend.

Bonne journée

Dago68

Re: digikam et kipi-plugins 1.1.0 manque exiv2 0.19,kexiv2 1.0.0

PostPosted: 19 February 2010, 13:19
by promeneur
merci beaucoup

je me suis permis d'insister car
- ce bug existe depuis la 2010.0 et digikam 1.0.0beta
- j'ai fait un rapport de bug chez qa.mandriva.com et bugs.kde.org

mais pas de réaction. ils ont peut-être pas le temps mais c'est quand même bloquant

Re: digikam et kipi-plugins 1.1.0 manque exiv2 0.19,kexiv2 1.0.0

PostPosted: 19 February 2010, 15:30
by promeneur
attention il semble que digikam et kipi plugins doivent être compilés avec exiv2 0.19 et kexiv2 1.0.0 sinon ils continuent à utiliser les version 0.18.5 (libexiv2_5) et 0.6.0(libkexiv2_7)

c'est même sûr

voir comment 10 de
https://bugs.kde.org/show_bug.cgi?id=226789

Re: digikam et kipi-plugins 1.1.0 manque exiv2 0.19,kexiv2 1.0.0

PostPosted: 19 February 2010, 19:12
by Dago68
Salut promeneur,

j'ai commencé à voir les paquets... mumble mumble

ce n'est pas possible compiler libkexiv2 1.0.0 (libkexiv2_8) car il fait parti de kde 4.4 et précisément du paquet kdegraphics4.

Dago68

Re: digikam et kipi-plugins 1.1.0 manque exiv2 0.19,kexiv2 1.0.0

PostPosted: 19 February 2010, 19:36
by promeneur
ça veut dire qu'il faut attendre que MIB sorte la 4.4.1 ou supérieur.

on attendra

Re: digikam et kipi-plugins 1.1.0 manque exiv2 0.19,kexiv2 1.0.0

PostPosted: 20 February 2010, 11:48
by promeneur
non on peut compiler digikam et kipiplugins avec les dernières versions de exiv2 et kexiv2 et kde 4.3 même 4.2

voici la réponse de G.Caulier dev de digikam
******************************************************************************
you can compile KEXiv2 (and all other libs from kdegraphics that digiKam use)
with old KDE4 version. I do it myself, as developper and maintainer of these
libs.

Don't forget : i use also mandriva distro (2010.0 with KDE 4.2.3)
*******************************************************************************

Re: digikam et kipi-plugins 1.1.0 manque exiv2 0.19,kexiv2 1.0.0

PostPosted: 20 February 2010, 22:06
by Dago68
Salut promeneur,

ce n'est pas si facile mais en forçant quelque chose je suis enfin arrive.

Pour l'instant je ne suis pas sure du résultat donc j'ai mit les paquets en test ici:

pour Mandriva 1010.0 64
http://mib.pianetalinux.org/2010.0/64/testing/digikam-1.1.0/

pour Mandriva 1010.0 32 il faut attendre la fase de building est longue.

Bonne soirée

Dago68

Re: digikam et kipi-plugins 1.1.0 manque exiv2 0.19,kexiv2 1.0.0

PostPosted: 20 February 2010, 22:46
by promeneur
merci

Re: digikam et kipi-plugins 1.1.0 manque exiv2 0.19,kexiv2 1.0.0

PostPosted: 21 February 2010, 2:36
by Dago68
Bonsoir,

voila pour Mandriva 2010.0 32 :

http://mib.pianetalinux.org/2010.0/32/testing/digikam-1.1.0/

Bon testing

Dago68

Re: digikam et kipi-plugins 1.1.0 manque exiv2 0.19,kexiv2 1.0.0

PostPosted: 21 February 2010, 10:24
by promeneur
Merci

je n'imaginais pas toutes ces dépendances

les métadonnées de testing/digikam ne sont pas bonnes

j'ai du créer un dépot local pour faire la maj

Re: digikam et kipi-plugins 1.1.0 manque exiv2 0.19,kexiv2 1.0.0

PostPosted: 21 February 2010, 10:38
by promeneur
ok les 5 fonctionnalités (!) manquantes sont là

mais tous est en anglais ! j'ai du changer la langue pour le français mais plein de texte reste en anglais plus que ceux qui ne sont pas traduits

merci pour les utilisateurs de digikam

ci-joint une capture où on voit qu'il y a maintenant 6 onglets au lieu d'un seul le "behavior"

Re: digikam et kipi-plugins 1.1.0 manque exiv2 0.19,kexiv2 1.0.0

PostPosted: 21 February 2010, 10:42
by promeneur
la capture ne marche pas
tu ne verras pas l'amélioration

désolé

Re: digikam et kipi-plugins 1.1.0 manque exiv2 0.19,kexiv2 1.0.0

PostPosted: 21 February 2010, 13:39
by Dago68
Bonjour promeneur,

les modifications sur kdegraphics4 peuvent empercher de faire fonctionner d'autres logiciels, si tu me dis que tous marchent bien, moi, je mes les paquets dans nos repo basic.

Bonne journée

Dago68