Kernel 3.0.0 + -NRJ and -NRJ-PAE for 2010.1, 2010.2, 2011.0

Latest shouts directly from our packagers and call for public testing MIB packages
Post Reply
User avatar
NicCo
Amministratore
Amministratore
Posts: 4745
Joined: 6 December 2007, 19:54

Kernel 3.0.0 + -NRJ and -NRJ-PAE for 2010.1, 2010.2, 2011.0

Post by NicCo »

Last Update: 2011/07/29 - 22:30
Kernel 3.0.0 NRJ for Mandriva 2010.2 and 2011.0

All rpms files needed are here:
2010.2 32bit > http://mib.pianetalinux.org/MIB/2010.2/ ... els/3.0.0/ and 2010.2 64bit > http://mib.pianetalinux.org/MIB/2010.2/ ... els/3.0.0/
2011.0 32bit > http://mib.pianetalinux.org/MIB/2011.0/ ... els/3.0.0/ and 2011.0 64bit > http://mib.pianetalinux.org/MIB/2011.0/ ... els/3.0.0/


Kernel 3.0.0 desktop nrj per Mandriva 2010.2 32bit

Code: Select all

urpmi.addmedia --update Kernel_3.0.0 http://mib.pianetalinux.org/MIB/2010.2/32/projects/kernels/3.0.0/
urpmi --auto -a kernel-firmware
urpmi --auto -a kernel-nrj-desktop-devel-3.0.0
urpmi --auto -a kernel-nrj-desktop-3.0.0
urpmi --auto-select --auto
#
Kernel 3.0.0 desktop nrj per Mandriva 2010.2 64bit

Code: Select all

urpmi.addmedia --update Kernel_3.0.0 http://mib.pianetalinux.org/MIB/2010.2/64/projects/kernels/3.0.0/
urpmi --auto -a kernel-firmware
urpmi --auto -a kernel-nrj-desktop-devel-3.0.0
urpmi --auto -a kernel-nrj-desktop-3.0.0
urpmi --auto-select --auto
#
Kernel 3.0.0 desktop nrj per Mandriva 2011.0 32bit

Code: Select all

urpmi.addmedia --update Kernel_3.0.0 http://mib.pianetalinux.org/MIB/2011.0/32/projects/kernels/3.0.0/
urpmi --auto -a kernel-firmware
urpmi --auto -a kernel-nrj-desktop-devel-3.0.0
urpmi --auto -a kernel-nrj-desktop-3.0.0
urpmi --auto-select --auto
#
Kernel 3.0.0 desktop nrj per Mandriva 2011.0 64bit

Code: Select all

urpmi.addmedia --update Kernel_3.0.0 http://mib.pianetalinux.org/MIB/2011.0/64/projects/kernels/3.0.0/
urpmi --auto -a kernel-firmware
urpmi --auto -a kernel-nrj-desktop-devel-3.0.0
urpmi --auto -a kernel-nrj-desktop-3.0.0
urpmi --auto-select --auto
#
________________________________________________________________________________________________________
________________________________________________________________________________________________________

Changelog: from kernel nrj 2.6.38.8

I enabled a NEW feature available since 3.0.0
Enable RCU priority boosting (RCU_BOOST)
This option boosts the priority of preempted RCU readers that block the current preemptible RCU grace period for too long. This option also prevents heavy loads from blocking RCU callback invocation for all flavors of RCU.

Say Y here if you are working with real-time apps or heavy loads Say N here if you are unsure.
________________________________________________________________________________________________________
________________________________________________________________________________________________________

My tested config is:
Amd x2-6000 - 4Gb ram - Nvidia 6200Gpu onboard
-kernel 3.0.0
-nvidia 280.04

First personal testing:
I worked all day long with new kernel nrj 3.0.0:
No problems, audio, video, network, all is fine,
the only issue I have, vmware 7.1.4 and vmplayer 3.1.4 don't build their modules,
so I must wait for an update (vmware 7.1.5, vmplayer 3.1.5) or unofficial patches


bye, NicCo
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
NicCo
Amministratore
Amministratore
Posts: 4745
Joined: 6 December 2007, 19:54

Re: Kernel 3.0.0 + -NRJ and -NRJ-PAE for 2010.1, 2010.2, 201

Post by NicCo »

Adesso Vi ho preparato anche tutti i driver proprietari, e ho testato personalmente che buildassero con 3.0.0
Li ho uppati nella stessa cartella del kernel, e ho anche aggiornato le liste locali della cartella come repository

Avvertimento
Per chi usa vmware/vmplayer, ricordo che la versione attuale 7.1.4/3.1.4 non buildano i moduli con kernel 3.0.0


Mandriva 2010.2 64bit
per aggiungere il nuovo repo di kernel 3.0.0, firmware e driver video

Code: Select all

urpmi.addmedia --update Kernel_3.0.0 http://mib.pianetalinux.org/MIB/2010.2/64/projects/kernels/3.0.0/
poi potrete installare uno dei tre driver proprietari (se avete Intel o altro, non occorre, saltate questa fase)

nvidia current 280.11 per le Nvidia recenti (partendo da Nvidia 6XXX)

Code: Select all

urpmi dkms-nvidia-current
oppure
nvidia 173.14.30 per le vecchie nvidia FX (es. FX 5200, FX 5900)

Code: Select all

urpmi dkms-nvidia173
oppure
ATI 8.861 per le ATI recenti a partire da HD 3XXX

Code: Select all

urpmi dkms-fglrx

all fine potrete installare i nuovo firmware ed il kernel nrj 3.0.0

Code: Select all

urpmi --auto kernel-firmware
urpmi --auto kernel-nrj-desktop-devel-3.0.0
urpmi --auto kernel-nrj-desktop-3.0.0
#
Ciao, NicCo
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
NicCo
Amministratore
Amministratore
Posts: 4745
Joined: 6 December 2007, 19:54

Re: Kernel 3.0.0 + -NRJ and -NRJ-PAE for 2010.1, 2010.2, 201

Post by NicCo »

New Nvidia drivers 280.11 for 2010.2 64bit: I'm going to install and test them:
if working with Kernel 3.0.0, I'll upload immediately

[POST EDIT] Ok, iI'm now using Kernel nrj 3.0.0 and nvidia current 280.11: all it's fine, tested also some 3D games:
so I'm just uploading all tested nvidia 280.11 rpms for 2010.2 64bit

Code: Select all

Scritto: /home/utente/rpmbuild/SRPMS/nvidia-current-280.11-69.1mib2010.2.src.rpm
Scritto: /home/utente/rpmbuild/RPMS/x86_64/x11-driver-video-nvidia-current-280.11-69.1mib2010.2.x86_64.rpm
Scritto: /home/utente/rpmbuild/RPMS/x86_64/dkms-nvidia-current-280.11-69.1mib2010.2.x86_64.rpm
Scritto: /home/utente/rpmbuild/RPMS/x86_64/nvidia-current-devel-280.11-69.1mib2010.2.x86_64.rpm
Scritto: /home/utente/rpmbuild/RPMS/x86_64/nvidia-current-cuda-opencl-280.11-69.1mib2010.2.x86_64.rpm
Scritto: /home/utente/rpmbuild/RPMS/x86_64/nvidia-current-doc-html-280.11-69.1mib2010.2.x86_64.rpm

Code: Select all

[root@localhost Documenti]# urpmi dkms-nvidia-current
Per soddisfare le dipendenze, saranno installati i seguenti pacchetti:
   Pacchetto                      Versione     Release       Arch.  
(supporto "LOCAL64")
  dkms-nvidia-current            280.11       69.1mib2010.2 x86_64  
  nvidia-current-doc-html        280.11       69.1mib2010.2 x86_64  
  x11-driver-video-nvidia-curre> 280.11       69.1mib2010.2 x86_64  
Altri 203KB di spazio disco saranno utilizzati.
verranno scaricati 17MB di pacchetti.
Procedo con l'installazione di 3 pacchetti? (S/n) 

ATI fglrx are compatible with Kernel 3.0.0
it's been tested in my PC and it does build, i think it should be working fine

Code: Select all

Scritto: /home/utente/rpmbuild/SRPMS/fglrx-8.861-69.1mib2010.2.src.rpm
Scritto: /home/utente/rpmbuild/RPMS/x86_64/x11-driver-video-fglrx-8.861-69.1mib2010.2.x86_64.rpm
Scritto: /home/utente/rpmbuild/RPMS/x86_64/fglrx-control-center-8.861-69.1mib2010.2.x86_64.rpm
Scritto: /home/utente/rpmbuild/RPMS/x86_64/dkms-fglrx-8.861-69.1mib2010.2.x86_64.rpm
Scritto: /home/utente/rpmbuild/RPMS/x86_64/fglrx-devel-8.861-69.1mib2010.2.x86_64.rpm

Code: Select all

[root@localhost 3.0.0]# urpmi dkms-fglrx
Per soddisfare le dipendenze, saranno installati i seguenti pacchetti:
   Pacchetto                      Versione     Release       Arch.  
(supporto "LOCAL64")
  dkms-fglrx                     8.861        69.1mib2010.2 x86_64  
  fglrx-control-center           8.861        69.1mib2010.2 x86_64  (suggerito)
  x11-driver-video-fglrx         8.861        69.1mib2010.2 x86_64  
Altri 118MB di spazio disco saranno utilizzati.
verranno scaricati 28MB di pacchetti.
Procedo con l'installazione di 3 pacchetti? (S/n) 

Nvidia 173.14.30 >This driver is for GeForce FX based cards (e.g. FX 5200, 5900)
it's been tested in my PC and it does build, i think it should be working fine

Code: Select all

Scritto: /home/utente/rpmbuild/SRPMS/nvidia173-173.14.30-69.1mib2010.2.src.rpm
Scritto: /home/utente/rpmbuild/RPMS/x86_64/x11-driver-video-nvidia173-173.14.30-69.1mib2010.2.x86_64.rpm
Scritto: /home/utente/rpmbuild/RPMS/x86_64/dkms-nvidia173-173.14.30-69.1mib2010.2.x86_64.rpm
Scritto: /home/utente/rpmbuild/RPMS/x86_64/nvidia173-devel-173.14.30-69.1mib2010.2.x86_64.rpm
Scritto: /home/utente/rpmbuild/RPMS/x86_64/nvidia173-cuda-173.14.30-69.1mib2010.2.x86_64.rpm
Scritto: /home/utente/rpmbuild/RPMS/x86_64/nvidia173-doc-html-173.14.30-69.1mib2010.2.x86_64.rpm

Code: Select all

[root@localhost Documenti]# urpmi dkms-nvidia173
Per soddisfare le dipendenze, saranno installati i seguenti pacchetti:
   Pacchetto                      Versione     Release       Arch.  
(supporto "LOCAL64")
  dkms-nvidia173                 173.14.30    69.1mib2010.2 x86_64  
  nvidia173-doc-html             173.14.30    69.1mib2010.2 x86_64  (suggerito)
  x11-driver-video-nvidia173     173.14.30    69.1mib2010.2 x86_64  
Altri 55MB di spazio disco saranno utilizzati.
verranno scaricati 10MB di pacchetti.
Procedo con l'installazione di 3 pacchetti? (S/n) 

Nvidia 96.43.19 >This driver is for old GeForce (serie 4 and some previous) based cards (e.g. GF MX4400)
it's been tested in my PC and it does NOT build, i think it should NOT work

Code: Select all

Scritto: /home/utente/rpmbuild/SRPMS/nvidia-96xx-96.43.19-69.1mib2010.2.src.rpm
Scritto: /home/utente/rpmbuild/RPMS/x86_64/x11-driver-video-nvidia96xx-96.43.19-69.1mib2010.2.x86_64.rpm
Scritto: /home/utente/rpmbuild/RPMS/x86_64/dkms-nvidia96xx-96.43.19-69.1mib2010.2.x86_64.rpm
Scritto: /home/utente/rpmbuild/RPMS/x86_64/nvidia96xx-devel-96.43.19-69.1mib2010.2.x86_64.rpm
Scritto: /home/utente/rpmbuild/RPMS/x86_64/nvidia96xx-doc-html-96.43.19-69.1mib2010.2.x86_64.rpm

Code: Select all

[root@localhost Documenti]# urpmi dkms-nvidia96xx
Per soddisfare le dipendenze, saranno installati i seguenti pacchetti:
   Pacchetto                      Versione     Release       Arch.  
(supporto "LOCAL64")
  dkms-nvidia96xx                96.43.19     69.1mib2010.2 x86_64  
  nvidia96xx-doc-html            96.43.19     69.1mib2010.2 x86_64  (suggerito)
  x11-driver-video-nvidia96xx    96.43.19     69.1mib2010.2 x86_64  
Altri 39MB di spazio disco saranno utilizzati.
verranno scaricati 7.3MB di pacchetti.
Procedo con l'installazione di 3 pacchetti? (S/n) 
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

ozky
Utente junior
Utente junior
Posts: 66
Joined: 24 March 2009, 15:28
OpenMandriva: Rosa 2012
Kernel: 3.2.20
Desktop: kde 4.8.4
country: Finland
Location: Raisio

Re: Kernel 3.0.0 + -NRJ and -NRJ-PAE for 2010.1, 2010.2, 201

Post by ozky »

when 2010.2 32bit kernel is going to be available so i can test that new kernel if that's working with my intel graphics ?
Rosa 2012 kde

User avatar
NicCo
Amministratore
Amministratore
Posts: 4745
Joined: 6 December 2007, 19:54

Re: Kernel 3.0.0 + -NRJ and -NRJ-PAE for 2010.1, 2010.2, 201

Post by NicCo »

ozky wrote:when 2010.2 32bit kernel is going to be available so i can test that new kernel if that's working with my intel graphics ?
I think and hope for tomorrow,
if astragalo build, test and then upload all files as promised (he has a laptop with Intel video too, so he can test properly)


bye, NicCo
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
astragalo
Collaboratore
Collaboratore
Posts: 652
Joined: 7 December 2007, 18:29
ROSA: Rosa R11.1
OpenMandriva: -
Kernel: 4.15.xx
Desktop: Plasma5
country: Italia

Re: Kernel 3.0.0 + -NRJ and -NRJ-PAE for 2010.1, 2010.2, 201

Post by astragalo »

The kernel with 2010.2 32bit (video intel) work fine, a litle bug with netaplet that not notify the network status.

Very great job! :D

Thanks Nicco.
L'erba cattiva non muore mai!!! ;)
:D :D :D

User avatar
andreas
Utente
Utente
Posts: 281
Joined: 1 November 2008, 20:03

Re: Kernel 3.0.0 + -NRJ and -NRJ-PAE for 2010.1, 2010.2, 201

Post by andreas »

I think there is some intel wifi module to upgrade too.
Tested on a Del Precision 60 (Nvidia Quadro FX 1500, and Intel Wifi AGN 5300).
I confirm the net applet and drakconf modules reporting a broken connection while the connection is alive (only iwith a wifi connection, not tested with awired lan)
With a 2.4 GHz N connection the wlan worked fine, but when I tried to connect to a router that had both 2.4 and 5 Ghz N- connections active, it resulted in a mess that the router handled switching off both connections.
Probably, together with the kernel 3.0, it is necessary to carry even updated iwlwifi modules.
All the other parts of the system worked flawlessly and visibly faster with the new kernel.
AndreaS

Procio Intel i7-4930k, mobo Asus X79-Deluxe, Adaptec raid 7805, Nvidia Quadro 6000 - Rosa Fresh R3 X64

ozky
Utente junior
Utente junior
Posts: 66
Joined: 24 March 2009, 15:28
OpenMandriva: Rosa 2012
Kernel: 3.2.20
Desktop: kde 4.8.4
country: Finland
Location: Raisio

Re: Kernel 3.0.0 + -NRJ and -NRJ-PAE for 2010.1, 2010.2, 201

Post by ozky »

good work thanks next thing to do is make full upgrade to 2011 rc2 with mib kernel repo enabled if there is no kernel 3 in 2011 rc2
Rosa 2012 kde

User avatar
NicCo
Amministratore
Amministratore
Posts: 4745
Joined: 6 December 2007, 19:54

Re: Kernel 3.0.0 + -NRJ and -NRJ-PAE for 2010.1, 2010.2, 201

Post by NicCo »

Problem with Network Manager is well known: there's a solution!

discussion:
http://comments.gmane.org/gmane.linux.mageia.devel/6661

(Even Eugeni Dodonov uses Kernel 3.0, read the bottom, and we should use old & byggy 2.6.38.7, no I don't think at all)


bugs:
https://bugs.mageia.org/show_bug.cgi?id=1266

Probably it need a new patched version of
libdrakx-net

next days we'll try the given solution

bye, NicCo
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
Salvatore47
Utente senior
Utente senior
Posts: 408
Joined: 17 November 2008, 18:38
OpenMandriva: 2011.0 - 64bit
Kernel: 3.1.6-nrj.69mib
Desktop: KDE - GNOME
country: ITALIA

Re: Kernel 3.0.0 + -NRJ and -NRJ-PAE for 2010.1, 2010.2, 201

Post by Salvatore47 »

Avvertimento
Per chi usa vmware/vmplayer, ricordo che la versione attuale 7.1.4/3.1.4 non buildano i moduli con kernel 3.0.0
Non c'è una patch per vmware/vmplayer ?

Ancora non provato.

Ciao, Salvo

User avatar
NicCo
Amministratore
Amministratore
Posts: 4745
Joined: 6 December 2007, 19:54

Re: Kernel 3.0.0 + -NRJ and -NRJ-PAE for 2010.1, 2010.2, 201

Post by NicCo »

Salvatore47 wrote:
Avvertimento
Per chi usa vmware/vmplayer, ricordo che la versione attuale 7.1.4/3.1.4 non buildano i moduli con kernel 3.0.0
Non c'è una patch per vmware/vmplayer ?

Ancora non provato.

Ciao, Salvo
NO, niente vmware per adesso! - Se ne trovassi qualcuna tu, segnamela, ciao!
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
NicCo
Amministratore
Amministratore
Posts: 4745
Joined: 6 December 2007, 19:54

Re: Kernel 3.0.0 + -NRJ and -NRJ-PAE for 2010.1, 2010.2, 201

Post by NicCo »

New ports have been completed

Mandriva 2011.0 - 32bit
http://mib.pianetalinux.org/MIB/2011.0/ ... els/3.0.0/

Mandriva 2011.0 - 64bit
http://mib.pianetalinux.org/MIB/2011.0/ ... els/3.0.0/

Mandriva 2010.2 - 64bit
http://mib.pianetalinux.org/MIB/2010.2/ ... els/3.0.0/
(for this port, we are still waiting nvidia and ati drivers, so you can install only if you use Intel or other open x.org driver)


bye, NicCo
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
verg
Utente
Utente
Posts: 107
Joined: 16 February 2011, 15:11
OpenMandriva: 2010.2
Kernel: 2.6.36.4-nrj
Desktop: kDE-4.8.4
country: Russia
Location: St. Petersburg

Re: Kernel 3.0.0 + -NRJ and -NRJ-PAE for 2010.1, 2010.2, 201

Post by verg »

MDV2011RC2+updates

Code: Select all

[root@localhost verg]# urpmi kernel-nrj-desktop-devel-latest
unable to locate package name (@kernel-nrj-desktop-devel-3.0.0-nrj.69mib-1[) in @provides@kernel-nrj-devel[== 3.0.0-nrj.69]@kernel-nrj-desktop-devel@kernel-nrj-desktop-devel-3.0.0-nrj.69mib[== 1-1:2011.0] at /usr/lib/perl5/vendor_perl/5.12.3/i386-linux-thread-multi/URPM/Resolve.pm line 1138.
[root@localhost verg]# urpmi kernel-nrj-desktop-latest
unable to locate package name (@kernel-nrj-desktop-latest-3.0.0[) in @provides@kernel-nrj-desktop-latest[== 3.0.0-nrj.69:2011.0]@kernel-nrj-desktop-latest[== 3.0.0-nrj.69] at /usr/lib/perl5/vendor_perl/5.12.3/i386-linux-thread-multi/URPM/Resolve.pm line 1138.

Code: Select all

[root@localhost verg]# urpmf -mf kernel-nrj
kernel-nrj-doc-3.0.0-nrj.69-mib2011.0.noarch:kernel3
kernel-nrj-source-latest-3.0.0-nrj.69-mib.i686:kernel3
kernel-nrj-desktop-devel-latest-3.0.0-nrj.69-mib.i686:kernel3
kernel-nrj-desktop-3.0.0-nrj.69mib-1-1-mib2011.0.i686:kernel3
kernel-nrj-source-3.0.0-nrj.69mib-1-1-mib2011.0.i686:kernel3
kernel-nrj-desktop-devel-3.0.0-nrj.69mib-1-1-mib2011.0.i686:kernel3
kernel-nrj-desktop-latest-3.0.0-nrj.69-mib2011.0.i686:kernel3

User avatar
NicCo
Amministratore
Amministratore
Posts: 4745
Joined: 6 December 2007, 19:54

Re: Kernel 3.0.0 + -NRJ and -NRJ-PAE for 2010.1, 2010.2, 201

Post by NicCo »

Code: Select all

urpmi.addmedia --update Kernel_3.0.0 http://mib.pianetalinux.org/MIB/2011.0/32/projects/kernels/3.0.0/
Don't use latest metapackes, use these commands

Code: Select all

urpmi --auto kernel-firmware
urpmi --auto kernel-nrj-desktop-devel-3.0.0
urpmi --auto kernel-nrj-desktop-3.0.0
#
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
verg
Utente
Utente
Posts: 107
Joined: 16 February 2011, 15:11
OpenMandriva: 2010.2
Kernel: 2.6.36.4-nrj
Desktop: kDE-4.8.4
country: Russia
Location: St. Petersburg

Re: Kernel 3.0.0 + -NRJ and -NRJ-PAE for 2010.1, 2010.2, 201

Post by verg »

I think you understand this:

Code: Select all

[root@localhost verg]# urpmi.addmedia --update Kernel_3.0.0 http://mib.pianetalinux.org/MIB/2011.0/32/projects/kernels/3.0.0/
добавляется источник «Kernel_3.0.0»
    http://mib.pianetalinux.org/MIB/2011.0/32/projects/kernels/3.0.0/media_info/synthesis.hdlist.cz

[root@localhost verg]# urpmi --auto kernel-firmware
Пакет kernel-firmware-20110314-2-mdv2011.0.noarch уже установлен   (package already installed)

[root@localhost verg]# urpmi --auto kernel-nrj-desktop-devel-3.0.0
Нет пакета с названием kernel-nrj-desktop-devel-3.0.0 
Следующие пакеты содержат kernel-nrj-desktop-devel-3.0.0: kernel-nrj-desktop-devel-3.0.0-nrj.69mib-1
Чтобы выбрать все, используйте параметр «-a»

[root@localhost verg]# urpmi --auto kernel-nrj-desktop-devel-3.0.0 -a
unable to locate package name (@kernel-nrj-desktop-devel-3.0.0-nrj.69mib-1[) in @provides@kernel-nrj-devel[== 3.0.0-nrj.69]@kernel-nrj-desktop-devel@kernel-nrj-desktop-devel-3.0.0-nrj.69mib[== 1-1:2011.0] at /usr/lib/perl5/vendor_perl/5.12.3/i386-linux-thread-multi/URPM/Resolve.pm line 1138.

[root@localhost verg]# urpmi --auto kernel-nrj-desktop-devel-3.0.0-nrj.69mib-1 -a
unable to locate package name (@kernel-nrj-desktop-devel-3.0.0-nrj.69mib-1[) in @provides@kernel-nrj-devel[== 3.0.0-nrj.69]@kernel-nrj-desktop-devel@kernel-nrj-desktop-devel-3.0.0-nrj.69mib[== 1-1:2011.0] at /usr/lib/perl5/vendor_perl/5.12.3/i386-linux-thread-multi/URPM/Resolve.pm line 1138.
Pulfer said that he packed hdlist's in mdv2010.2 http://unixforum.org/index.php?s=&showt ... &p=1172052
May be this . . . :roll:
Will download packages manually.
Installed properly from the local place:

Code: Select all

[root@localhost verg]# urpmi --auto kernel-nrj-desktop-devel-3.0.0-nrj.69mib-1-1-mib2011.0.i686.rpm


устанавливается kernel-nrj-desktop-devel-3.0.0-nrj.69mib-1-1-mib2011.0.i686.rpm
Подготовка...                    #########################################################################################################
      1/1: kernel-nrj-desktop-devel-3.0.0-nrj.69mib
                                 #########################################################################################################
[root@localhost verg]# urpmi --auto kernel-nrj-desktop-3.0.0-nrj.69mib-1-1-mib2011.0.i686.rpm


устанавливается kernel-nrj-desktop-3.0.0-nrj.69mib-1-1-mib2011.0.i686.rpm
Подготовка...                    #########################################################################################################
      1/1: kernel-nrj-desktop-3.0.0-nrj.69mib
                                 #########################################################################################################
I: *** Including module: dash ***
I: *** Including module: i18n ***
I: *** Including module: rpmversion ***
I: *** Including module: network ***
W: Possible missing firmware "prism2_ru.fw" for kernel module "prism2_usb.ko"
W: Possible missing firmware "symbol_sp24t_sec_fw" for kernel module "orinoco.ko"
W: Possible missing firmware "symbol_sp24t_prim_fw" for kernel module "orinoco.ko"
W: Possible missing firmware "prism_ap_fw.bin" for kernel module "orinoco.ko"
W: Possible missing firmware "prism_sta_fw.bin" for kernel module "orinoco.ko"
W: Possible missing firmware "iwmc3200wifi-lmac-sdio.bin" for kernel module "iwmc3200wifi.ko"
W: Possible missing firmware "iwmc3200wifi-calib-sdio.bin" for kernel module "iwmc3200wifi.ko"
W: Possible missing firmware "iwmc3200wifi-umac-sdio.bin" for kernel module "iwmc3200wifi.ko"
W: Possible missing firmware "atmel_at76c504a_2958.bin" for kernel module "atmel.ko"
W: Possible missing firmware "atmel_at76c504_2958.bin" for kernel module "atmel.ko"
W: Possible missing firmware "atmel_at76c504-wpa.bin" for kernel module "atmel.ko"
W: Possible missing firmware "ctfw_cna.bin" for kernel module "bna.ko"
W: Possible missing firmware "bnx2x/bnx2x-e2-6.2.9.0.fw" for kernel module "bnx2x.ko"
W: Possible missing firmware "bnx2x/bnx2x-e1h-6.2.9.0.fw" for kernel module "bnx2x.ko"
W: Possible missing firmware "bnx2x/bnx2x-e1-6.2.9.0.fw" for kernel module "bnx2x.ko"
I: *** Including module: ifcfg ***
I: *** Including module: plymouth ***
W: Possible missing firmware "radeon/SUMO2_me.bin" for kernel module "radeon.ko"
W: Possible missing firmware "radeon/SUMO2_pfp.bin" for kernel module "radeon.ko"                                                           
W: Possible missing firmware "radeon/SUMO_me.bin" for kernel module "radeon.ko"                                                             
W: Possible missing firmware "radeon/SUMO_pfp.bin" for kernel module "radeon.ko"                                                            
W: Possible missing firmware "nouveau/fuc41ad" for kernel module "nouveau.ko"                                                               
W: Possible missing firmware "nouveau/fuc41ac" for kernel module "nouveau.ko"                                                               
W: Possible missing firmware "nouveau/fuc409d" for kernel module "nouveau.ko"                                                               
W: Possible missing firmware "nouveau/fuc409c" for kernel module "nouveau.ko"                                                               
W: Possible missing firmware "nouveau/nvc4_fuc41ad" for kernel module "nouveau.ko"                                                          
W: Possible missing firmware "nouveau/nvc4_fuc41ac" for kernel module "nouveau.ko"                                                          
W: Possible missing firmware "nouveau/nvc4_fuc409d" for kernel module "nouveau.ko"
W: Possible missing firmware "nouveau/nvc4_fuc409c" for kernel module "nouveau.ko"
W: Possible missing firmware "nouveau/nvc3_fuc41ad" for kernel module "nouveau.ko"
W: Possible missing firmware "nouveau/nvc3_fuc41ac" for kernel module "nouveau.ko"
W: Possible missing firmware "nouveau/nvc3_fuc409d" for kernel module "nouveau.ko"
W: Possible missing firmware "nouveau/nvc3_fuc409c" for kernel module "nouveau.ko"
W: Possible missing firmware "nouveau/nvc0_fuc41ad" for kernel module "nouveau.ko"
W: Possible missing firmware "nouveau/nvc0_fuc41ac" for kernel module "nouveau.ko"
W: Possible missing firmware "nouveau/nvc0_fuc409d" for kernel module "nouveau.ko"
W: Possible missing firmware "nouveau/nvc0_fuc409c" for kernel module "nouveau.ko"
I: *** Including module: btrfs ***
I: *** Including module: crypt ***
I: *** Including module: dm ***
I: Skipping udev rule: 64-device-mapper.rules
I: *** Including module: dmraid ***
I: Skipping udev rule: 64-device-mapper.rules
I: *** Including module: dmsquash-live ***
I: *** Including module: kernel-modules ***
W: Possible missing firmware "cbfw_fc.bin" for kernel module "bfa.ko"
W: Possible missing firmware "ctfw_cna.bin" for kernel module "bfa.ko"
W: Possible missing firmware "ctfw_fc.bin" for kernel module "bfa.ko"
W: Possible missing firmware "isci/isci_firmware.bin" for kernel module "isci.ko"
W: Possible missing firmware "aic94xx-seq.fw" for kernel module "aic94xx.ko"
I: *** Including module: lvm ***
I: Skipping udev rule: 64-device-mapper.rules
I: *** Including module: mdraid ***
I: *** Including module: fcoe ***
I: *** Including module: nfs ***
I: *** Including module: resume ***
I: *** Including module: rootfs-block ***
I: *** Including module: terminfo ***
I: *** Including module: udev-rules ***
I: Skipping udev rule: 50-udev.rules
I: Skipping udev rule: 95-late.rules
I: *** Including module: aufs-mount ***
I: *** Including module: base ***
I: *** Including modules done ***
I: Wrote /boot/initrd-3.0.0-desktop-nrj.69mib.img:
I: -rw-r--r-- 1 root root 31267838 Июл 28 02:52 /boot/initrd-3.0.0-desktop-nrj.69mib.img
Необходимо перезапустить компьютер для kernel-nrj-desktop-3.0.0-nrj.69mib
Seems all worked fine :D +known NM-notifications bug (about broken connection)

Code: Select all

[verg@localhost ~]$ uname -a
Linux localhost.localdomain 3.0.0-desktop-nrj.69mib #1 SMP PREEMPT Wed Jul 27 13:22:00 MSD 2011 i686 i686 i386 GNU/Linux
Last edited by verg on 31 July 2011, 18:48, edited 1 time in total.

Post Reply