Kernel 3.0.0 + -NRJ and -NRJ-PAE for 2010.1, 2010.2, 2011.0

Latest shouts directly from our packagers and call for public testing MIB packages
User avatar
polka
Utente junior
Utente junior
Posts: 90
Joined: 3 November 2008, 0:16
OpenMandriva: 2011
Kernel: 3.0.3nrj
Desktop: KDE
country: Italia
Location: Ortona (Chieti)

Re: Kernel 3.0.0 + -NRJ and -NRJ-PAE for 2010.1, 2010.2, 201

Post by polka »

Salve. Il 29 luglio ho chiesto come installare il Kernel 3.0 su un portatile Acer con 2010.2 32 bit.
NiCco ha gentimente risposto e seguendo i comandi suggeriti ho installato il Kernel 3.0 che funziona perfettamente.
Ora vorrei fare lo stesso sul fisso a 64 bit che però monta una scheda video inegrata AMD Radeon HD 3300
Quello che trovo su MCC - Hardware - Configura il sistema grafico è: ATI Radeon HD 2000 and later(radeon/fglrx)
E' possibile avere la stessa semplice guida per questo nuovo upgrade?
Mi sono letto più volte tutti i messaggi sul sito, ma non riesco a seguire tutti i passaggi.
Grazie.
Ciao
Fisso = MDV 2011 x86_64 - Kernel 3.0.3 nrj / Portatile = Acer extensa 5220 MDV 2011 32b - 3.0.3 nrj

User avatar
NicCo
Amministratore
Amministratore
Posts: 4745
Joined: 6 December 2007, 19:54

Re: Kernel 3.0.0 + -NRJ and -NRJ-PAE for 2010.1, 2010.2, 201

Post by NicCo »

Il primo msg di questo Topic è stato modificato e semplificato, vai a vedere:
adesso contiene i comandi da eseguire per aggiornare tutto, kernel, firmwares, drivers



Per quanto riguarda ATI, sono presenti i driver 8.861 con patch per kernel 3.0, che io avevo testato a vista monitorandone l'installazione sulla finestra di terminale e di buildare sul kernel 3.0.0 buildano e sembrano inserire i file e far tutto correttamente, ma non ho potuto testarli praticamente perchè non ho scheda ATI.

È stato riportato da un utente Doom-X una schermata nera con la sua Ati, quindi non so se il problema è limitato al suo caso o è generale

Sono usciti i driver 8.872 che ufficialmente supportano il kernel 3.0.0 senza bisogno di patch, quindi forse sarebe meglio aspettare il porting di questa versione


Ciao, NicCo
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
andreas
Utente
Utente
Posts: 281
Joined: 1 November 2008, 20:03

Re: Kernel 3.0.0 + -NRJ and -NRJ-PAE for 2010.1, 2010.2, 201

Post by andreas »

Mah, Almeno nel mio caso hanno funzionato bene: mi è addirittura sparito un fastidioso flag che diceva Hardware incompatibile, anche se poi funzionava tutto a dovere..
AndreaS

Procio Intel i7-4930k, mobo Asus X79-Deluxe, Adaptec raid 7805, Nvidia Quadro 6000 - Rosa Fresh R3 X64

User avatar
tobal
Collaboratore
Collaboratore
Posts: 248
Joined: 17 May 2009, 19:04
ROSA: 2012.1
OpenMandriva: -
Kernel: 3.9.11-nr-laptop
Desktop: KDE ROSA 4.11.0
country: España
Location: Spain
Contact:

Re: Kernel 3.0.0 + -NRJ and -NRJ-PAE for 2010.1, 2010.2, 201

Post by tobal »

Mdv 2011.0 32 bits very very very very bad
No X, only if i enter from grub with F3+Modos Seguros
If enter in this way, my touchpad not work right, too

Possible causes:

Plymouth
Bootsplash
Grub

I have executed this from official mdv kernel and no X too

Code: Select all

plymouth-set-default-theme --rebuild-initrd Mandriva-Free
Actually, i will must reinstall mdv 2011 again in my laptop.
Last edited by tobal on 5 August 2011, 17:59, edited 1 time in total.

User avatar
braytac
Utente junior
Utente junior
Posts: 18
Joined: 2 April 2011, 8:08
OpenMandriva: 2010.2
Kernel: 2.6.38.2
Desktop: lxde

Re: Kernel 3.0.0 + -NRJ and -NRJ-PAE 2010.2->remaster fail

Post by braytac »

braytac wrote:To make a live CD with kernel 3.0, this happens :(

Image

until 2.6.38.8, it work fine :| , only kernel was changed to 3.0.

User avatar
NicCo
Amministratore
Amministratore
Posts: 4745
Joined: 6 December 2007, 19:54

Re: Kernel 3.0.0 + -NRJ and -NRJ-PAE for 2010.1, 2010.2, 201

Post by NicCo »

@braytac
I've already read your previous msg about livecd

but this is the kernel topic and not the livecd one
you must write in the livecd forum or home page

The problem is in livecd needing to be properly modified, patched and updated for kernel 3.0.0!

so your msg had and has not sense here, I can't help
i am not livecd programmer or maintainer, or involved!

To understand:
e.g: if with kernel 3.0.0 the program vmware 7.1.4 and/or vmplayer 3.1.4 don't work anymore
i can't do anything in the kernel, i only have to wait for vmware update supporting new kernel
a new version vmware 7.1.5 / vmplayer 3.1.5 is needed for kernel 3.0.0, but I can't change kernel 3.0.0 to adapt it to vmware stuff
you can search with google, and there are many people searching now the right patch for vmware 7.1.4 or for an official update:
they don't search or even think to modify the kernel, or saying to Linus Torvalds:
go and remove some new changes & features in 3.0.0 because I have problems with vmware ;)

The same happens with xorg-server, proprietary video drivers, some external (dkms-xxx) wifi drivers:
for this reason i prepared some new and and the most recent nvidia & ati drivers, the older dont build with kernel 3.0.x
but I can't modify the kernel itself, to trasform it as full compatible with all old and incompatible proprietary drivers or programs (livecd)...

Hoping you have understood,
bye, NicCo
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
tobal
Collaboratore
Collaboratore
Posts: 248
Joined: 17 May 2009, 19:04
ROSA: 2012.1
OpenMandriva: -
Kernel: 3.9.11-nr-laptop
Desktop: KDE ROSA 4.11.0
country: España
Location: Spain
Contact:

Re: Kernel 3.0.0 + -NRJ and -NRJ-PAE for 2010.1, 2010.2, 201

Post by tobal »

This is the bug i obtained when i installed kernel 3.0

Code: Select all

I: *** Including module: dash ***
I: *** Including module: i18n ***
I: *** Including module: rpmversion ***
I: *** Including module: network ***
W: Possible missing firmware "ctfw_cna.bin" for kernel module "bna.ko"
W: Possible missing firmware "bnx2x/bnx2x-e2-6.2.9.0.fw" for kernel module "bnx2x.ko"
W: Possible missing firmware "bnx2x/bnx2x-e1h-6.2.9.0.fw" for kernel module "bnx2x.ko"
W: Possible missing firmware "bnx2x/bnx2x-e1-6.2.9.0.fw" for kernel module "bnx2x.ko"
W: Possible missing firmware "atmel_at76c504a_2958.bin" for kernel module "atmel.ko"
W: Possible missing firmware "atmel_at76c504_2958.bin" for kernel module "atmel.ko"
W: Possible missing firmware "atmel_at76c504-wpa.bin" for kernel module "atmel.ko"
W: Possible missing firmware "iwmc3200wifi-lmac-sdio.bin" for kernel module "iwmc3200wifi.ko"
W: Possible missing firmware "iwmc3200wifi-calib-sdio.bin" for kernel module "iwmc3200wifi.ko"
W: Possible missing firmware "iwmc3200wifi-umac-sdio.bin" for kernel module "iwmc3200wifi.ko"
W: Possible missing firmware "symbol_sp24t_sec_fw" for kernel module "orinoco.ko"
W: Possible missing firmware "symbol_sp24t_prim_fw" for kernel module "orinoco.ko"
W: Possible missing firmware "prism_ap_fw.bin" for kernel module "orinoco.ko"
W: Possible missing firmware "prism_sta_fw.bin" for kernel module "orinoco.ko"
W: Possible missing firmware "prism2_ru.fw" for kernel module "prism2_usb.ko"
I: *** Including module: ifcfg ***
I: *** Including module: plymouth ***
W: Possible missing firmware "radeon/SUMO2_me.bin" for kernel module "radeon.ko"
W: Possible missing firmware "radeon/SUMO2_pfp.bin" for kernel module "radeon.ko"
W: Possible missing firmware "radeon/SUMO_me.bin" for kernel module "radeon.ko"
W: Possible missing firmware "radeon/SUMO_pfp.bin" for kernel module "radeon.ko"
W: Possible missing firmware "nouveau/fuc41ad" for kernel module "nouveau.ko"
W: Possible missing firmware "nouveau/fuc41ac" for kernel module "nouveau.ko"
W: Possible missing firmware "nouveau/fuc409d" for kernel module "nouveau.ko"
W: Possible missing firmware "nouveau/fuc409c" for kernel module "nouveau.ko"
W: Possible missing firmware "nouveau/nvc4_fuc41ad" for kernel module "nouveau.ko"
W: Possible missing firmware "nouveau/nvc4_fuc41ac" for kernel module "nouveau.ko"
W: Possible missing firmware "nouveau/nvc4_fuc409d" for kernel module "nouveau.ko"
W: Possible missing firmware "nouveau/nvc4_fuc409c" for kernel module "nouveau.ko"
W: Possible missing firmware "nouveau/nvc3_fuc41ad" for kernel module "nouveau.ko"
W: Possible missing firmware "nouveau/nvc3_fuc41ac" for kernel module "nouveau.ko"
W: Possible missing firmware "nouveau/nvc3_fuc409d" for kernel module "nouveau.ko"
W: Possible missing firmware "nouveau/nvc3_fuc409c" for kernel module "nouveau.ko"
W: Possible missing firmware "nouveau/nvc0_fuc41ad" for kernel module "nouveau.ko"
W: Possible missing firmware "nouveau/nvc0_fuc41ac" for kernel module "nouveau.ko"
W: Possible missing firmware "nouveau/nvc0_fuc409d" for kernel module "nouveau.ko"
W: Possible missing firmware "nouveau/nvc0_fuc409c" for kernel module "nouveau.ko"
I: *** Including module: crypt ***
I: *** Including module: dm ***
I: Skipping udev rule: 64-device-mapper.rules
I: *** Including module: dmraid ***
I: Skipping udev rule: 64-device-mapper.rules
I: *** Including module: dmsquash-live ***
I: *** Including module: kernel-modules ***
W: Possible missing firmware "cbfw_fc.bin" for kernel module "bfa.ko"
W: Possible missing firmware "ctfw_cna.bin" for kernel module "bfa.ko"
W: Possible missing firmware "ctfw_fc.bin" for kernel module "bfa.ko"
W: Possible missing firmware "isci/isci_firmware.bin" for kernel module "isci.ko"
W: Possible missing firmware "aic94xx-seq.fw" for kernel module "aic94xx.ko"
I: *** Including module: lvm ***
I: Skipping udev rule: 64-device-mapper.rules
I: *** Including module: mdraid ***
I: *** Including module: fcoe ***
I: *** Including module: nfs ***
I: *** Including module: resume ***
I: *** Including module: rootfs-block ***
I: *** Including module: terminfo ***
I: *** Including module: udev-rules ***
I: Skipping udev rule: 50-udev.rules
I: Skipping udev rule: 95-late.rules
I: *** Including module: aufs-mount ***
I: *** Including module: base ***
I: *** Including modules done ***
I: Wrote /boot/initrd-3.0.0-desktop-nrj.69mib.img:
I: -rw-r--r-- 1 root root 28052392 ago  3 11:40 /boot/initrd-3.0.0-desktop-nrj.69mib.img
It's the same message if i execute this:

Code: Select all

 plymouth-set-default-theme --rebuild-initrd Mandriva-Free 
nicco said to me that this message is no problem, but it is not so

User avatar
braytac
Utente junior
Utente junior
Posts: 18
Joined: 2 April 2011, 8:08
OpenMandriva: 2010.2
Kernel: 2.6.38.2
Desktop: lxde

Re: Kernel 3.0.0 + -NRJ and -NRJ-PAE for 2010.1, 2010.2, 201

Post by braytac »

Understood NicCo ;).I just commented on the problem, the same way that people reports problems with proprietary drivers, etc..
Thanks!

User avatar
NicCo
Amministratore
Amministratore
Posts: 4745
Joined: 6 December 2007, 19:54

Re: Kernel 3.0.0 + -NRJ and -NRJ-PAE for 2010.1, 2010.2, 201

Post by NicCo »

@braytac
There were some saying that starting from 3.0.0, some old programs could have some unexpected problems:
the reason could be in a stupid thing:
- up to kernel 2.6.39.X, the version number was 4 digit
- starting from kernel 3.0.X this number has only 3 digit
perhaps this can lead to some problems with certain old programs

Fedora seems wishing adopting a different scheme version to avoid any possible problems:
they are going to rename 3.0.0 as 2.6.40.x, 3.1.x as 2.6.41.x, and so on

bye, NicCo
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
tobal
Collaboratore
Collaboratore
Posts: 248
Joined: 17 May 2009, 19:04
ROSA: 2012.1
OpenMandriva: -
Kernel: 3.9.11-nr-laptop
Desktop: KDE ROSA 4.11.0
country: España
Location: Spain
Contact:

Re: Kernel 3.0.0 + -NRJ and -NRJ-PAE for 2010.1, 2010.2, 201

Post by tobal »

At last kernel 3.0.0 works fine in my PC
Pay attention please, it is very important!!!

I have installed nvidia driver from mdv repositories. I had configurated drivers with XFDrake, but it not configure the drivers right. I started everytime my laptop and appeared the nvidia shoot image, and i thought i had all good but not so.
First step, look if you have a tmp folder in your home directory, if it is not, then make it ;)
Second step, go to XFDrake and install your nvidia correctly.
Finally reboot your laptop or pc

That's all :)

Thanks and exvcuse my bad humour nicco :oops: :oops: :oops:

Bye

User avatar
NicCo
Amministratore
Amministratore
Posts: 4745
Joined: 6 December 2007, 19:54

Re: Kernel 3.0.0 + -NRJ and -NRJ-PAE for 2010.1, 2010.2, 201

Post by NicCo »

@Tobal
I can understand that having the PC with OS not more bootable is not a thing making happy,
and that you are a little too impulsive and easy to lose your temper,
but also smart and stubborn enough to try again and find the solution yourself... :D

I'm very happy you found the solution to make the kernel 3.0.0 working also in your laptop pc,

but in the end what was the problem? A lacking temp folder in your home?


Can you test now your sensor's temp and how much your battery last
- with kernel 2.6.38.7
- with kernel 3.0.0

All other guys with new kernel 3 we have the feedback apart ourselves, report:
the temp is much lower and laptop is cooler while the battery is lasting about the double



bye, NicCo
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
verg
Utente
Utente
Posts: 107
Joined: 16 February 2011, 15:11
OpenMandriva: 2010.2
Kernel: 2.6.36.4-nrj
Desktop: kDE-4.8.4
country: Russia
Location: St. Petersburg

Re: Kernel 3.0.0 + -NRJ and -NRJ-PAE for 2010.1, 2010.2, 201

Post by verg »

Successfuly got upgrade from Mandriva2010.2Free32bit(KDE clean install) to Mandriva2011.0 and also installed kernel-3.0.0-nrj on it(no problems at all).
So no systemd and networkmanager in system use.
Net-applet are used for network-up and seems i need patched drakx-net package =)
Image

With default kernel 38.7 net-applet is OK.
Last edited by verg on 5 August 2011, 18:32, edited 1 time in total.

User avatar
astragalo
Collaboratore
Collaboratore
Posts: 652
Joined: 7 December 2007, 18:29
ROSA: Rosa R11.1
OpenMandriva: -
Kernel: 4.15.xx
Desktop: Plasma5
country: Italia

Re: Kernel 3.0.0 + -NRJ and -NRJ-PAE for 2010.1, 2010.2, 201

Post by astragalo »

It's ready in the same repo.

Bye.
L'erba cattiva non muore mai!!! ;)
:D :D :D

User avatar
verg
Utente
Utente
Posts: 107
Joined: 16 February 2011, 15:11
OpenMandriva: 2010.2
Kernel: 2.6.36.4-nrj
Desktop: kDE-4.8.4
country: Russia
Location: St. Petersburg

Re: Kernel 3.0.0 + -NRJ and -NRJ-PAE for 2010.1, 2010.2, 201

Post by verg »

Yes, this is a good idea to use drakx-net v.0.90 from 2010.2 repo =)
Because the system really don't need upgraded drakx-net v.0.93
But i have to put these packages to urpmi skip list. :mrgreen: And force installation for drakx-net-applet0.93
Last edited by verg on 5 August 2011, 18:56, edited 1 time in total.

User avatar
tobal
Collaboratore
Collaboratore
Posts: 248
Joined: 17 May 2009, 19:04
ROSA: 2012.1
OpenMandriva: -
Kernel: 3.9.11-nr-laptop
Desktop: KDE ROSA 4.11.0
country: España
Location: Spain
Contact:

Re: Kernel 3.0.0 + -NRJ and -NRJ-PAE for 2010.1, 2010.2, 201

Post by tobal »

verg wrote:Yes, this is a good idea to use drakx-net v.0.90 from 2010.2 repo =)
Because the system really don't need upgraded drakx-net v.0.93
But i have to put these packages to urpmi skip list. :mrgreen:
Well, the patch is applied in the 2011.0 net-applet but it seems not work. Anyway, this bug is a nonsense, and net-applet not commin' installed by default with 2011, because it uses network-manager and plasma-networkmanager, and it appears as connected. Mandriva not have a good program with drakx-net, a lot of bugs.

Post Reply