MIB Mandriva 2010.3 repositories

Latest shouts directly from our packagers and call for public testing MIB packages
User avatar
Pulfer
Collaboratore
Collaboratore
Posts: 291
Joined: 30 July 2008, 3:10
ROSA: 2012.1 i686
OpenMandriva: -
Kernel: 3.10.x
Desktop: KDE 4.10.x
country: Russia
Location: Vladivostok

Re: MIB Mandriva 2010.3 repositories

Post by Pulfer »

codicem wrote:
rugyada wrote:Ciao Codicem,

Pulfer suggerisce di aggiornare con l'opzione --debug:
qui il link dell'output:

Code: Select all

urpmi.update -a
urpmi --auto-select --debug
Looks like you don't have Main & Contrib Backports enabled. So urpmi cannot find libvpx1 package.
Core i7-3770 / 4 Gb RAM / Gigabyte Z77-D3H / ASUS ENGTS250 / Rosa 2012.1 i686

User avatar
rugyada
Amministratore
Amministratore
Posts: 1545
Joined: 14 July 2008, 22:58
ROSA: ROSA.Fresh R8 64bit
OpenMandriva: OMLx 4.1 64bit
Kernel: kernel-relea current
Desktop: KDE tutta la vita
country: Italy

Re: MIB Mandriva 2010.3 repositories

Post by rugyada »

Pulfer wrote:Looks like you don't have Main & Contrib Backports enabled. So urpmi cannot find libvpx1 package.
Codicem, sembra che tu non abbia i repo Main e Contrib Backports abilitati.

Vedi la nota di NicCo nel primo post:
NicCo wrote:Come aggiungere i repository MIB 2010.3 su Mandriva 2010.2
Tu devi già avere i soliti /main, /contrib, /nonfree completi dei rami /release /updates e /backports configurati per mdv 2010.2
Image
ciauu ciauu, ruru

MIB... e le stelle stanno a guardare.
«I grandi spiriti hanno sempre incontrato violenta opposizione da parte delle menti mediocri.»
(Albert Einstein)

User avatar
ninarello19
Utente
Utente
Posts: 222
Joined: 4 March 2009, 15:56
OpenMandriva: 2010.2
Kernel: 2.6.38.2-desktop-nrj
Desktop: KDE 4.5.5

Re: MIB Mandriva 2010.3 repositories

Post by ninarello19 »

Ho installato Mib Mandriva 2010.3 repositories ho risolto alcuni problemi durante linstallazione cancellando le seguenti librerie, perchè andavano in conflitto.
- libxcb-devel -1.6
- libxau6-devel-1.0.5
- libxdmcp6-devel-1.0.3

Ho installato manualmente i driver stabili nvidia-current 295.49,
perchè altrimenti mi voleva installare la versione 300.xx beta...
Ho dovuto disabilitare il repo /expert 64:
Credo che dovreste rimuovere i driver Beta dal repo /experts

L'installazione è andata bene ed al riavvio tutto OK

Ho dovuto cancellare la cartella . pulse.

L'unica cosa che in atto non funziona è l'audio con VLC.
Ho disinstllato vlc 1.1.13 ed ho provato ad installare l'ultima versione 2.0.1 ma non si installa e mi da questo messaggfio di errore.:

Code: Select all

[root@localhost utente]# urpmi vlc
Uno dei pacchetti richiesti non può essere installato:
vlc-2.0.1-69.1mib2010.2.x86_64 (perché non è soddisfatto libmatroska.so.5()(64bit))
Continuo comunque l'Installazione? (S/n) s
Questa libreria non la trovo. Come posso risolvere il problema?
Grazie
ninarello19
=========
RosaDesktop.Fresh 2012.1 R1 - arch. x86_64 - KDE 4.10.4 MIB - Kernel 3.10.15-nrjQL-desktop-69rosa #1 SMP PREEMPT
O.S. alternativi su VMware workstation 10.0.0>>> Ubuntu, Windows XP Pro, Windows Seven e Mac come Macchine VIrtuali

User avatar
codicem
Utente
Utente
Posts: 119
Joined: 4 November 2008, 23:21
ROSA: 2012.1 x64
OpenMandriva: 2010.2 x64
Kernel: 3.1.10-d. - 3.6.10
Desktop: kde 4.8.3 - 4.9.5
country: Italy

Re: MIB Mandriva 2010.3 repositories

Post by codicem »

rugyada wrote:NicCo ha scritto:Come aggiungere i repository MIB 2010.3 su Mandriva 2010.2
Tu devi già avere i soliti /main, /contrib, /nonfree completi dei rami /release /updates e /backports configurati per mdv 2010.2
Installati diversi pacchetti, più di 300, ma ora mi si blocca con il seguente output.
Cosa fare?
Codicem
mob asus P5LD2 - n.2 hd sata 250g - ram 2 g - pentium d820 2.80GHz d-core - nvidia asus gt240 1g
Mandriva 2010.2 x86_64 - kernel 3.1.10-desktop-nrj.69mib - kde 4.8.3
RosaDesktop.Fresh 2012.1 - Kernel: 3.6.10-nrj-desktop-1rosa x86_64 - kde 4.9.5

User avatar
Pulfer
Collaboratore
Collaboratore
Posts: 291
Joined: 30 July 2008, 3:10
ROSA: 2012.1 i686
OpenMandriva: -
Kernel: 3.10.x
Desktop: KDE 4.10.x
country: Russia
Location: Vladivostok

Re: MIB Mandriva 2010.3 repositories

Post by Pulfer »

codicem wrote:
rugyada wrote:NicCo ha scritto:Come aggiungere i repository MIB 2010.3 su Mandriva 2010.2
Tu devi già avere i soliti /main, /contrib, /nonfree completi dei rami /release /updates e /backports configurati per mdv 2010.2
Installati diversi pacchetti, più di 300, ma ora mi si blocca con il seguente output.
Cosa fare?
Looks like something is wrong with urpmi:

Code: Select all

Argument "27617|25641" isn't numeric in array element at /usr/lib/perl5/vendor_perl/5.10.1/x86_64-linux-thread-multi/URPM/Resolve.pm line 1266, <STDIN> line 3.
I don't know why it happens, I had this issue only once (in one of my VirtualBox 2010.2 installations). And I remember I could fix it by installing perl-URPM-3.37.2-1.11mdv2010.2 from main/testing.
Core i7-3770 / 4 Gb RAM / Gigabyte Z77-D3H / ASUS ENGTS250 / Rosa 2012.1 i686

User avatar
NicCo
Amministratore
Amministratore
Posts: 4740
Joined: 6 December 2007, 19:54

Re: MIB Mandriva 2010.3 repositories

Post by NicCo »

@codicem

Ho finito un'altro upgrade ieri, con repo MIB 2010.2 gia presenti, ho aggiunto i 2010.3 e ho aggiornato
Ho dovuto cancellare il vecchio vlc che mi generava parecchi conflitti, per proseguire poi con l'aggiornamento
Non saprei se questo risolve tutto, ma almeno toglie tantissimi nodi riferiti a vlc ed ai suoi conflitti con l'update
Alla fine ho reinstallato il vlc e mi sono ritrovato la versione 2.0.1 > ho dovuto resettare la cartella /$home/.config/vlc

Code: Select all

urpme -a vlc
Yesterday I finished another upgrade, an old installation with MIB 2010.2 where i added MIB 2010.3
I had to delete the old vlc before i could go on with the update, i had many conflicting problems with vlc
I don't know if removing vlc resolves all problems, but at least remove many conflicting rpms with update
At the end, i reinstalled vlc and I found the new 2.0.1 > I had to reset his config deleting /$home/.config/vlc

bye, NicCo
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
promeneur
Utente senior
Utente senior
Posts: 547
Joined: 6 February 2009, 17:47
ROSA: -
OpenMandriva: 2010.3 i586
Kernel: 3.5.7 nrj dsktp pae
Desktop: MIB kde 4.8.4
country: France

Re: MIB Mandriva 2010.3 repositories

Post by promeneur »

good news

since i use mib kernel (2.6.x, ..., 3.1.6) bluedevil does not start correctly

with kernel 3.2.18 bluedevil starts correctly and is in the systray
Asus M2N, AMD Athlon 64 X2 5000+, 8 GB, Asus Nvidia 210 silent, Linksys WMP600N, Plugable USB-BT4LE Bluetooth 4.0 Adapter, lecteur multicarte Addonics AEIDDSAU, HP LaserJet 1220

User avatar
Pulfer
Collaboratore
Collaboratore
Posts: 291
Joined: 30 July 2008, 3:10
ROSA: 2012.1 i686
OpenMandriva: -
Kernel: 3.10.x
Desktop: KDE 4.10.x
country: Russia
Location: Vladivostok

Re: MIB Mandriva 2010.3 repositories

Post by Pulfer »

NicCo wrote:Yesterday I finished another upgrade, an old installation with MIB 2010.2 where i added MIB 2010.3
I had to delete the old vlc before i could go on with the update, i had many conflicting problems with vlc
I see that 2 days ago somebody packaged vlc 2.0.1-69.1mib to 2010.2 /basic repository. Maybe that's the root of the problem? We never had reports about vlc update issues earlier.
Core i7-3770 / 4 Gb RAM / Gigabyte Z77-D3H / ASUS ENGTS250 / Rosa 2012.1 i686

User avatar
NicCo
Amministratore
Amministratore
Posts: 4740
Joined: 6 December 2007, 19:54

Re: MIB Mandriva 2010.3 repositories

Post by NicCo »

The problem I had was related to old VLC 1.1.13 and 2.0.1 version conflicts, not between the two 2.0.x versions

Code: Select all

urpme -a vlc 
urpmi vlc

bye, NicCo
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
vmalav
Utente
Utente
Posts: 133
Joined: 7 December 2007, 20:26
OpenMandriva: 2010.2
Kernel: 3.2.18nrj 64
Desktop: kde 4.8.3
country: ita

Re: MIB Mandriva 2010.3 repositories

Post by vmalav »

As for nicco also in my 2010.2 (with 2010.3 repos) problem solved deleting old vlc pakages and installing
urpmi task-vlc.
Just another question:
what we have to do with 2010.2 repos (maybe we have to delete them?)
2010.2 x86_64 athlon 64x2 4200+ ram 4G nvidia 6200 256M

User avatar
codicem
Utente
Utente
Posts: 119
Joined: 4 November 2008, 23:21
ROSA: 2012.1 x64
OpenMandriva: 2010.2 x64
Kernel: 3.1.10-d. - 3.6.10
Desktop: kde 4.8.3 - 4.9.5
country: Italy

Re: MIB Mandriva 2010.3 repositories

Post by codicem »

ok, ho rimosso Vlc ma anche Gimp2.6 e l'installazione è andata a buon fine.
Poi ho reinstallato sia Vlc che Gimp 2.8.
Sembra tutto Ok.
L'unica cosa e che mi appare sempre l'aggiornamento di drakguard-0.7.7-4mdv2010.2.noarch.
Una volta aggiornato, mi appare l'aggiornamento di drakguard-policy-0.7.7-1mdv2010.2.noarch e dopodichè di nuovo l'aggiornamento di drakguard-0.7.7-4mdv2010.2.noarch.
Mi date qualche spiegazione.
Codicem
mob asus P5LD2 - n.2 hd sata 250g - ram 2 g - pentium d820 2.80GHz d-core - nvidia asus gt240 1g
Mandriva 2010.2 x86_64 - kernel 3.1.10-desktop-nrj.69mib - kde 4.8.3
RosaDesktop.Fresh 2012.1 - Kernel: 3.6.10-nrj-desktop-1rosa x86_64 - kde 4.9.5

User avatar
NicCo
Amministratore
Amministratore
Posts: 4740
Joined: 6 December 2007, 19:54

Re: MIB Mandriva 2010.3 repositories

Post by NicCo »

È un divertente loop che è presente da tanto tempo sui bckport mandriva, e nessuno si è deciso ancora a sistemarlo

per evitare l'aggiornamento di drakguard eseguire da root

Code: Select all

echo "/^drakguard/" >> /etc/urpmi/skip.list
oppure

Code: Select all

echo "/^drakguard-policy/" >> /etc/urpmi/skip.list

Ciao, NicCo
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
Pulfer
Collaboratore
Collaboratore
Posts: 291
Joined: 30 July 2008, 3:10
ROSA: 2012.1 i686
OpenMandriva: -
Kernel: 3.10.x
Desktop: KDE 4.10.x
country: Russia
Location: Vladivostok

Re: MIB Mandriva 2010.3 repositories

Post by Pulfer »

vmalav wrote:what we have to do with 2010.2 repos (maybe we have to delete them?)
We are still porting useful packages from 2010.2 repository to official Contrib/Non-Free and MIB 2010.3 basic.

2010.3 repositories are still considered to be "experimental" and "in progress".
Core i7-3770 / 4 Gb RAM / Gigabyte Z77-D3H / ASUS ENGTS250 / Rosa 2012.1 i686

User avatar
ninarello19
Utente
Utente
Posts: 222
Joined: 4 March 2009, 15:56
OpenMandriva: 2010.2
Kernel: 2.6.38.2-desktop-nrj
Desktop: KDE 4.5.5

Re: MIB Mandriva 2010.3 repositories

Post by ninarello19 »

Con gli aggiornamenti di oggi non sono stati installati i seguenti pacchetti e mi ha dato il seguente messagggio :

Code: Select all

root@localhost utente]# urpmi --auto-select
Alcuni dei pacchetti richiesti non possono essere installati:
lib64totem-plparser-mini17-2.32.6-69.1mib2010.2.x86_64 (perché non è soddisfatto libquvi.so.6()(64bit))
lib64totem-plparser17-2.32.6-69.1mib2010.2.x86_64 (perché non è soddisfatto libquvi.so.6()(64bit))
Continuo comunque l'Installazione? (S/n) s
[root@localhost utente]# 
Che debbo fare ?
Grazie
Ninarello19
ninarello19
=========
RosaDesktop.Fresh 2012.1 R1 - arch. x86_64 - KDE 4.10.4 MIB - Kernel 3.10.15-nrjQL-desktop-69rosa #1 SMP PREEMPT
O.S. alternativi su VMware workstation 10.0.0>>> Ubuntu, Windows XP Pro, Windows Seven e Mac come Macchine VIrtuali

User avatar
Pulfer
Collaboratore
Collaboratore
Posts: 291
Joined: 30 July 2008, 3:10
ROSA: 2012.1 i686
OpenMandriva: -
Kernel: 3.10.x
Desktop: KDE 4.10.x
country: Russia
Location: Vladivostok

Re: MIB Mandriva 2010.3 repositories

Post by Pulfer »

ninarello19 wrote:Con gli aggiornamenti di oggi non sono stati installati i seguenti pacchetti e mi ha dato il seguente messagggio :

Code: Select all

root@localhost utente]# urpmi --auto-select
Alcuni dei pacchetti richiesti non possono essere installati:
lib64totem-plparser-mini17-2.32.6-69.1mib2010.2.x86_64 (perché non è soddisfatto libquvi.so.6()(64bit))
lib64totem-plparser17-2.32.6-69.1mib2010.2.x86_64 (perché non è soddisfatto libquvi.so.6()(64bit))
Continuo comunque l'Installazione? (S/n) s
[root@localhost utente]# 
Che debbo fare ?
You need to enable Contrib Backports, lib64quvi6 is there.
Core i7-3770 / 4 Gb RAM / Gigabyte Z77-D3H / ASUS ENGTS250 / Rosa 2012.1 i686

Post Reply