[Risolto] Riconoscimento scheda video

Installazione Mandriva/OpenMandriva e successivi aggiornamenti ufficiali
Post Reply
User avatar
polka
Utente junior
Utente junior
Posts: 90
Joined: 3 November 2008, 0:16
OpenMandriva: 2011
Kernel: 3.0.3nrj
Desktop: KDE
country: Italia
Location: Ortona (Chieti)

[Risolto] Riconoscimento scheda video

Post by polka »

Avevo una partizione non utilizzata con su MDV 2010.1 Ho deciso di rimetterlo in funzione aggiornato. Ho cambiato completamente i Repo seguendo la guida di NicCo e poi ho dato
# urpmi auto--update
Dopo qualche domanda preliminare se volevo installare dei programmi a cui ho risposto abbastanza casualmente è partito l'aggiornamento.
Dopo circa 750 programmi scaricati ho havuto la 2010.2 aggiornata e funzionante.
Poi ho voluto installare il Kernel 3.0.3 nrj per 64 bit
Ho seguito l'altra guida di NicCo. Tutto bene. Poi dice di riavviare.
Il sistema si lancia, ma a metà dell'avvio mi da una schermata bianca con solo la freccia del mouse che può essere mossa. Non risponde a nulla se non allo spegnimento totale.
La scheda video incorporata mella MB è una ATI Radeon HD 3300 che è regolarmente riconosciuta e funzionante con le altre installazioni di Mandriva sullo stesso disco.
Pensando all'accaduto mi sono ricordato che durante il riavvio ho letto, tra le varie cose che stava facendo, che ha installato(?), mettendoci parecchio tempo, i driver NVIDIA.
Tra il vario hardware che posseggo ho una scheda NVIDIA GT320. Allora l'ho montata sulla MB e fatto ripartire il il computer che ha portato a termine il lancio del sistema e che ad un sommario test funziona perfettamente.
Dato che ovviamente non posso montare o smontare la scheda secondo il SO (sempre e solo MDV) che intendo usare, chiedo:
c'è un modo per dire all'installazione del Kernel 3.0.3 che deve usare i driver per la ATI e non quelli della NVIDIA
Scusate il romanzo qui sopra, ma non sapevo come condensare tutto l'accaduto in poche righe.
Saluto in attesa di un qualche suggerimento.

P.S. Perché quando scrivo questo testo mi vengono segnalate quasi tutte le parole come errate con una sottolineatura rossa?
Grazie
Last edited by polka on 2 October 2011, 0:47, edited 1 time in total.
Fisso = MDV 2011 x86_64 - Kernel 3.0.3 nrj / Portatile = Acer extensa 5220 MDV 2011 32b - 3.0.3 nrj

User avatar
astragalo
Collaboratore
Collaboratore
Posts: 652
Joined: 7 December 2007, 18:29
ROSA: Rosa R11.1
OpenMandriva: -
Kernel: 4.15.xx
Desktop: Plasma5
country: Italia

Re: Riconoscimento scheda video

Post by astragalo »

Penso sia il correttore ortografico di FF segui le indicazioni di questa pagina. Installa e seleziona l'italiano.

http://support.mozilla.com/it/kb/Il%20c ... automatico

Per il resto non so :)

Bye.
L'erba cattiva non muore mai!!! ;)
:D :D :D

User avatar
mykol
Utente senior
Utente senior
Posts: 301
Joined: 14 January 2008, 12:13

Re: Riconoscimento scheda video

Post by mykol »

avevo un problema simile con la 2011 avviata come "live" e l'ho risolto così, in sostanza aggiungendo nomodeset (in minuscolo) sulla riga di comando al boot.

Esattamente:

compare la riga Opzioni di Boot = UUID=d3196a77 ..... splash=silent vga=788
con i tasti freccia sposta il cursore a sx della "splash=silent" -> si aggiunge uno SPAZIO e NOMODESET e si controlla che ci sia un altro spazio prima della parola successiva vga=788
invio.

Come suggerito da "stregaforyou" in questa discussione viewtopic.php?f=42&t=3033&p=17184#p17184
Mandriva 2009.1 i686 32 bit MIB, x86_64.
Mandriva 2010.0 i686 32 bit MIB

User avatar
polka
Utente junior
Utente junior
Posts: 90
Joined: 3 November 2008, 0:16
OpenMandriva: 2011
Kernel: 3.0.3nrj
Desktop: KDE
country: Italia
Location: Ortona (Chieti)

Re: [ Risolto] Riconoscimento scheda video

Post by polka »

Credo di avere risolto utilizzando "F3" al lancio di Grub poi cancellando "splash=silent" e "vga 788" e mettendo "vesa" al loro posto.
Quindi una volta lanciato il sistema e l'interfaccia grafica con MCC sono andato a correggere la scheda video mettendo quella esatta.
Poi ho risposto sì quando mi ha chiesto se volevo i driver originali. Ha scaricato i driver e gli ha compilati. Ho spento e rilanciato e pare che vada bene.
Dico spero perchè non ho ancora provato a lungo, Comunque metto risolto.
Grazie a chi mi ha dato un'idea per affrontare la situazione.
Fisso = MDV 2011 x86_64 - Kernel 3.0.3 nrj / Portatile = Acer extensa 5220 MDV 2011 32b - 3.0.3 nrj

Post Reply