Yum Package Manager Crash

About ROSA Desktop distribution and help to users
Post Reply
User avatar
cabernet
Utente junior
Utente junior
Posts: 15
Joined: 23 January 2013, 7:54
ROSA: 2013
OpenMandriva: -
Kernel: -
Desktop: KDE
country: sa

Yum Package Manager Crash

Post by cabernet »

I have found yum to be a good solid, easy to use package manager, so I thought I would install it in FRESH.
Unfortunately it fails as per the log below. Any suggestions on how to remedy this crash ?

# yum search mesa
Traceback (most recent call last):
File "/usr/bin/yum", line 29, in <module>
yummain.user_main(sys.argv[1:], exit_code=True)
File "/usr/share/yum-cli/yummain.py", line 262, in user_main
errcode = main(args)
File "/usr/share/yum-cli/yummain.py", line 88, in main
base.getOptionsConfig(args)
File "/usr/share/yum-cli/cli.py", line 228, in getOptionsConfig
self.conf
File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 863, in <lambda>
conf = property(fget=lambda self: self._getConfig(),
File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 295, in _getConfig
startupconf = config.readStartupConfig(fn, root)
File "/usr/lib/python2.7/site-packages/yum/config.py", line 872, in readStartupConfig
startupconf.releasever = _getsysver(startupconf.installroot, startupconf.distroverpkg)
File "/usr/lib/python2.7/site-packages/yum/config.py", line 1002, in _getsysver
ts = rpmUtils.transaction.initReadOnlyTransaction(root=installroot)
File "/usr/lib/python2.7/site-packages/rpmUtils/transaction.py", line 180, in initReadOnlyTransaction



read_ts.pushVSFlags((rpm._RPMVSF_NOSIGNATURES|rpm._RPMVSF_NODIGESTS))
AttributeError: 'module' object has no attribute '_RPMVSF_NOSIGNATURES'

User avatar
NicCo
Amministratore
Amministratore
Posts: 4745
Joined: 6 December 2007, 19:54

Re: Yum Package Manager Crash

Post by NicCo »

Yum is not the ROSA and/or Mandriva rpm manager,
I fear it would be rather difficult that will be fixed...
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

Post Reply