Impossible update nvidia

About ROSA Desktop distribution and help to users
Post Reply
User avatar
tobal
Collaboratore
Collaboratore
Posts: 248
Joined: 17 May 2009, 19:04
ROSA: 2012.1
OpenMandriva: -
Kernel: 3.9.11-nr-laptop
Desktop: KDE ROSA 4.11.0
country: España
Location: Spain
Contact:

Impossible update nvidia

Post by tobal »

Hi, i'm trying update nvidia drivers from MIB repo in ROSA 2012.1 64 bits:

Code: Select all

Se tienen que quitar los paquetes siguientes para poder actualizar otros:
nvidia-current-doc-html-325.08-9-rosa2012.1.x86_64
 (debido a que no se satisfizo x11-driver-video-nvidia-current == 325.08-9)
x11-driver-video-nvidia-current-325.08-9-rosa2012.1.x86_64
 (debido a que no se satisfizo kmod(nvidia-current) == 325.08)


Sorry, the following packages cannot be selected:

- nvidia-current-doc-html-325.15-69.1-mib2012.1.x86_64 (debido a que no se satisfizo x11-driver-video-nvidia-current[== 325.15-69.1])
- x11-driver-video-nvidia-current-325.15-69.1-mib2012.1.x86_64 (debido a que no se satisfizo libGL.so()(64bit), intentando promover x11-driver-video-nvidia-current)
It seems a dependencies problem

Thanks

User avatar
stefano1956
Utente senior
Utente senior
Posts: 381
Joined: 22 May 2012, 15:50
ROSA: Rosa2016.1
OpenMandriva: Oma 4.1 LX
Kernel: 4.9.124
Desktop: kde
country: Italia

Re: Impossible update nvidia

Post by stefano1956 »

It's the same for me on my rosa 64 bit

This is the messagge: - x11-driver-video-nvidia-current-325.15-69.1-mib2012.1.x86_64 (perché non è soddisfatto libGL.so()(64bit))

User avatar
GvMariani
Collaboratore
Collaboratore
Posts: 610
Joined: 27 July 2009, 11:31
ROSA: 2016.1 Fresh R10
OpenMandriva: -
Kernel: 4.19.13-nrj-desktop
Desktop: Plasma 5
country: Italy
Location: Cologno Monzese (MI) - Italia

Re: Impossible update nvidia

Post by GvMariani »

stefano1956 wrote:It's the same for me on my rosa 64 bit
This is the messagge: - x11-driver-video-nvidia-current-325.15-69.1-mib2012.1.x86_64 (perché non è soddisfatto libGL.so()(64bit))
Please run the urpmi update command in a console with the switch --debug and post the resulting output...
libGLso is contained int the x11-driver-video-nvidia-current package itself, so it should easily find it.

GvM

PS. The rpms from this repo: http://abf-downloads.rosalinux.ru/akden ... a/release/ do work for you?
Last edited by GvMariani on 21 August 2013, 11:11, edited 1 time in total.

User avatar
GvMariani
Collaboratore
Collaboratore
Posts: 610
Joined: 27 July 2009, 11:31
ROSA: 2016.1 Fresh R10
OpenMandriva: -
Kernel: 4.19.13-nrj-desktop
Desktop: Plasma 5
country: Italy
Location: Cologno Monzese (MI) - Italia

Re: Impossible update nvidia

Post by GvMariani »

tobal wrote:Hi, i'm trying update nvidia drivers from MIB repo in ROSA 2012.1 64 bits:

Code: Select all

Se tienen que quitar los paquetes siguientes para poder actualizar otros:
nvidia-current-doc-html-325.08-9-rosa2012.1.x86_64
 (debido a que no se satisfizo x11-driver-video-nvidia-current == 325.08-9)
x11-driver-video-nvidia-current-325.08-9-rosa2012.1.x86_64
 (debido a que no se satisfizo kmod(nvidia-current) == 325.08)
Sorry, the following packages cannot be selected:
- nvidia-current-doc-html-325.15-69.1-mib2012.1.x86_64 (debido a que no se satisfizo x11-driver-video-nvidia-current[== 325.15-69.1])
- x11-driver-video-nvidia-current-325.15-69.1-mib2012.1.x86_64 (debido a que no se satisfizo libGL.so()(64bit), intentando promover x11-driver-video-nvidia-current)
It seems a dependencies problem
Thanks
See my reply to the others post...

GvM

User avatar
andreas
Utente
Utente
Posts: 281
Joined: 1 November 2008, 20:03

Re: Impossible update nvidia

Post by andreas »

I had the same problem on my rosa x64. The driver on akdengi repo installed flawlessly, but I got the same installation error when the mib repo was updated. I solved installing the x11 driver via urpmi --allow-force --force.
AndreaS

Procio Intel i7-4930k, mobo Asus X79-Deluxe, Adaptec raid 7805, Nvidia Quadro 6000 - Rosa Fresh R3 X64

User avatar
GvMariani
Collaboratore
Collaboratore
Posts: 610
Joined: 27 July 2009, 11:31
ROSA: 2016.1 Fresh R10
OpenMandriva: -
Kernel: 4.19.13-nrj-desktop
Desktop: Plasma 5
country: Italy
Location: Cologno Monzese (MI) - Italia

Re: Impossible update nvidia

Post by GvMariani »

andreas wrote:I had the same problem on my rosa x64. The driver on akdengi repo installed flawlessly, but I got the same installation error when the mib repo was updated. I solved installing the x11 driver via urpmi --allow-force --force.
Yes. but: does the driver from akdengi repo install without errors *now*, after the update from our repo??
If so, then the problem surely lies somewhere in our package, otherwise it lies elsewhere...

If you could afford to uninstall and then re-install the nvidia-current from the akdengi repo, we could verify what is the case.

GvM

User avatar
tobal
Collaboratore
Collaboratore
Posts: 248
Joined: 17 May 2009, 19:04
ROSA: 2012.1
OpenMandriva: -
Kernel: 3.9.11-nr-laptop
Desktop: KDE ROSA 4.11.0
country: España
Location: Spain
Contact:

Re: Impossible update nvidia

Post by tobal »


User avatar
akiro
Utente
Utente
Posts: 143
Joined: 6 August 2009, 0:06
ROSA: -
OpenMandriva: -
Kernel: 4.9.35-desktop-1.mga
Desktop: KDE 5.12.2
country: italia
Location: prov di MI
Contact:

Re: Impossible update nvidia

Post by akiro »

Hi, only a note to say that I had the same problem and resolved with the "# urpmi x11-driver-video-nvidia-current-325 --allow-force --force" advice.
Bye
Winston Smith, Arthur Dent, Benjamin Malaussene,...
Mageia 6 x86_64

User avatar
andreas
Utente
Utente
Posts: 281
Joined: 1 November 2008, 20:03

Re: Impossible update nvidia

Post by andreas »

Both drivers do not install now.
AndreaS

Procio Intel i7-4930k, mobo Asus X79-Deluxe, Adaptec raid 7805, Nvidia Quadro 6000 - Rosa Fresh R3 X64

User avatar
GvMariani
Collaboratore
Collaboratore
Posts: 610
Joined: 27 July 2009, 11:31
ROSA: 2016.1 Fresh R10
OpenMandriva: -
Kernel: 4.19.13-nrj-desktop
Desktop: Plasma 5
country: Italy
Location: Cologno Monzese (MI) - Italia

Re: Impossible update nvidia

Post by GvMariani »

andreas wrote:Both drivers do not install now.
For the nvidia-current, I guess the culprit is this line in the spec file for MIB kernels

Code: Select all

%define kconflicts3 dkms-nvidia-current < 325.15-2
at least it seems so, according to some post in OM Cooker mail list,
because the above line surely forbid the installation of the dkms 325.15 package and that, in turn, disallow the installation of the main nvidia-current...

I guess Nicco put it when the nvidia-current was not compatilbe with kernel 3.10.x and then forgot about it.

GvM

User avatar
NicCo
Amministratore
Amministratore
Posts: 4740
Joined: 6 December 2007, 19:54

Re: Impossible update nvidia

Post by NicCo »

GvMariani wrote:For the nvidia-current, I guess the culprit is this line in the spec file for MIB kernels

Code: Select all

%define kconflicts3 dkms-nvidia-current < 325.15-2
at least it seems so, according to some post in OM Cooker mail list,
because the above line surely forbid the installation of the dkms 325.15 package and that, in turn, disallow the installation of the main nvidia-current...

I guess Nicco put it when the nvidia-current was not compatilbe with kernel 3.10.x and then forgot about it.

GvM

New fixed SRPMS of kernel 3.10.9 have been sent to ABF, now are rebuilding the -desktop flavours to test
I hope that the important "hang on boot" issue is now fixed, and the small nvidia-current version issue too...

you can give a look at the last changelog

Code: Select all

%changelog

* Thu Aug 22 2013 Nicolo' Costanza <abitrules@yahoo.it> 3.10.9-69
- replacement 3.10.9 release
- To fix the "hangs on boot issue" signaled: bugs.rosalinux.ru/show_bug.cgi?id=2530
- add: /patches-NRJ/0004-block-Switch-from-BFQ-v6r2-for-3.10.0-to-BFQ-v6r2-fo.patch
- sync: /patches
- update: /patches-QL/tuxonice-for-linux-3.10.9-2013-08-21.patch
- fix conflicts as suggested by Tomasz Paweł Gajc: dkms-nvidia-current < 325.15-1
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
Mayavimmer
Utente junior
Utente junior
Posts: 50
Joined: 21 November 2012, 11:06
ROSA: ROSA Desktp Frsh R2
OpenMandriva: -
Kernel: 3.11.10-nrjQL-deskto
Desktop: KDE
country: Italy

Re: Impossible update nvidia

Post by Mayavimmer »

NicCo wrote: New fixed SRPMS of kernel 3.10.9 have been sent to ABF, now are rebuilding the -desktop flavours to test
I hope that the important "hang on boot" issue is now fixed, and the small nvidia-current version issue too...
I successfully booted 3.10.9 on two different computers, one Intel based and the other Sis/Via I think.

My friend with the Sis/Via (I think) has an Nvidia Geforce 8400s (I recall) which still does not work with any combination of the latest (325.15 -- the previous one was ok) nvidia or nouveau drivers, and kernels desktop 3.8.12, 3.8.13, 3.10.5, 3.10.9, both nrj and nrjQL. It DOES work with nv, though.

His problem is a bit different from tobal's in that the nvidia 325.15 driver seems to install without error messages, but on reboot no show.

If the problem has not yet been identified, I'll try to get a hold of his computer again and get some diagnostic info, lsmod grep nvidia, Xorg.log, or any other desired info.

User avatar
Mayavimmer
Utente junior
Utente junior
Posts: 50
Joined: 21 November 2012, 11:06
ROSA: ROSA Desktp Frsh R2
OpenMandriva: -
Kernel: 3.11.10-nrjQL-deskto
Desktop: KDE
country: Italy

Re: Impossible update nvidia

Post by Mayavimmer »

Ok, I tried the fix suggested on this kernel topic: viewtopic.php?f=38&t=4112 but it still won't work. My friend has a Geforce 8400s with the 3.10.9 nrjQL kernel and the new 325 drivers from akdengi's repository at http://abf-downloads.rosalinux.ru/akden ... a/release/, as suggested in the kernel topic.
His slightly edited Xorg.log with the (EE)rrors at the end:

Code: Select all

[    90.344]
X.Org X Server 1.13.4
Release Date: 2013-04-17
[    90.344] X Protocol Version 11, Revision 0
[    90.345] Build Operating System: Linux_3.6.7-nrj-desktop-1rosa mandriva
[    90.345] Current Operating System: Linux [XXXXX] 3.10.9-nrjQL-desktop-70rosa #1 SMP PREEMPT Fri Aug 23 04:50:13 MSK 2013 x86_64
[    90.345] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.10.9-nrjQL-desktop-70rosa root=UUID=cffc8c08-ea07-4cff-bdab-1edcd51083a3 ro splash=silent logo.nologo quiet resume=/dev/sda6 init=/lib/systemd/systemd
[    90.346] Build Date: 29 July 2013  04:21:09PM
[    90.346]
[    90.347] Current version of pixman: 0.28.2
[    90.347]    Before reporting problems, check http://qa.mandriva.com
        to make sure that you have the latest version.
[    90.347] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    90.348] (==) Log file: "/var/log/Xorg.6.log", Time: Wed Aug 28 13:20:54 2013
[    90.349] (==) Using config file: "/etc/X11/xorg.conf"
[    90.349] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    90.350] (==) ServerLayout "layout1"
[    90.350] (**) |-->Screen "screen1" (0)
[    90.350] (**) |   |-->Monitor "monitor1"
[    90.350] (**) |   |-->Device "device1"
[    90.350] (**) Option "DontZap" "False"
[    90.350] (**) Option "AllowMouseOpenFail"
[    90.350] (==) Automatically adding devices
[    90.350] (==) Automatically enabling devices
[    90.350] (==) Automatically adding GPU devices
[    90.350] (==) FontPath set to:
        catalogue:/etc/X11/fontpath.d
[    90.350] (==) ModulePath set to "/usr/lib64/xorg/extra-modules,/usr/lib64/xorg/modules"
[    90.350] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[    90.350] (II) Loader magic: 0x7fdc20
[    90.350] (II) Module ABI versions:
[    90.350]    X.Org ANSI C Emulation: 0.4
[    90.350]    X.Org Video Driver: 13.1
[    90.350]    X.Org XInput driver : 18.0
[    90.350]    X.Org Server Extension : 7.0
[    90.351] (II) config/udev: Adding drm device (/dev/dri/card0)
[    90.353] (--) PCI:*(0:2:0:0) 10de:0422:0000:0000 rev 161, Mem @ 0xfd000000/16777216, 0xc0000000/268435456, 0xfa000000/33554432, I/O @ 0x0000bc00/128, BIOS @ 0x????????/131072
[    90.353] (II) Open ACPI successful (/var/run/acpid.socket)
[    90.354] Initializing built-in extension Generic Event Extension
[    90.354] Initializing built-in extension SHAPE
[    90.355] Initializing built-in extension MIT-SHM
[    90.355] Initializing built-in extension XInputExtension
[    90.355] Initializing built-in extension XTEST
[    90.356] Initializing built-in extension BIG-REQUESTS
[    90.356] Initializing built-in extension SYNC
[    90.357] Initializing built-in extension XKEYBOARD
[    90.357] Initializing built-in extension XC-MISC
[    90.357] Initializing built-in extension SECURITY
[    90.357] Initializing built-in extension XINERAMA
[    90.358] Initializing built-in extension XFIXES
[    90.358] Initializing built-in extension XFree86-Bigfont
[    90.358] Initializing built-in extension RENDER
[    90.359] Initializing built-in extension RANDR
[    90.359] Initializing built-in extension COMPOSITE
[    90.359] Initializing built-in extension DAMAGE
[    90.360] Initializing built-in extension MIT-SCREEN-SAVER
[    90.360] Initializing built-in extension DOUBLE-BUFFER
[    90.371] Initializing built-in extension RECORD
[    90.378] Initializing built-in extension DPMS
[    90.385] Initializing built-in extension X-Resource
[    90.392] Initializing built-in extension XVideo
[    90.399] Initializing built-in extension XVideo-MotionCompensation
[    90.406] Initializing built-in extension XFree86-VidModeExtension
[    90.412] Initializing built-in extension XFree86-DGA
[    90.419] Initializing built-in extension XFree86-DRI
[    90.425] Initializing built-in extension DRI2
[    90.425] (II) "glx" will be loaded by default.
[    90.425] (II) LoadModule: "v4l"
[    90.425] (II) Loading /usr/lib64/xorg/modules/drivers/v4l_drv.so
[    90.425] (II) Module v4l: vendor="X.Org Foundation"
[    90.425]    compiled for 1.13.0, module version = 0.1.1
[    90.425]    ABI class: X.Org Video Driver, version 13.0
[    90.425] (II) LoadModule: "glx"
[    90.425] (II) Loading /usr/lib64/xorg/extra-modules/libglx.so
[    90.455] (II) Module glx: vendor="NVIDIA Corporation"
[    90.455]    compiled for 4.0.2, module version = 1.0.0
[    90.455]    Module class: X.Org Server Extension
[    90.455] (II) NVIDIA GLX Module  325.15  Wed Jul 31 18:12:00 PDT 2013
[    90.462] Loading extension GLX
[    90.462] (II) LoadModule: "nvidia"
[    90.462] (II) Loading /usr/lib64/xorg/extra-modules/nvidia_drv.so
[    90.463] (II) Module nvidia: vendor="NVIDIA Corporation"
[    90.463]    compiled for 4.0.2, module version = 1.0.0
[    90.463]    Module class: X.Org Video Driver
[    90.463] (II) v4l driver for Video4Linux
[    90.463] (II) NVIDIA dlloader X Driver  325.15  Wed Jul 31 17:50:57 PDT 2013
[    90.463] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    90.463] (++) using VT number 2

[    90.463] (WW) Falling back to old probe method for v4l
[    90.463] (II) Loading sub module "fb"
[    90.463] (II) LoadModule: "fb"
[    90.463] (II) Loading /usr/lib64/xorg/modules/libfb.so
[    90.464] (II) Module fb: vendor="X.Org Foundation"
[    90.464]    compiled for 1.13.4, module version = 1.0.0
[    90.464]    ABI class: X.Org ANSI C Emulation, version 0.4
[    90.464] (WW) Unresolved symbol: fbGetGCPrivateKey
[    90.464] (II) Loading sub module "wfb"
[    90.464] (II) LoadModule: "wfb"
[    90.464] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[    90.465] (II) Module wfb: vendor="X.Org Foundation"
[    90.465]    compiled for 1.13.4, module version = 1.0.0
[    90.465]    ABI class: X.Org ANSI C Emulation, version 0.4
[    90.465] (II) Loading sub module "shadow"
[    90.465] (II) LoadModule: "shadow"
[    90.465] (II) Loading /usr/lib64/xorg/modules/libshadow.so
[    90.465] (II) Module shadow: vendor="X.Org Foundation"
[    90.465]    compiled for 1.13.4, module version = 1.1.0
[    90.465]    ABI class: X.Org ANSI C Emulation, version 0.4
[    90.465] (II) Loading sub module "ramdac"
[    90.465] (II) LoadModule: "ramdac"
[    90.465] (II) Module "ramdac" already built-in
[    90.465] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[    90.466] (==) NVIDIA(0): RGB weight 888
[    90.466] (==) NVIDIA(0): Default visual is TrueColor
[    90.466] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    90.466] (**) NVIDIA(0): Option "AddARGBGLXVisuals"
[    90.466] (**) NVIDIA(0): Option "DynamicTwinView" "false"
[    90.466] (**) NVIDIA(0): Enabling 2D acceleration
[    94.852] (EE) NVIDIA(0): The NVIDIA kernel module does not appear to be receiving
[    94.853] (EE) NVIDIA(0):     interrupts generated by the NVIDIA GPU at PCI:2:0:0.
[    94.853] (EE) NVIDIA(0):     Please see Chapter 8: Common Problems in the README for
[    94.853] (EE) NVIDIA(0):     additional information.
[    94.853] (EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
[    94.853] (EE) NVIDIA(0): Failing initialization of X screen 0
[    94.853] (II) UnloadModule: "nvidia"
[    94.853] (II) UnloadSubModule: "shadow"
[    94.853] (II) UnloadSubModule: "wfb"
[    94.853] (II) UnloadSubModule: "fb"
[    94.853] (EE) Screen(s) found, but none have a usable configuration.
[    94.853]
Fatal server error:
[    94.853] no screens found
[    94.853] (EE)
Please consult the The X.Org Foundation support
         at http://qa.mandriva.com
 for help.
[    94.853] (EE) Please also check the log file at "/var/log/Xorg.6.log" for additional information.
[    94.853] (EE)
[    94.894] Server terminated with error (1). Closing log file.
He took his computer back so I am hoping to get the nvidia working with a few simple instructions over the phone (ideally by just updating the system).

User avatar
tobal
Collaboratore
Collaboratore
Posts: 248
Joined: 17 May 2009, 19:04
ROSA: 2012.1
OpenMandriva: -
Kernel: 3.9.11-nr-laptop
Desktop: KDE ROSA 4.11.0
country: España
Location: Spain
Contact:

Re: Impossible update nvidia

Post by tobal »

I'm followin' with the same problem when i try update kernel-nrj-laptop-3.10.10-1rosa

Code: Select all

Sorry, the following packages cannot be selected:

- x11-driver-video-nvidia-current-325.15-69.1-mib2012.1.x86_64 (due to unsatisfied libGL.so()(64bit))
There is something wrong with this repository

Thanks

Post Reply