[SOLVED] Can't boot GUI after Rosa Desktop R2 update

About ROSA Desktop distribution and help to users
Post Reply
User avatar
steros
Utente junior
Utente junior
Posts: 59
Joined: 10 December 2009, 10:29
ROSA: 2012.1
OpenMandriva: -
Kernel: 3.10.21-nrjQL
Desktop: Kde 4
country: Italy

[SOLVED] Can't boot GUI after Rosa Desktop R2 update

Post by steros »

I have a Sandy Bridge netbook with Nvidia GPU (Optimus technology).
I'm actually using Kernel 3.10.21 (but nrj, nrjQL and older versions have the same problem).
After last update (R2 one) I can't start X no more.

This is my Xorg.0.log:

Code: Select all

[    33.499]
X.Org X Server 1.14.4
Release Date: 2013-10-31
[    36.942] X Protocol Version 11, Revision 0
[    36.942] Build Operating System: Linux_3.11.0-9-generic mandriva
[    36.942] Current Operating System: Linux pcsamsung 3.10.21-vanilla.nrj.desktop.1rosa #1 SMP PREEMPT Sun Dec 1 00:00:55 MSK 2013 x86_64
[    36.942] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.10.21-vanilla.nrj.desktop.1rosa root=UUID=ddfb35cb-2444-4931-a939-9d6b690a9b1c ro splash=silent logo.nologo quiet nomodeset resume=/dev/sda7 init=/lib/systemd/systemd
[    36.942] Build Date: 08 November 2013  01:38:44PM
[    36.942]
[    36.942] Current version of pixman: 0.30.2
[    36.942]    Before reporting problems, check http://bugs.rosalinux.ru/
        to make sure that you have the latest version.
[    36.942] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    36.942] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Dec  5 17:42:35 2013
[    37.939] (==) Using config file: "/etc/X11/xorg.conf"
[    37.939] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    37.939] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    38.129] (==) ServerLayout "layout1"
[    38.129] (**) |-->Screen "screen1" (0)
[    38.129] (**) |   |-->Monitor "monitor1"
[    38.171] (**) |   |-->Device "device1"
[    38.171] (**) Option "DontZap" "False"
[    38.171] (**) Option "AllowMouseOpenFail"
[    38.171] (==) Automatically adding devices
[    38.171] (==) Automatically enabling devices
[    38.171] (==) Automatically adding GPU devices
[    38.171] (==) FontPath set to:
        catalogue:/etc/X11/fontpath.d
[    38.171] (==) ModulePath set to "/usr/lib64/xorg/extra-modules,/usr/lib64/xorg/modules"
[    38.171] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[    38.193] (II) Loader magic: 0x833c20
[    38.193] (II) Module ABI versions:
[    38.193]    X.Org ANSI C Emulation: 0.4
[    38.193]    X.Org Video Driver: 14.1
[    38.193]    X.Org XInput driver : 19.1
[    38.193]    X.Org Server Extension : 7.0
[    38.193] (II) xfree86: Adding drm device (/dev/dri/card0)
[    38.194] (--) PCI:*(0:0:2:0) 8086:0116:144d:c0a5 rev 9, Mem @ 0xf5400000/4194304, 0xc0000000/268435456, I/O @ 0x0000e000/64
[    38.194] (--) PCI: (0:1:0:0) 10de:0df4:144d:c0a5 rev 161, Mem @ 0xf4000000/16777216, 0xd0000000/268435456, 0xe0000000/33554432, I/O @ 0x0000d000/128, BIOS @ 0x????????/524288
[    38.194] (II) Open ACPI successful (/var/run/acpid.socket)
[    38.199] Initializing built-in extension Generic Event Extension
[    38.199] Initializing built-in extension SHAPE
[    38.199] Initializing built-in extension MIT-SHM
[    38.199] Initializing built-in extension XInputExtension
[    38.199] Initializing built-in extension XTEST
[    38.199] Initializing built-in extension BIG-REQUESTS
[    38.199] Initializing built-in extension SYNC
[    38.199] Initializing built-in extension XKEYBOARD
[    38.199] Initializing built-in extension XC-MISC
[    38.199] Initializing built-in extension SECURITY
[    38.199] Initializing built-in extension XINERAMA
[    38.199] Initializing built-in extension XFIXES
[    38.199] Initializing built-in extension XFree86-Bigfont
[    38.199] Initializing built-in extension RENDER
[    38.199] Initializing built-in extension RANDR
[    38.199] Initializing built-in extension COMPOSITE
[    38.199] Initializing built-in extension DAMAGE
[    38.199] Initializing built-in extension MIT-SCREEN-SAVER
[    38.199] Initializing built-in extension DOUBLE-BUFFER
[    38.199] Initializing built-in extension RECORD
[    38.199] Initializing built-in extension DPMS
[    38.199] Initializing built-in extension X-Resource
[    38.199] Initializing built-in extension XVideo
[    38.199] Initializing built-in extension XVideo-MotionCompensation
[    38.199] Initializing built-in extension XFree86-VidModeExtension
[    38.199] Initializing built-in extension XFree86-DGA
[    38.199] Initializing built-in extension XFree86-DRI
[    38.200] Initializing built-in extension DRI2
[    38.200] (II) "glx" will be loaded by default.
[    38.200] (II) LoadModule: "v4l"
[    38.624] (II) Loading /usr/lib64/xorg/modules/drivers/v4l_drv.so
[    38.689] (II) Module v4l: vendor="X.Org Foundation"
[    38.689]    compiled for 1.14.4, module version = 0.1.1
[    38.689]    ABI class: X.Org Video Driver, version 14.1
[    38.689] (II) LoadModule: "glx"
[    38.689] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[    38.801] (II) Module glx: vendor="X.Org Foundation"
[    38.801]    compiled for 1.14.4, module version = 1.0.0
[    38.801]    ABI class: X.Org Server Extension, version 7.0
[    38.801] (==) AIGLX enabled
[    38.891] Loading extension GLX
[    38.891] (II) LoadModule: "intel"
[    38.891] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[    40.191] (II) Module intel: vendor="X.Org Foundation"
[    40.191]    compiled for 1.14.4, module version = 2.99.905
[    40.191]    Module class: X.Org Video Driver
[    40.191]    ABI class: X.Org Video Driver, version 14.1
[    40.191] (II) v4l driver for Video4Linux
[    40.191] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
        i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
        915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
        Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
        GM45, 4 Series, G45/G43, Q45/Q43, G41, B43, HD Graphics,
        HD Graphics 2000, HD Graphics 3000, HD Graphics 2500,
        HD Graphics 4000, HD Graphics P4000, HD Graphics 4600,
        HD Graphics 5000, HD Graphics P4600/P4700, Iris(TM) Graphics 5100,
        HD Graphics 4400, HD Graphics 4200, Iris(TM) Pro Graphics 5200
[    40.226] (++) using VT number 1

[    40.227] (WW) Falling back to old probe method for v4l
[    40.230] (EE) No devices detected.
[    40.230] (EE)
Fatal server error:
[    40.230] (EE) no screens found(EE)
[    40.230] (EE)
Please consult the The X.Org Foundation support
         at http://bugs.rosalinux.ru/
 for help.
[    40.231] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    40.231] (EE)
I have the following packages installed:

Code: Select all

dkms-nvidia-current-325.15-6-rosa2012.1.x86_64
dkms-nvidia-long-lived-304.108-4-rosa2012.1.x86_64
intel-gpu-tools-1.2-1-rosa2012.1.x86_64
lib64drm_intel1-2.4.46-1-rosa2012.1.x86_64
lib64IntelXvMC1-2.99.905-2-rosa2012.1.x86_64
libdrm_intel1-2.4.46-1-rosa2012.1.i586
nvidia-additional-settings-1-1-rosa2012.1.noarch
nvidia-compute-profiler-4.2.9-6-rosa2012.1.x86_64
nvidia-cuda-toolkit-4.2.9-6-rosa2012.1.x86_64
nvidia-current-cuda-opencl-325.15-6-rosa2012.1.x86_64
nvidia-current-devel-325.15-6-rosa2012.1.x86_64
nvidia-current-doc-html-325.15-6-rosa2012.1.x86_64
nvidia-long-lived-doc-html-304.108-4-rosa2012.1.x86_64
vaapi-driver-intel-1.0.19-1-rosa2012.1.x86_64
x11-driver-video-intel-2.99.905-2-rosa2012.1.x86_64
x11-driver-video-nvidia-current-325.15-6-rosa2012.1.x86_64
x11-driver-video-nvidia-long-lived-304.108-4-rosa2012.1.x86_64
x11-server-xorg-1.14.4-2-rosa2012.1.x86_64
xorg-x11-7.7-3-rosa2012.1.x86_64
Any hint?
Last edited by steros on 7 December 2013, 11:40, edited 1 time in total.
Steros - Mdv Rosa 2012.1 x86_64 - KDE 4

User avatar
steros
Utente junior
Utente junior
Posts: 59
Joined: 10 December 2009, 10:29
ROSA: 2012.1
OpenMandriva: -
Kernel: 3.10.21-nrjQL
Desktop: Kde 4
country: Italy

Re: Can't boot GUI after Rosa Desktop R2 update

Post by steros »

UPDATE: If, from text console, I reconfigure xorg with intel, xorg starts correctly but on next reboot I get the same problem.
Steros - Mdv Rosa 2012.1 x86_64 - KDE 4

User avatar
NicCo
Amministratore
Amministratore
Posts: 4740
Joined: 6 December 2007, 19:54

Re: Can't boot GUI after Rosa Desktop R2 update

Post by NicCo »

I believe you must delete the file /etc/X11/xorg.config

everytime I configure this, at reboot there are issues
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
steros
Utente junior
Utente junior
Posts: 59
Joined: 10 December 2009, 10:29
ROSA: 2012.1
OpenMandriva: -
Kernel: 3.10.21-nrjQL
Desktop: Kde 4
country: Italy

Re: Can't boot GUI after Rosa Desktop R2 update

Post by steros »

Hi Nicco.

I already tried to remove it but nothing changes.
If I force "intel" driver and 1366x768 as resolution from text configuration and then I do "init 3" and "init 5", I get a working KDE login but with wrong resolution (1024x768). When I reboot (with or without xorg.config) xorg fail to start.

As a side note I'm using OpenMandriva GRUB (I have Windows, Rosa e OpenMandriva on the same disk) but with boot configuration copied from original boot. I also tried to reinstall Rosa GRUB but nothing change.

What could I check to identify the problem?
Steros - Mdv Rosa 2012.1 x86_64 - KDE 4

User avatar
steros
Utente junior
Utente junior
Posts: 59
Joined: 10 December 2009, 10:29
ROSA: 2012.1
OpenMandriva: -
Kernel: 3.10.21-nrjQL
Desktop: Kde 4
country: Italy

Re: Can't boot GUI after Rosa Desktop R2 update

Post by steros »

I resolved the problem forcing reinstall or nvidia and intel rpms.

Don't ask me why...

Bye.
Steros - Mdv Rosa 2012.1 x86_64 - KDE 4

Post Reply