Device Notifier can no longer mount removable media

About ROSA Desktop distribution and help to users
Post Reply
User avatar
rolf
Utente
Utente
Posts: 112
Joined: 20 May 2009, 3:15
ROSA: R3 2012.1 x86_64
OpenMandriva: OMV 2014.0 x86_64
Kernel: 3.13.11-nrjQL-realti
Desktop: KDE 4.13.2
country: USA

Device Notifier can no longer mount removable media

Post by rolf »

Posted to Rosa forum, already.
I suspect a software update, maybe udisks2? Recently, when I plug a usb key, external hdd, insert a video dvd or data disk and choose one of the handlers in Device Notifier, it does not work, and an error about "Could not mount device" is displayed :?:

User avatar
stefano1956
Utente senior
Utente senior
Posts: 381
Joined: 22 May 2012, 15:50
ROSA: Rosa2016.1
OpenMandriva: Oma 4.1 LX
Kernel: 4.9.124
Desktop: kde
country: Italia

Re: Device Notifier can no longer mount removable media

Post by stefano1956 »

All updates done? I've update yesterday, and all works fine
Rosa 2012.1 R2 64 bit

User avatar
rolf
Utente
Utente
Posts: 112
Joined: 20 May 2009, 3:15
ROSA: R3 2012.1 x86_64
OpenMandriva: OMV 2014.0 x86_64
Kernel: 3.13.11-nrjQL-realti
Desktop: KDE 4.13.2
country: USA

Re: Device Notifier can no longer mount removable media

Post by rolf »

Yes. BTW, my time is a bit limited, so testing has not been extensive, but I've got a Mandriva 2011 64 bit installation on this machine. I booted to that and device notifier worked for an sd card from my camera. Back in Rosa, same card, same reader device notifier fails, cannot mount. A couple of differences from stock Rosa are several MIB files and pyparted in skip.list because it conflicted with some other parted package and I couldn't use some program, the details are not clear, atm. I might try removing that restriction and see if that makes the difference. Thanks.

Code: Select all

[rolf@localhost ~]$ cat /etc/rosa-release 
ROSA Desktop Fresh R2 release 2012.1 for x86_64

[rolf@localhost ~]$ cat /etc/urpmi/skip.list 
# Here you can specify the packages that won't be upgraded automatically
# for example, to exclude all apache packages :
# /^apache/
pyparted
#task-printing

[rolf@localhost ~]$ rpm -qa|grep mib
net-snmp-mibs-5.7.1-1-rosa2012.1.x86_64
mib-ossigeno-icons-4.3.0-69.4-rosa2012.1.noarch
lib64k3bdevice6-2.0.2-69.1-mib2012.1.x86_64
libktorrent-common-1.3.1-69.1-mib2012.1.x86_64
lib64k3blib6-2.0.2-69.1-mib2012.1.x86_64
lib64ktorrent5-1.3.1-69.1-mib2012.1.x86_64
k3b-2.0.2-69.1-mib2012.1.x86_64
lib64ktcore15-4.3.1-69.1-mib2012.1.x86_64
ktorrent-4.3.1-69.1-mib2012.1.x86_64
lib64nspr4-4.10.3-69-mib2012.1.x86_64
jackit-example-clients-1.9.9.5-69.2-mib2012.1.x86_64
x11-driver-video-vboxvideo-4.3.6-69-mib2012.1.x86_64
jackit-1.9.9.5-69.2-mib2012.1.x86_64
dkms-vboxadditions-4.3.6-69-mib2012.1.noarch
usb_modeswitch-data-20130807-69-mib2012.1.noarch
lib64nspr-devel-4.10.3-69-mib2012.1.x86_64
nss-3.15.4-69.1-mib2012.1.x86_64
lib64opus0-1.1-69.1-mib2012.1.x86_64
lib64sqlite3_0-3.8.3.1-69-mib2012.1.x86_64
lib64jackserver0-1.9.9.5-69.2-mib2012.1.x86_64
lib64opus-devel-1.1-69.1-mib2012.1.x86_64
lib64jack0-1.9.9.5-69.2-mib2012.1.x86_64
lib64csound5-5.19.01-69.1-mib2012.1.x86_64
lib64jack-devel-1.9.9.5-69.2-mib2012.1.x86_64
csound-5.19.01-69.1-mib2012.1.x86_64
lib64vlccore7-2.1.4-69-mib2012.1.x86_64
lib64nss3-3.15.4-69.1-mib2012.1.x86_64
lib64vlc5-2.1.4-69-mib2012.1.x86_64
vlc-plugin-theora-2.1.4-69-mib2012.1.x86_64
vlc-2.1.4-69-mib2012.1.x86_64
vlc-plugin-pulse-2.1.4-69-mib2012.1.x86_64
vlc-plugin-gnutls-2.1.4-69-mib2012.1.x86_64
vlc-plugin-opengl-2.1.4-69-mib2012.1.x86_64
vlc-plugin-mpc-2.1.4-69-mib2012.1.x86_64
vlc-plugin-gme-2.1.4-69-mib2012.1.x86_64
vlc-plugin-zvbi-2.1.4-69-mib2012.1.x86_64
vlc-plugin-mod-2.1.4-69-mib2012.1.x86_64
vlc-plugin-sdl-2.1.4-69-mib2012.1.x86_64
vlc-plugin-fluidsynth-2.1.4-69-mib2012.1.x86_64
vlc-plugin-dv-2.1.4-69-mib2012.1.x86_64
vlc-plugin-lirc-2.1.4-69-mib2012.1.x86_64
vlc-plugin-libass-2.1.4-69-mib2012.1.x86_64
vlc-plugin-ncurses-2.1.4-69-mib2012.1.x86_64
vlc-plugin-bonjour-2.1.4-69-mib2012.1.x86_64
vlc-plugin-jack-2.1.4-69-mib2012.1.x86_64
vlc-plugin-lua-2.1.4-69-mib2012.1.x86_64
vlc-plugin-speex-2.1.4-69-mib2012.1.x86_64
vlc-plugin-twolame-2.1.4-69-mib2012.1.x86_64
vlc-plugin-aa-2.1.4-69-mib2012.1.x86_64
vlc-plugin-kate-2.1.4-69-mib2012.1.x86_64
vlc-plugin-schroedinger-2.1.4-69-mib2012.1.x86_64
vlc-plugin-shout-2.1.4-69-mib2012.1.x86_64
vlc-plugin-libnotify-2.1.4-69-mib2012.1.x86_64
vlc-plugin-upnp-2.1.4-69-mib2012.1.x86_64
vlc-plugin-flac-2.1.4-69-mib2012.1.x86_64
vlc-plugin-opus-2.1.4-69-mib2012.1.x86_64
lib64vlc-devel-2.1.4-69-mib2012.1.x86_64
nss-shlibsign-3.15.4-69.1-mib2012.1.x86_64
lib64freebl3-3.15.4-69.1-mib2012.1.x86_64
sqlite3-tools-3.8.3.1-69-mib2012.1.x86_64
lib64sqlite3-devel-3.8.3.1-69-mib2012.1.x86_64
lib64nss-devel-3.15.4-69.1-mib2012.1.x86_64

User avatar
rolf
Utente
Utente
Posts: 112
Joined: 20 May 2009, 3:15
ROSA: R3 2012.1 x86_64
OpenMandriva: OMV 2014.0 x86_64
Kernel: 3.13.11-nrjQL-realti
Desktop: KDE 4.13.2
country: USA

Re: Device Notifier can no longer mount removable media

Post by rolf »

Update: pyparted-3.10-6-rosa2012.1.x86_64 is now installed but that didn't change the failure, nor after reboot.

Post Reply