ROSA R9 Plasma non si aggiorna ad R10, infine si corrompe...

Discussioni sul progetto ROSA e aiuto agli utenti
Post Reply
User avatar
NicCo
Amministratore
Amministratore
Posts: 4739
Joined: 6 December 2007, 19:54

ROSA R9 Plasma non si aggiorna ad R10, infine si corrompe...

Post by NicCo »

CIao,
volevo segnalare che sull'installazione di ROSA R9 Plasma, sul Laptop di mio figlio, è successo qualcosa di anomalo:
pur effettuando periodicamente tutti gli aggiornamenti, era rimasta sempre con la dicitura R9, sia all'avvio del Grub, che come product.id, cosa che già mi aveva lasciato perplesso...

Due giorni addietro, dopo aver effettuato gli aggiornamenti, al riavvio, Plasma dopo il Login avvenuto con successo, mostra solo una schermata nera con il puntatore sopra, quindi tutto risulta corrotto e inutilizzabile, ho verificato ed anche con un account Ospite accade lo stesso, e così in pratica, tutta la distro è inutilizzabile e quindi da installare nuovamente...

Allo stesso tempo, un amico mio mi ha chiamato ieri, per un problema, dopo gli aggiornamenti della sua ROSA R9 Plasma, non si avvia più, questa volta si blocca ancora prima che il Plasma possa mostrare la finestra di Login,

tutto questo mi sembra possa essere difficilmente il frutto di un caso, o di un eccesso di sfortuna, mi chiedo qui se qualcuno di Voi ha riscontrato lo stesso problema, o uno simile

Grazie,
CIao
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
Alex-G
Utente
Utente
Posts: 104
Joined: 19 September 2011, 11:49
ROSA: Rosa
OpenMandriva: OpenMandriva
Kernel: Vari
Desktop: Vari
country: IT

Re: ROSA R9 Plasma non si aggiorna ad R10, infine si corromp

Post by Alex-G »

Dunque alt, prima di dover reinstallare tutto farei alcuni test: se il problema quindi dipende solo dal desktop plasma, magari non c'è buisogno di reinstallare tutto il sistema ma solo eventualmente il DE specifico, per questo è sempre bene tenersi qualche altro DE di riserva/amministrazione, tanto i propri dati stanno sempre li integri, per cui se si risolve il problema specifico del desktop, poi riappaiono inalterati come prima.

Quindi, una volta ri-avviato il sistema:
1) Prima di fare login con l' utente, da una conosole root (CTRL+ALT+F2) inviare il comando
# urpmi --auto-update
questo dovrebbe risolvere eventuali problemi di aggiornamenti parziali e repository non aggiornati.
Osservare bene le risposte che arrivano nel terminale
Riavviare e provare a rientrare nel desktop.

Fatto questo, se il problema non dovesse essere risolto
2) creare un nuovo utente e fare login da quello, quindi sempre da una conosole root (CTRL+ALT+F2) inviare il comando
# adduser nome-nuovo-utente

Se anche questo non dovesse funzionare:
3) disinstallare il Desktop Environment Plasma e reinstallarlo: onestamente non so se c'è un modo per disinstallarlo in una volta sola invece che togliere i singoli pacchetti ad uno ad uno, forse basta disinstallare il metapacchetto che li comprende tutti ma prima di arrivarci è meglio tentare le altre 2 opzioni precedenti.

Se si tratta di un bug di questa particolare versione di Plasma, non conviene ugualmente disinstallare tutto il sistema (se non come ultimissima possibilità): basta usare un altro Desktop Environment anche solo temporaneamante, in attesa che il bug sia risolto.

Post Reply