Driver Video e AHCI mancanti

Discussioni sul progetto ROSA e aiuto agli utenti
Post Reply
User avatar
Alex-G
Utente
Utente
Posts: 104
Joined: 19 September 2011, 11:49
ROSA: Rosa
OpenMandriva: OpenMandriva
Kernel: Vari
Desktop: Vari
country: IT

Driver Video e AHCI mancanti

Post by Alex-G »

ROSA.FRESH.KDE.R10.x86_64

Code: Select all

Manufacturer ASUSTeK Computer INC.
Model P5SD2-VM
North Bridge SiS 672 Revision 00
South Bridge SiS 968 Revision 01
CPU Intel(R) Pentium(R) Dual CPU E2200 @ 2.20GHz
(sempre la stessa macchina con hw non recente ma nemmeno da buttare)

ADATTATORE VIDEO

Code: Select all

Marca: Silicon Integrated Systems [SiS]
Descrizione: 771/671 PCIE VGA Display Adapter
Classe dei supporti: VGA compatible controller
[size=100][b]Modulo: [u]sconosciuto[/u][/b][/size]
Infatti l' installazione del driver video mi presenta come unica opzione il driver VESA
Come penso di risolvere:
ho notato che nel repo di Rosa esiste un solo driver per SIS
x11-driver-video-sis-0.10.9-1-rosa2016.1.x86_64.rpm
Che evidentemente non è riconosciuto come adatto alla scheda integrata

Nel repo di OMA invece la dotazione è più completa
x11-driver-video-sis-0.10.7-18-omv2015.0.aarch64.rpm
x11-driver-video-sisimedia-0.9.1-2.20091203.20-omv2015.0.aarch64.rpm
x11-driver-video-sisusb-0.9.6-18-omv2015.0.aarch64.rpm

Per cui uno degli altri 2 potrebbe fare al caso mio; non dovesse funzionare tenterò la strada del driver già funzionante in altre distro, tanto il driver x86_64 è sempre lo stesso.
In alternativa ... non resta che una scheda video da inserire nello slot pci-x
------------------------------------------

ADATTATORE SATA AHCI

Code: Select all

Marca: Silicon Integrated Systems [SiS]
Classe dei supporti: SATA controller
Descrizione: AHCI IDE Controller (0106)
Modulo: sconosciuto
IL controller è integrato nel South Bridge SiS 968... boh.. se non è tra i moduli del Kernel (e pare non vi sia altrimenti sarebbe stato riconosciuto ed installato automaticamente) o lo trovo in giro, oppure installo una schedina SATA aggiuntiva, ne ho diverse

User avatar
GvMariani
Collaboratore
Collaboratore
Posts: 610
Joined: 27 July 2009, 11:31
ROSA: 2016.1 Fresh R10
OpenMandriva: -
Kernel: 4.19.13-nrj-desktop
Desktop: Plasma 5
country: Italy
Location: Cologno Monzese (MI) - Italia

Re: Driver Video e AHCI mancanti

Post by GvMariani »

Huu... è proprio antica quella scheda video...
Nel repo di OMA invece la dotazione è più completa
x11-driver-video-sis-0.10.7-18-omv2015.0.aarch64.rpm
x11-driver-video-sisimedia-0.9.1-2.20091203.20-omv2015.0.aarch64.rpm
x11-driver-video-sisusb-0.9.6-18-omv2015.0.aarch64.rpm
Per cui uno degli altri 2 potrebbe fare al caso mio; non dovesse funzionare tenterò la strada del driver già funzionante in altre distro, tanto il driver x86_64 è sempre lo stesso.
In alternativa ... non resta che una scheda video da inserire nello slot pci-x
Non credo che uno degli altri due possa funzionare...
Vado a memoria e potrei sbagliare, ma il sisimedia è la pacchettizzazione (con alcuni back-ports) di una release del driver sis per X11 antecedente la 0.10.x: se già quello non riconosce la scheda, figurati quello più vecchio; mentre il sisusb è un driver che supporta SiS video chip (in realtà il solo 315E/PRO) connessi ad un dongle USB basato sul controller Net2280: ergo, se la tua scheda non è USB (e dunque esterna) allora anche questo driver non funzionerà di sicuro...

Prima di partire con la scheda video aggiuntiva, io proverei:
1) a googlare in giro per vedere se esistono indicazioni di driver per x11/linux: secondo questa pagina https://en.wikipedia.org/wiki/Silicon_I ... ed_Systems, la tua scheda integrata è una Mirage 3...
forse cercando questa, oltre all'output di inxi puoi trovare qualcosa...

2) provare il driver modesetting: se la scheda integrata supporta il KMS a livello di drm e mesa, allora questo dovrebbe funzionare ed è pure abbastanza maturo...
Dovrai però editare a mano l'xorg.conf o, se non ce l'hai (come è di default di questi tempi) provvedere a mano uno snippet di configurazione in xorg.conf.d, per la sezione "Device" (v. man xorg.conf per tutti i dettagli).

User avatar
Alex-G
Utente
Utente
Posts: 104
Joined: 19 September 2011, 11:49
ROSA: Rosa
OpenMandriva: OpenMandriva
Kernel: Vari
Desktop: Vari
country: IT

Re: Driver Video e AHCI mancanti

Post by Alex-G »

Comunque la scheda video non è ciò che mi interessa veramente, dato che la SIS x funzionare funziona ma è proprio pessima, l' avranno messa giusto per non rimanere fermi nel caso la scheda pci-x si guastasse.
Si in effetti hai ragione, il driver sisusb non c' entra una mazza con l' HW in oggetto, .... è li in elenco perché lo lasciato dopo il copiaincolla :? Comunque li ho provati e come avevi previsto non funzionano, funziona solo il driver VESA

Proverò ugualmente il tuoi suggerimenti ma solo per la curiosità di vedere uno straccio di accelerazione ... quella integrata non è una scheda con cui lavorarci ;)

Quello che mi interessa veramente è far funzionare correttamente il controller Sata AHCI

User avatar
GvMariani
Collaboratore
Collaboratore
Posts: 610
Joined: 27 July 2009, 11:31
ROSA: 2016.1 Fresh R10
OpenMandriva: -
Kernel: 4.19.13-nrj-desktop
Desktop: Plasma 5
country: Italy
Location: Cologno Monzese (MI) - Italia

Re: Driver Video e AHCI mancanti

Post by GvMariani »

Alex-G wrote: Quello che mi interessa veramente è far funzionare correttamente il controller Sata AHCI
Secondo questo link https://ata.wiki.kernel.org/index.php/H ... ver_status, il driver ahci dovrebbe supportare nativamente il sis968 e quindi dovrebbe caricarsi da solo al boot.
Se non lo fa, è possibile che nel BIOS il controller sia settato di default in modalità di compatibilità IDE (PATA), mentre dovrebbe invece stare in modalità AHCI: questa è la prima cosa che controllerei...
Poi guarderei bene le syslog per eventuali errori o messaggi da "ahci" o "libata": potrebbero chiarire che cosa non va...

In ogni caso, puoi sempre provare a caricare il modulo del driver anche a sistema avviato:
(da root) digiti

Code: Select all

modprobe ahci
e vedi cosa succede.
Se la cosa funziona, aggiungi uno snippet di configurazione (p.es., ahci.conf) in /etc/modules-load.d, contenente semplicemente il nome del modulo "ahci"; in questo modo, il modulo dovrebbe essere caricato automaticamene ad ogni boot...

PS. Tutte queste info le puoi ricavare da https://wiki.archlinux.org/index.php/kernel_modules...

Post Reply