Installazione KDE-4.3.4

Discussioni e feedback su pacchetti e repository MIB
User avatar
irascibile55
Nuovo utente
Nuovo utente
Posts: 13
Joined: 19 October 2008, 17:40

Installazione KDE-4.3.4

Post by irascibile55 »

Ciao a tutti,
non so se questo è il posto giusto per questo mio post, qualora non lo fosse Vi prego di scusarmi.
Il motivo di questo mia è il seguente:
Se installo Kde 4.3.4 la chat di Skype 2.1.0.47 beta, continuerà a funzionare? A me serve questa risposta, perchè ho bisogno di questa parte di Skype, se la risposta è negativa io soprassiedo, se è positiva cioè che funziona, allora lo installo volentieri
RingraziandoVi per una risposta

Cordialmente
Irascibile55

User avatar
picard12
Utente junior
Utente junior
Posts: 48
Joined: 12 January 2008, 9:34

Re: installazione kde 4.3.4

Post by picard12 »

a me funziona tutto benissimo, skype.
ciao

User avatar
irascibile55
Nuovo utente
Nuovo utente
Posts: 13
Joined: 19 October 2008, 17:40

Re: installazione kde 4.3.4

Post by irascibile55 »

ciao,
grazie per la risposta Picard 12
Cordialmente
Irascibile55

User avatar
NicCo
Amministratore
Amministratore
Posts: 4740
Joined: 6 December 2007, 19:54

Re: installazione kde 4.3.4

Post by NicCo »

irascibile55 wrote:Se installo Kde 4.3.4 la chat di Skype 2.1.0.47 beta, continuerà a funzionare?
..............................................................
Cordialmente
Irascibile55
La risposta è Skype 2.1.0.47 certamente funziona, come nel frattempo ha confermato anche picard12

La compatibilità con i programmi precedenti è stata una delle chiavi di lettura del porting:
Il MIB usa Skype 24h/24h per comunicare tra i membri, quindi figurati se non ne avessimo tenuto conto...

Abbiamo seguito durante lo sviluppo, due Forum pubblici misti in italiano/inglese
Topic1> http://mib.pianetalinux.org/mib/distrib ... =11&t=1574
Topic2> http://mib.pianetalinux.org/mib/distrib ... =20&t=1555
Su questi, se siete curiosi, potete seguire sviluppi, errori riscontrati poi corretti, come si sono succeduti nel tempo.

Un'altra fonte di Notizie anche sul MIB Blog, all'articolo sul Pubblic Testing, e ai relativi msg lì ricevuti
http://mib.pianetalinux.org/mib/it/mib- ... sting.html

Fase 0>
All'inizio sono stati sprecati alcuni giorni, perchè seguendo un suggerimento ricevuto sul Forum di fondare il KDE-4.3.4
sulle nuove QT4.6, che dicevano essere retrocompatibili, ci siamo ritrovati un KDE 4.3.4 non compatibile con numerosi programmi, tra cui anche Skype: http://mib.pianetalinux.org/mib/distrib ... 7834#p7834

E così abbiamo buttato tutto il porting alle ortiche, e abbiamo iniziato nuovamente usando le QT presenti sul sistema,
4.5.3 su Mandriva 2010.0
4.5.2 su Mandriva 2009.1

Fase 1>
Appena finito tutto il porting nuovamente, lo abbiamo testato tra gli utenti del MIB Staff (internal/private testing phase),
e a noi adesso funzionava tutto, proprio tutto, programmi precedenti, programmi nuovi ed anche Skype naturalmente,
e poi allargato il test a pochi utenti che lo avevano richiesto, ciò ha aiutato a scovare alcune imperfezioni e rimuoverle
(aapgrilla, alejandro nova, germ, anshul jane, fonzie-two, fabio-75, che qui ringrazio per la loro fiducia e collaborazione)

Fase 2>
Abbiamo aperto un Public Testing rivolto a tutti, con repo appositi e stringhe di configurazione e aggiornamento:
il test è stato un successi inaspettato, pensavamo che 20/30 utenti lo avrebbero eseguito ed invece i nostri logs
riportano circa 250 aggiornamenti al MIB KDE 4.3.4...

Fase 3>
Dal momento che il Public Testing di una settimana, aveva dato esiti tutti positivi, siamo passati ieri pomeriggio
al Public Release, copiando i files dai repo dedicati al KDE4.3.4, sui repo MIB standard per 2009.1 e 2010.0, e aggiornando le liste affinchè tutti gli utenti con i repo MIB ne potessero usufruire direttamente.

Stamattina, a neanche 12 ore dal Public Release, sui logs circa 125 aggiornamenti completi MIB KDE 4.3.4,
cosa volere adesso di più?

Come potete vedere, dal momento che il porting era sensibile e delicatissimo, abbiamo usato parecchie precauzioni!


Ciao,
NicCo
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
irascibile55
Nuovo utente
Nuovo utente
Posts: 13
Joined: 19 October 2008, 17:40

Re: Installazione KDE-4.3.4

Post by irascibile55 »

Ciao,
grazie, NicCo, risposta molto precisa tecnicamente e soprattutto molto esauriente, era quello che cercavo, così posso aggiornare il desktop casalingo, se ti ricordi già tempo fa, evevo posto la stessa domanda relativa alla versione cooker che porta le QT 4.6 e con questa versione purtroppo la chat non funziona, dovendo usare skype per parlare con mio figlio non potevo compromettere la situazione altrimenti, la moglie mi avrebbe rosicato.
Ti ringrazio e procedo subito con l'aggiornamento.
Cordialmente
Irascibile55

User avatar
SymbianFlo
Utente sostenitore
Utente sostenitore
Posts: 1493
Joined: 7 December 2007, 20:07
OpenMandriva: 2010.1 x86_64
Kernel: 2.6.33.5-nrj-69mib
Desktop: kde4.5.rc1
Location: Pordenone
Contact:

Re: Installazione KDE-4.3.4

Post by SymbianFlo »

@Irascibile
prima cosa che si controlla da noi e se skype funziona regolare , come ti ha gia detto Nicco
tra di noi usiamo skype per tutto , trasferimenti file , conferenze , conversazioni etc.
@
Nicco
4 ubuntisti convertiti a mandriva 2009.1 in 64 ( solo perche ci si puo ancora installare pacchetti kde3.5.10 sulla 2009.1)
grazie al kde4.3.4 il mio lug pullula de kde4.3.4 :lol: :lol: :lol:

[aggiornato]
e altri 2 a 2010.0

PS:
Mandriva non vale tutto questo sforzo , ma un ubuntista convertito vale piu di mille Anne Nicolas :lol: :lol: :lol: :lol: :lol:
:D ciao ciao SymbianFlo :D
Image
Linus Torvalds only has to enter a room, and every Windows computer in it segfaults instantly.
http://video.linuxfoundation.org/video/1057

User avatar
NicCo
Amministratore
Amministratore
Posts: 4740
Joined: 6 December 2007, 19:54

Re: Installazione KDE-4.3.4

Post by NicCo »

irascibile55 wrote:Ciao,
grazie, NicCo, risposta molto precisa tecnicamente e soprattutto molto esauriente, era quello che cercavo, così posso aggiornare il desktop casalingo, se ti ricordi già tempo fa, evevo posto la stessa domanda relativa alla versione cooker che porta le QT 4.6 e con questa versione purtroppo la chat non funziona, dovendo usare skype per parlare con mio figlio non potevo compromettere la situazione altrimenti, la moglie mi avrebbe rosicato.
Ti ringrazio e procedo subito con l'aggiornamento.
Cordialmente
Irascibile55
Quando hai installato tutto, riavviato più volte, e usato un pò il sistema per alcune ore, facci sapere quali sono le tue impressioni d'uso:
- prima dell'aggiornamento
- dopo l'aggiornamento al MIB KDE 4.3.4

Ciao,
NicCo
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
steros
Utente junior
Utente junior
Posts: 59
Joined: 10 December 2009, 10:29
ROSA: 2012.1
OpenMandriva: -
Kernel: 3.10.21-nrjQL
Desktop: Kde 4
country: Italy

Re: Installazione KDE-4.3.4

Post by steros »

Ciao a tutti.
Ho aggiornato la mia 2009.1 con il nuovo kde 4.3.4 e Skype mi è stato fatto fuori.
Non riesco più a installarlo perché sembra che dipenda da pacchetti più vecchi di quelli che ho adesso in uso. Ad esempio dipende da libqtcore4 che, a sua volta, non è installabile perché dipende da pacchetti più vecchi e via dicendo...
Idee?
Steros - Mdv Rosa 2012.1 x86_64 - KDE 4

User avatar
NicCo
Amministratore
Amministratore
Posts: 4740
Joined: 6 December 2007, 19:54

Re: Installazione KDE-4.3.4

Post by NicCo »

steros wrote:Ciao a tutti.
Ho aggiornato la mia 2009.1 con il nuovo kde 4.3.4 e Skype mi è stato fatto fuori.
Non riesco più a installarlo perché sembra che dipenda da pacchetti più vecchi di quelli che ho adesso in uso. Ad esempio dipende da libqtcore4 che, a sua volta, non è installabile perché dipende da pacchetti più vecchi e via dicendo...
Idee?
Io ho la 2009.1 x64, e il mio Skype 2.1.0.44 è funzionante e attivo 24h/24h

Sicuramente hai un problema di repository, per esempio se hai installato l'architettura x86_64, devi aver abilitato anche i repo 32bit, altrimenti le librerie necessarie in maniera compatibilità non vengono trovate e programmi come Skype non possono sopravvivere,

ho pubblicato una guida su una buona configurazione dei repo, ma cancella prima i repo precedenti...
http://mib.pianetalinux.org/mib/forum/i ... =viewtopic

e cosi' se installi una 64bit è consigliabile avere installati anche tutti i repo 32bit, anche se in modalità disabilitata, poi quando occorre si abilitano per esempio i repo main32/release e main32/updates, per installare lo Skype, e poi alla fine si disabilitano nuovamente (non c'è bisogno di cancellarli),

ho usato una tecnica simile con uno script adeguato per installare l'emulatore PSX (solo 32bit) su una Mandriva 64bit:
esso necessitava librerie 32bit sia da /main che da /contrib, e ho scritto una Guida ad Hoc:
http://mib.pianetalinux.org/mib/forum/i ... =viewtopic
Analizzate adesso lo script:
  • attivo i repo che servono con un nome "tmp_Main_32_release" e così gli altri,
  • dò il comando per installare "urpmi epsxe",
  • rimuovo i repo aggiunti che adesso non servono più
Ciao,
NicCo
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
steros
Utente junior
Utente junior
Posts: 59
Joined: 10 December 2009, 10:29
ROSA: 2012.1
OpenMandriva: -
Kernel: 3.10.21-nrjQL
Desktop: Kde 4
country: Italy

Re: Installazione KDE-4.3.4

Post by steros »

Grazie per la risposta, ma purtroppo il problema persiste. Mi ero dimenticato di dire che la versione in uso è x86_64.
Ho utilizzato gli stessi repository russi riportati nell'esempio ma non è cambiato niente.
Ho notato che te parli di Skype 2.1.0.44, mentre sul repository io trovo la versione 2.1.0.47. Hai forse sbagliato a scrivere o hai veramente quella versione?
Inoltre sul repository trovo sia Skype a 32 che a 64 bit (entrambi non installabili). Quale hai utilizzato?
Tra l'altro, su un altro PC con la 2010.0 (x86_64) aggiornata sempre al kde 4.3.4 sto utilizzando senza problemi Skype a 64 bit.
Qualcuno mi sa aiutare?
Steros - Mdv Rosa 2012.1 x86_64 - KDE 4

User avatar
NicCo
Amministratore
Amministratore
Posts: 4740
Joined: 6 December 2007, 19:54

Re: Installazione KDE-4.3.4

Post by NicCo »

Per la versione di Skype ho sbaglaito solo a scrivere il numero...

Se l'altro PC va, anche questo deve andare, ti ripeto che non hai i repo configurati correttamente, così lo Skype non può scaricarsi dal repo 32bit alcune indispensabili librerie 32bit (di cui non ricordo i nomi ma sono circa 5 rpms), e quindi si rifiuta anche di farsi installare, quindi io cancellerei tutti i repo, e li rimetterei nuovamente seguendo la mia guida, e avendo cura di abilitare il repo main32/release e main32/updates durante l'installazione di Skype

Ciao,
NicCo
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
SymbianFlo
Utente sostenitore
Utente sostenitore
Posts: 1493
Joined: 7 December 2007, 20:07
OpenMandriva: 2010.1 x86_64
Kernel: 2.6.33.5-nrj-69mib
Desktop: kde4.5.rc1
Location: Pordenone
Contact:

Re: Installazione KDE-4.3.4

Post by SymbianFlo »

steros wrote:Ciao a tutti.
Ho aggiornato la mia 2009.1 con il nuovo kde 4.3.4 e Skype mi è stato fatto fuori.
Non riesco più a installarlo perché sembra che dipenda da pacchetti più vecchi di quelli che ho adesso in uso. Ad esempio dipende da libqtcore4 che, a sua volta, non è installabile perché dipende da pacchetti più vecchi e via dicendo...
Idee?
ciao
stella
libqtcore4 e a 32 bit invece lib64qtcore4 e a 64 bit , ok quindi se tu hai i repo main 32 e main 32-updates come gia detto da nicco non devi avere problemi . :D
:D ciao ciao SymbianFlo :D
Image
Linus Torvalds only has to enter a room, and every Windows computer in it segfaults instantly.
http://video.linuxfoundation.org/video/1057

User avatar
NicCo
Amministratore
Amministratore
Posts: 4740
Joined: 6 December 2007, 19:54

Re: Installazione KDE-4.3.4

Post by NicCo »

steros wrote:Grazie per la risposta, ma purtroppo il problema persiste. Mi ero dimenticato di dire che la versione in uso è x86_64.
Ho utilizzato gli stessi repository russi riportati nell'esempio ma non è cambiato niente.
Ho notato che te parli di Skype 2.1.0.44, mentre sul repository io trovo la versione 2.1.0.47. Hai forse sbagliato a scrivere o hai veramente quella versione?
Inoltre sul repository trovo sia Skype a 32 che a 64 bit (entrambi non installabili). Quale hai utilizzato?
Tra l'altro, su un altro PC con la 2010.0 (x86_64) aggiornata sempre al kde 4.3.4 sto utilizzando senza problemi Skype a 64 bit.
Qualcuno mi sa aiutare?
Ti ho risposto più che sufficientemente dandoti la soluzione qui:
http://mib.pianetalinux.org/mib/forum/i ... opic#p8335


Ma dal momento che essa non sembra portarti alla soluzione:
(avendo altresì notato che anche altri utenti sembrano avere lo stesso piccolo problema che non riescono a risolvere)
ho preparato appositamente per te una Guida, consistente in un piccolo e semplice script da eseguire su Konsole di root:
  • uno è per Mandriva 2010.0 - 64bit
  • l'altro per Mandriva 2009.1 - 64bit
Tale script, va prima ad installare come repositories temporanei tutti quelli che occorrono, usando un nome temporaneo, poi va ad installare SKYPE, quindi cancella i repo temporanei che adesso non occorrono più, e alla fine ti comunica che l'installazione è avvenuta e ti saluta...

Link alla Guida:
http://mib.pianetalinux.org/mib/forum/i ... =viewtopic



Se neanche questo ti è sufficiente, mi spiace, mi arrendo... ma io ce l'ho messa proprio tutta!

Ciao,
Buone Feste e Buon Anno,
da NicCo
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
SymbianFlo
Utente sostenitore
Utente sostenitore
Posts: 1493
Joined: 7 December 2007, 20:07
OpenMandriva: 2010.1 x86_64
Kernel: 2.6.33.5-nrj-69mib
Desktop: kde4.5.rc1
Location: Pordenone
Contact:

Re: Installazione KDE-4.3.4

Post by SymbianFlo »

:lol: :lol: piu facile de cosi manco in winzozz non installi :lol:
:D ciao ciao SymbianFlo :D
Image
Linus Torvalds only has to enter a room, and every Windows computer in it segfaults instantly.
http://video.linuxfoundation.org/video/1057

User avatar
irascibile55
Nuovo utente
Nuovo utente
Posts: 13
Joined: 19 October 2008, 17:40

Re: Installazione KDE-4.3.4

Post by irascibile55 »

ciao a tutti,
ho installato kde 4.3.4 tutto ok. grazie di tutto.

Per skype : steros installa la versione static

Post Reply