Problema installazione nuove qt4-4.7.4-69.1mib2010.2

Discussioni e feedback su pacchetti e repository MIB
User avatar
akiro
Utente
Utente
Posts: 143
Joined: 6 August 2009, 0:06
ROSA: -
OpenMandriva: -
Kernel: 4.9.35-desktop-1.mga
Desktop: KDE 5.12.2
country: italia
Location: prov di MI
Contact:

Re: Problema installazione nuove qt4-4.7.4-69.1mib2010.2

Post by akiro »

ciao,
ho anch'io qualche problema con il pacchetto in oggetto ed una Mandriva 2010.2 x86_64.

ieri il sistema ha fatto l'aggiornamento delle ultime qt4 ma deve averlo fatto parzialmente, qui il log messages:

Code: Select all

Feb  2 23:47:43 picci mdkapplet[1198]: Checking... Updates are available#012
Feb  2 23:47:45 picci mdkapplet[1198]: Launching MandrivaUpdate
Feb  2 23:47:45 picci mdkapplet[1198]: running: MandrivaUpdate --no-media-update --no-confirmation --no-splash
Feb  2 23:47:48 picci MandrivaUpdate[10050]: ### Program is starting ###
Feb  2 23:47:49 picci MandrivaUpdate[10050]: opening the RPM database
Feb  2 23:47:51 picci MandrivaUpdate[10050]: opening the RPM database
Feb  2 23:48:02 picci MandrivaUpdate: transaction on / (remove=0, install=0, upgrade=8)
Feb  2 23:48:05 picci MandrivaUpdate[10050]: [RPM] qt4-common-4.7.4-69.1mib2010.2 installed
Feb  2 23:48:06 picci MandrivaUpdate[10050]: [RPM] lib64qtcore4-4.7.4-69.1mib2010.2 installed
Feb  2 23:48:06 picci MandrivaUpdate[10050]: [RPM] lib64qtnetwork4-4.7.4-69.1mib2010.2 installed
Feb  2 23:48:08 picci MandrivaUpdate[10050]: [RPM] lib64qtgui4-4.7.4-69.1mib2010.2 installed
Feb  2 23:48:08 picci MandrivaUpdate[10050]: [RPM] lib64qtsvg4-4.7.4-69.1mib2010.2 installed
Feb  2 23:48:09 picci MandrivaUpdate[10050]: [RPM] lib64qtxmlpatterns4-4.7.4-69.1mib2010.2 installed
Feb  2 23:48:11 picci MandrivaUpdate[10050]: [RPM] lib64qtwebkit4-4.7.4-69.1mib2010.2 installed
Feb  2 23:48:11 picci MandrivaUpdate[10050]: [RPM] qt4-xmlpatterns-4.7.4-69.1mib2010.2 installed
Feb  2 23:48:11 picci MandrivaUpdate[10050]: [RPM] qt4-common-4.7.3-2mib2010.2 removed
Feb  2 23:48:12 picci MandrivaUpdate[10050]: [RPM] lib64qtnetwork4-4.7.3-2mib2010.2 removed
Feb  2 23:48:12 picci MandrivaUpdate[10050]: [RPM] lib64qtsvg4-4.7.3-2mib2010.2 removed
Feb  2 23:48:13 picci MandrivaUpdate[10050]: [RPM] lib64qtcore4-4.7.3-2mib2010.2 removed
Feb  2 23:48:13 picci MandrivaUpdate[10050]: [RPM] lib64qtxmlpatterns4-4.7.3-2mib2010.2 removed
Feb  2 23:48:14 picci MandrivaUpdate[10050]: [RPM] lib64qtwebkit4-4.7.3-2mib2010.2 removed
Feb  2 23:48:14 picci MandrivaUpdate[10050]: [RPM] lib64qtgui4-4.7.3-2mib2010.2 removed
Feb  2 23:48:15 picci MandrivaUpdate[10050]: [RPM] qt4-xmlpatterns-4.7.3-2mib2010.2 removed
Feb  2 23:48:15 picci MandrivaUpdate: transaction on / (remove=0, install=0, upgrade=8)
Feb  2 23:48:17 picci MandrivaUpdate[10050]: [RPM] lib64qtxml4-4.7.4-69.1mib2010.2 installed
Feb  2 23:48:18 picci MandrivaUpdate[10050]: [RPM] lib64qtdbus4-4.7.4-69.1mib2010.2 installed
Feb  2 23:48:18 picci MandrivaUpdate[10050]: [RPM] lib64qtsql4-4.7.4-69.1mib2010.2 installed
Feb  2 23:48:19 picci MandrivaUpdate[10050]: [RPM] lib64qtscript4-4.7.4-69.1mib2010.2 installed
Feb  2 23:48:19 picci MandrivaUpdate[10050]: [RPM] nss-shlibsign-3.13.1-69.2mib2010.2 installed
Feb  2 23:48:20 picci MandrivaUpdate[10050]: [RPM] lib64nss3-3.13.1-69.2mib2010.2 installed
Feb  2 23:48:24 picci MandrivaUpdate[10050]: [RPM] nss-3.13.1-69.2mib2010.2 installed
Feb  2 23:48:24 picci MandrivaUpdate[10050]: [RPM] lib64qt3support4-4.7.4-69.1mib2010.2 installed
Feb  2 23:48:25 picci MandrivaUpdate[10050]: [RPM] lib64nss3-3.13.1-69.1mib2010.2 removed
Feb  2 23:48:25 picci MandrivaUpdate[10050]: [RPM] lib64qtxml4-4.7.3-2mib2010.2 removed
Feb  2 23:48:26 picci MandrivaUpdate[10050]: [RPM] lib64qtdbus4-4.7.3-2mib2010.2 removed
Feb  2 23:48:26 picci MandrivaUpdate[10050]: [RPM] lib64qtsql4-4.7.3-2mib2010.2 removed
Feb  2 23:48:27 picci MandrivaUpdate[10050]: [RPM] nss-3.13.1-69.1mib2010.2 removed
Feb  2 23:48:28 picci MandrivaUpdate[10050]: [RPM] lib64qtscript4-4.7.3-2mib2010.2 removed
Feb  2 23:48:28 picci MandrivaUpdate[10050]: [RPM] lib64qt3support4-4.7.3-2mib2010.2 removed
Feb  2 23:48:28 picci MandrivaUpdate: transaction on / (remove=0, install=0, upgrade=8)
Feb  2 23:48:30 picci MandrivaUpdate[10050]: [RPM] lib64qtdesigner4-4.7.4-69.1mib2010.2 installed
Feb  2 23:48:31 picci MandrivaUpdate[10050]: [RPM] lib64qtscripttools4-4.7.4-69.1mib2010.2 installed
Feb  2 23:48:31 picci MandrivaUpdate[10050]: [RPM] lib64qtmultimedia4-4.7.4-69.1mib2010.2 installed
Feb  2 23:48:31 picci MandrivaUpdate[10050]: [RPM] qt4-database-plugin-mysql-4.7.4-69.1mib2010.2 installed
Feb  2 23:48:32 picci MandrivaUpdate[10050]: [RPM] lib64qtclucene4-4.7.4-69.1mib2010.2 installed
Feb  2 23:48:33 picci MandrivaUpdate[10050]: [RPM] lib64qtopengl4-4.7.4-69.1mib2010.2 installed
Feb  2 23:48:34 picci MandrivaUpdate[10050]: [RPM] rootcerts-20120117.00-69.1mib2010.2 installed
Feb  2 23:48:35 picci MandrivaUpdate[10050]: [RPM] lib64qttest4-4.7.4-69.1mib2010.2 installed
Feb  2 23:48:35 picci MandrivaUpdate[10050]: [RPM] lib64qtdesigner4-4.7.3-2mib2010.2 removed
Feb  2 23:48:36 picci MandrivaUpdate[10050]: [RPM] lib64qtscripttools4-4.7.3-2mib2010.2 removed
Feb  2 23:48:36 picci MandrivaUpdate[10050]: [RPM] lib64qtmultimedia4-4.7.3-2mib2010.2 removed
Feb  2 23:48:37 picci MandrivaUpdate[10050]: [RPM] qt4-database-plugin-mysql-4.7.3-2mib2010.2 removed
Feb  2 23:48:37 picci MandrivaUpdate[10050]: [RPM] lib64qtclucene4-4.7.3-2mib2010.2 removed
Feb  2 23:48:38 picci MandrivaUpdate[10050]: [RPM] lib64qtopengl4-4.7.3-2mib2010.2 removed
Feb  2 23:48:39 picci MandrivaUpdate[10050]: [RPM] rootcerts-20111103.00-69.1mib2010.2 removed
Feb  2 23:48:39 picci MandrivaUpdate[10050]: [RPM] lib64qttest4-4.7.3-2mib2010.2 removed
Feb  2 23:48:39 picci MandrivaUpdate: transaction on / (remove=0, install=0, upgrade=6)
Feb  2 23:48:49 picci MandrivaUpdate[10050]: [RPM] wine64-1.4-0.rc1.69.1mib2010.2 installed
Feb  2 23:48:57 picci MandrivaUpdate[10050]: [RPM] wine32-1.4-0.rc1.69.1mib2010.2 installed
Feb  2 23:49:00 picci MandrivaUpdate[10050]: [RPM] lib64qthelp4-4.7.4-69.1mib2010.2 installed
Feb  2 23:49:02 picci MandrivaUpdate[10050]: [RPM] lib64qtdeclarative4-4.7.4-69.1mib2010.2 installed
Feb  2 23:49:02 picci MandrivaUpdate[10050]: [RPM] qt4-database-plugin-sqlite-4.7.4-69.1mib2010.2 installed
Feb  2 23:49:03 picci MandrivaUpdate[10050]: [RPM] qt4-qtdbus-4.7.4-69.1mib2010.2 installed
Feb  2 23:49:06 picci MandrivaUpdate[10050]: [RPM] wine32-1.3.37-69.1mib2010.2 removed
Feb  2 23:49:07 picci MandrivaUpdate[10050]: [RPM] lib64qthelp4-4.7.3-2mib2010.2 removed
Feb  2 23:49:08 picci MandrivaUpdate[10050]: [RPM] lib64qtdeclarative4-4.7.3-2mib2010.2 removed
Feb  2 23:49:11 picci MandrivaUpdate[10050]: [RPM] wine64-1.3.37-69.1mib2010.2 removed
Feb  2 23:49:11 picci MandrivaUpdate[10050]: [RPM] qt4-database-plugin-sqlite-4.7.3-2mib2010.2 removed
Feb  2 23:49:12 picci MandrivaUpdate[10050]: [RPM] qt4-qtdbus-4.7.3-2mib2010.2 removed
Feb  2 23:49:13 picci MandrivaUpdate[10050]: running: rpm -ql qt4-common-4.7.4-69.1mib2010.2
Feb  2 23:49:13 picci MandrivaUpdate[10050]: running: rpm -ql lib64qtnetwork4-4.7.4-69.1mib2010.2
Feb  2 23:49:13 picci MandrivaUpdate[10050]: running: rpm -ql lib64qtsvg4-4.7.4-69.1mib2010.2
Feb  2 23:49:13 picci MandrivaUpdate[10050]: running: rpm -ql lib64qtcore4-4.7.4-69.1mib2010.2
Feb  2 23:49:13 picci MandrivaUpdate[10050]: running: rpm -ql lib64qtxmlpatterns4-4.7.4-69.1mib2010.2
Feb  2 23:49:13 picci MandrivaUpdate[10050]: running: rpm -ql lib64qtwebkit4-4.7.4-69.1mib2010.2
Feb  2 23:49:13 picci MandrivaUpdate[10050]: running: rpm -ql lib64qtgui4-4.7.4-69.1mib2010.2
Feb  2 23:49:13 picci MandrivaUpdate[10050]: running: rpm -ql qt4-xmlpatterns-4.7.4-69.1mib2010.2
Feb  2 23:49:13 picci MandrivaUpdate[10050]: running: rpm -ql lib64nss3-3.13.1-69.2mib2010.2
Feb  2 23:49:13 picci MandrivaUpdate[10050]: running: rpm -ql nss-shlibsign-3.13.1-69.2mib2010.2
Feb  2 23:49:13 picci MandrivaUpdate[10050]: running: rpm -ql lib64qtxml4-4.7.4-69.1mib2010.2
Feb  2 23:49:13 picci MandrivaUpdate[10050]: running: rpm -ql lib64qtdbus4-4.7.4-69.1mib2010.2
Feb  2 23:49:14 picci MandrivaUpdate[10050]: running: rpm -ql lib64qtsql4-4.7.4-69.1mib2010.2
Feb  2 23:49:14 picci MandrivaUpdate[10050]: running: rpm -ql nss-3.13.1-69.2mib2010.2
Feb  2 23:49:14 picci MandrivaUpdate[10050]: running: rpm -ql lib64qtscript4-4.7.4-69.1mib2010.2
Feb  2 23:49:14 picci MandrivaUpdate[10050]: running: rpm -ql lib64qt3support4-4.7.4-69.1mib2010.2
Feb  2 23:49:14 picci MandrivaUpdate[10050]: running: rpm -ql lib64qtdesigner4-4.7.4-69.1mib2010.2
Feb  2 23:49:14 picci MandrivaUpdate[10050]: running: rpm -ql lib64qtscripttools4-4.7.4-69.1mib2010.2
Feb  2 23:49:14 picci MandrivaUpdate[10050]: running: rpm -ql lib64qtmultimedia4-4.7.4-69.1mib2010.2
Feb  2 23:49:14 picci MandrivaUpdate[10050]: running: rpm -ql qt4-database-plugin-mysql-4.7.4-69.1mib2010.2
Feb  2 23:49:14 picci MandrivaUpdate[10050]: running: rpm -ql lib64qtclucene4-4.7.4-69.1mib2010.2
Feb  2 23:49:14 picci MandrivaUpdate[10050]: running: rpm -ql lib64qtopengl4-4.7.4-69.1mib2010.2
Feb  2 23:49:14 picci MandrivaUpdate[10050]: running: rpm -ql rootcerts-20120117.00-69.1mib2010.2
Feb  2 23:49:14 picci MandrivaUpdate[10050]: running: rpm -ql lib64qttest4-4.7.4-69.1mib2010.2
Feb  2 23:49:14 picci MandrivaUpdate[10050]: running: rpm -ql wine32-1.4-0.rc1.69.1mib2010.2
Feb  2 23:49:14 picci MandrivaUpdate[10050]: running: rpm -ql lib64qthelp4-4.7.4-69.1mib2010.2
Feb  2 23:49:14 picci MandrivaUpdate[10050]: running: rpm -ql lib64qtdeclarative4-4.7.4-69.1mib2010.2
Feb  2 23:49:14 picci MandrivaUpdate[10050]: running: rpm -ql wine64-1.4-0.rc1.69.1mib2010.2
Feb  2 23:49:14 picci MandrivaUpdate[10050]: running: rpm -ql qt4-database-plugin-sqlite-4.7.4-69.1mib2010.2
Feb  2 23:49:14 picci MandrivaUpdate[10050]: running: rpm -ql qt4-qtdbus-4.7.4-69.1mib2010.2
Feb  2 23:49:16 picci MandrivaUpdate[10050]: opening the RPM database
Feb  2 23:52:46 picci MandrivaUpdate[10050]: ### Program is exiting ###
Feb  2 23:52:46 picci mdkapplet[1198]: Computing new updates...
Feb  2 23:52:46 picci mdkapplet[1198]: running: urpmi.update --update
Feb  2 23:53:18 picci mdkapplet[1198]: Checking... Updates are available#012
...
Feb  3 00:20:29 picci mdkapplet[1198]: Launching MandrivaUpdate
Feb  3 00:20:29 picci mdkapplet[1198]: running: MandrivaUpdate --no-media-update --no-confirmation --no-splash
Feb  3 00:20:32 picci MandrivaUpdate[14521]: ### Program is starting ###
Feb  3 00:20:33 picci MandrivaUpdate[14521]: opening the RPM database
Feb  3 00:20:34 picci MandrivaUpdate[14521]: opening the RPM database
Feb  3 00:20:43 picci MandrivaUpdate: transaction on / (remove=0, install=0, upgrade=2)
Feb  3 00:20:44 picci MandrivaUpdate[14521]: [RPM] lib64apr1-1.4.5-0.1mdv2010.2 installed
Feb  3 00:20:44 picci MandrivaUpdate[14521]: [RPM] lib64apr-util1-1.4.1-0.1mdv2010.2 installed
Feb  3 00:20:44 picci MandrivaUpdate[14521]: [RPM] lib64apr-util1-1.3.9-3.1mdv2010.1 removed
Feb  3 00:20:45 picci MandrivaUpdate[14521]: [RPM] lib64apr1-1.4.2-1.2mdv2010.2 removed
Feb  3 00:20:45 picci MandrivaUpdate[14521]: running: rpm -ql lib64apr-util1-1.4.1-0.1mdv2010.2
Feb  3 00:20:45 picci MandrivaUpdate[14521]: running: rpm -ql lib64apr1-1.4.5-0.1mdv2010.2
Feb  3 00:20:47 picci MandrivaUpdate[14521]: opening the RPM database
Feb  3 00:20:50 picci MandrivaUpdate[14521]: ### Program is exiting ###
Feb  3 00:20:50 picci mdkapplet[1198]: Computing new updates...
Feb  3 00:20:50 picci mdkapplet[1198]: running: urpmi.update --update
Feb  3 00:21:12 picci mdkapplet[1198]: Packages are up to date
in un primo momento mi aveva dato un errore (tipo urpmi non aggiornato) ma avevo chiuso e l'avevo rilanciato, poi ha installato qualcosa, ma al riavvio oggi mi ha dato un problema sulla libqtgui...

Code: Select all

17:17:50 picci kernel: plasma-desktop[1118]: segfault at 60 ip 00007fdf4f7d7d83 sp 00007fff494035d0 error 4 in libQtGui.so.4.7.4[7f
Ho cercato di rimuovere eventuali riferimenti a pacchetti i586 vecchi ed ad aggiornare alle 4.7.4 ma mi sembra tutto a posto.

Come conseguenza non vedo più il desktop, vedo solo il puntatore e tutto il resto è nero... Per fortuna di default parto con una konsole aperta per cui posso lanciare qualche applicazione da lì.

Che posso fare?

edit:
kcrash:

Code: Select all

Application: Spazio di lavoro di Plasma (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fba35c04720 (LWP 1104))]

Thread 2 (Thread 0x7fba11546710 (LWP 1105)):
#0  0x00007fba33e61429 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fba340e9262 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007fba340dd622 in ?? () from /usr/lib64/libQtCore.so.4
#3  0x00007fba340e85f5 in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007fba2a470bc3 in ?? () from /usr/lib64/nvidia-current/libGL.so.1
#5  0x00007fba33e5ca5d in start_thread () from /lib64/libpthread.so.0
#6  0x00007fba32be565d in clone () from /lib64/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fba35c04720 (LWP 1104)):
[KCrash Handler]
#5  0x00007fba335abd83 in QTextEngine::isRightToLeft() const () from /usr/lib64/libQtGui.so.4
#6  0x00007fba335b448a in QTextEngine::leadingSpaceWidth(QScriptLine const&) () from /usr/lib64/libQtGui.so.4
#7  0x00007fba335b5dfb in ?? () from /usr/lib64/libQtGui.so.4
#8  0x00007fba335b7a66 in QTextLine::naturalTextRect() const () from /usr/lib64/libQtGui.so.4
#9  0x00007fba181238d2 in ?? () from /usr/lib64/kde4/plasma_applet_folderview.so
#10 0x00007fba1813107b in ?? () from /usr/lib64/kde4/plasma_applet_folderview.so
#11 0x00007fba18132b46 in ?? () from /usr/lib64/kde4/plasma_applet_folderview.so
#12 0x00007fba339776cd in ?? () from /usr/lib64/libQtGui.so.4
#13 0x00007fba339901d4 in ?? () from /usr/lib64/libQtGui.so.4
#14 0x00007fba3399551b in ?? () from /usr/lib64/libQtGui.so.4
#15 0x00007fba33996182 in ?? () from /usr/lib64/libQtGui.so.4
#16 0x00007fba339955d0 in ?? () from /usr/lib64/libQtGui.so.4
#17 0x00007fba33996182 in ?? () from /usr/lib64/libQtGui.so.4
#18 0x00007fba339969d4 in ?? () from /usr/lib64/libQtGui.so.4
#19 0x00007fba339afdeb in QGraphicsView::paintEvent(QPaintEvent*) () from /usr/lib64/libQtGui.so.4
#20 0x00007fba33392a32 in QWidget::event(QEvent*) () from /usr/lib64/libQtGui.so.4
#21 0x00007fba3375d396 in QFrame::event(QEvent*) () from /usr/lib64/libQtGui.so.4
#22 0x00007fba339ab16b in QGraphicsView::viewportEvent(QEvent*) () from /usr/lib64/libQtGui.so.4
#23 0x00007fba341dad27 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#24 0x00007fba3333cb9c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#25 0x00007fba333417bd in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#26 0x00007fba3472b366 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#27 0x00007fba341db4fc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#28 0x00007fba3339b57d in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib64/libQtGui.so.4
#29 0x00007fba3356e0c6 in ?? () from /usr/lib64/libQtGui.so.4
#30 0x00007fba3338c990 in QWidgetPrivate::syncBackingStore() () from /usr/lib64/libQtGui.so.4
#31 0x00007fba33393105 in QWidget::event(QEvent*) () from /usr/lib64/libQtGui.so.4
#32 0x00007fba3375d396 in QFrame::event(QEvent*) () from /usr/lib64/libQtGui.so.4
#33 0x00007fba337ea64b in QAbstractScrollArea::event(QEvent*) () from /usr/lib64/libQtGui.so.4
#34 0x00007fba3333cbcc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#35 0x00007fba333417bd in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#36 0x00007fba3472b366 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#37 0x00007fba341db4fc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#38 0x00007fba341df39b in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQtCore.so.4
#39 0x00007fba33994aca in ?? () from /usr/lib64/libQtGui.so.4
#40 0x00007fba33995052 in QGraphicsScene::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libQtGui.so.4
#41 0x00007fba2cca9eb5 in Plasma::Corona::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libplasma.so.3
#42 0x00007fba257d7a83 in ?? () from /usr/lib64/libkdeinit4_plasma-desktop.so
#43 0x00007fba341edafe in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#44 0x00007fba3398f3d0 in QGraphicsScene::event(QEvent*) () from /usr/lib64/libQtGui.so.4
#45 0x00007fba3333cbcc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#46 0x00007fba333417bd in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#47 0x00007fba3472b366 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#48 0x00007fba341db4fc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#49 0x00007fba341df39b in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQtCore.so.4
#50 0x00007fba34207c63 in ?? () from /usr/lib64/libQtCore.so.4
#51 0x00007fba2f7af2d2 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#52 0x00007fba2f7b3998 in ?? () from /lib64/libglib-2.0.so.0
#53 0x00007fba2f7b3b4c in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#54 0x00007fba342077a3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#55 0x00007fba333ef11e in ?? () from /usr/lib64/libQtGui.so.4
#56 0x00007fba341da222 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#57 0x00007fba341da60c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#58 0x00007fba341df5d9 in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#59 0x00007fba257dee62 in kdemain () from /usr/lib64/libkdeinit4_plasma-desktop.so
#60 0x0000000000406b08 in _start ()
Last edited by akiro on 3 February 2012, 19:43, edited 1 time in total.
Winston Smith, Arthur Dent, Benjamin Malaussene,...
Mageia 6 x86_64

User avatar
GvMariani
Collaboratore
Collaboratore
Posts: 610
Joined: 27 July 2009, 11:31
ROSA: 2016.1 Fresh R10
OpenMandriva: -
Kernel: 4.19.13-nrj-desktop
Desktop: Plasma 5
country: Italy
Location: Cologno Monzese (MI) - Italia

Re: Problema installazione nuove qt4-4.7.4-69.1mib2010.2

Post by GvMariani »

azioga wrote:Ho sparato i due colpi nel buio, ma non ho colpito nessuno :D
ti allego kdm.log, ma non mi sembra ci sia niente di interessante
Infatti...

Tiriamone un altro paio nel buio:
* Hai provato a resettare la configurazione di KWin? (rimuovi o sposta o rinomina .kde4/share/config/kwinrc)

* Un kernel più recente (cioè un DRM molto più aggiornato dell'attuale) fa differenza?

* Se vai in Configure Your Desktop - Desktop effects e provi a selezionare Xrender e poi ancora OpenGL funge?
E, dopo aver fatto questo, in .xsession-errors che trovi a proposito di Kwin?

GvM

User avatar
GvMariani
Collaboratore
Collaboratore
Posts: 610
Joined: 27 July 2009, 11:31
ROSA: 2016.1 Fresh R10
OpenMandriva: -
Kernel: 4.19.13-nrj-desktop
Desktop: Plasma 5
country: Italy
Location: Cologno Monzese (MI) - Italia

Re: Problema installazione nuove qt4-4.7.4-69.1mib2010.2

Post by GvMariani »

akiro wrote:ciao,
ho anch'io qualche problema con il pacchetto in oggetto ed una Mandriva 2010.2 x86_64.
ieri il sistema ha fatto l'aggiornamento delle ultime qt4 ma deve averlo fatto parzialmente, qui il log messages:
in un primo momento mi aveva dato un errore (tipo urpmi non aggiornato) ma avevo chiuso e l'avevo rilanciato, poi ha installato qualcosa, ma al riavvio oggi mi ha dato un problema sulla libqtgui...

Code: Select all

17:17:50 picci kernel: plasma-desktop[1118]: segfault at 60 ip 00007fdf4f7d7d83 sp 00007fff494035d0 error 4 in libQtGui.so.4.7.4[7f
Ho cercato di rimuovere eventuali riferimenti a pacchetti i586 vecchi ed ad aggiornare alle 4.7.4 ma mi sembra tutto a posto.
Come conseguenza non vedo più il desktop, vedo solo il puntatore e tutto il resto è nero... Per fortuna di default parto con una konsole aperta per cui posso lanciare qualche applicazione da lì.
Che posso fare?
Dal log che hai messo non sembrano esserci stati errori: comunque questo è l'elenco completo dei file che dovrebbero esserci (magari non hai i -devel, ma quello non importa)

Code: Select all

lib64qt3support4-4.7.4-69.1mib2010.2.x86_64.rpm          qt4-assistant-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qt4-devel-4.7.4-69.1mib2010.2.x86_64.rpm            qt4-common-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qtclucene4-4.7.4-69.1mib2010.2.x86_64.rpm           qt4-database-plugin-mysql-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qtcore4-4.7.4-69.1mib2010.2.x86_64.rpm              qt4-database-plugin-pgsql-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qtdbus4-4.7.4-69.1mib2010.2.x86_64.rpm              qt4-database-plugin-sqlite-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qtdeclarative4-4.7.4-69.1mib2010.2.x86_64.rpm       qt4-database-plugin-tds-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qtdesigner4-4.7.4-69.1mib2010.2.x86_64.rpm          qt4-demos-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qtgui4-4.7.4-69.1mib2010.2.x86_64.rpm               qt4-designer-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qthelp4-4.7.4-69.1mib2010.2.x86_64.rpm              qt4-designer-plugin-qt3support-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qtmultimedia4-4.7.4-69.1mib2010.2.x86_64.rpm        qt4-designer-plugin-webkit-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qtnetwork4-4.7.4-69.1mib2010.2.x86_64.rpm           qt4-devel-private-4.7.4-69.1mib2010.2.noarch.rpm
lib64qtopengl4-4.7.4-69.1mib2010.2.x86_64.rpm            qt4-doc-4.7.4-69.1mib2010.2.noarch.rpm
lib64qtscript4-4.7.4-69.1mib2010.2.x86_64.rpm            qt4-examples-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qtscripttools4-4.7.4-69.1mib2010.2.x86_64.rpm       qt4-graphicssystems-plugin-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qtsql4-4.7.4-69.1mib2010.2.x86_64.rpm               qt4-linguist-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qtsvg4-4.7.4-69.1mib2010.2.x86_64.rpm               qt4-qdoc3-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qttest4-4.7.4-69.1mib2010.2.x86_64.rpm              qt4-qmlviewer-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qtwebkit4-4.7.4-69.1mib2010.2.x86_64.rpm            qt4-qtconfig-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qtxml4-4.7.4-69.1mib2010.2.x86_64.rpm               qt4-qtdbus-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qtxmlpatterns4-4.7.4-69.1mib2010.2.x86_64.rpm       qt4-qvfb-4.7.4-69.1mib2010.2.x86_64.rpm
qt4-accessibility-plugin-4.7.4-69.1mib2010.2.x86_64.rpm  qt4-xmlpatterns-4.7.4-69.1mib2010.2.x86_64.rpm
Prima di fare diagnosi, serve qualche info in più:
* scheda e drive video usati
* contenuto di xorg.conf
* il file .xsession-errors
* l'output di dmesg
* il contenuto del file Xorg.0.log
* l'output di glxinfo.

Un paio di tentativi iniziali potrebbero comunque essere:
* resettare KWin: rimuovi o sposta o rinomina .kde4/share/config/kwinrc
* resettare la configurazione del Desktop KDE: rinomina la directory .kde4
Lo schermo nero con cursore funzionante e applicazioni già aperte funzionanti puzza di problemi di configurazione di KWin/KDE
(e se ne dovrebbe trovare traccia in .xsession-errors): se fosse un problema sottostante non avresti neppure quelli.

GvM

User avatar
akiro
Utente
Utente
Posts: 143
Joined: 6 August 2009, 0:06
ROSA: -
OpenMandriva: -
Kernel: 4.9.35-desktop-1.mga
Desktop: KDE 5.12.2
country: italia
Location: prov di MI
Contact:

Re: Problema installazione nuove qt4-4.7.4-69.1mib2010.2

Post by akiro »

GvMariani wrote: Dal log che hai messo non sembrano esserci stati errori: comunque questo è l'elenco completo dei file che dovrebbero esserci (magari non hai i -devel, ma quello non importa)

Code: Select all

lib64qt3support4-4.7.4-69.1mib2010.2.x86_64.rpm          qt4-assistant-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qt4-devel-4.7.4-69.1mib2010.2.x86_64.rpm            qt4-common-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qtclucene4-4.7.4-69.1mib2010.2.x86_64.rpm           qt4-database-plugin-mysql-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qtcore4-4.7.4-69.1mib2010.2.x86_64.rpm              qt4-database-plugin-pgsql-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qtdbus4-4.7.4-69.1mib2010.2.x86_64.rpm              qt4-database-plugin-sqlite-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qtdeclarative4-4.7.4-69.1mib2010.2.x86_64.rpm       qt4-database-plugin-tds-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qtdesigner4-4.7.4-69.1mib2010.2.x86_64.rpm          qt4-demos-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qtgui4-4.7.4-69.1mib2010.2.x86_64.rpm               qt4-designer-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qthelp4-4.7.4-69.1mib2010.2.x86_64.rpm              qt4-designer-plugin-qt3support-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qtmultimedia4-4.7.4-69.1mib2010.2.x86_64.rpm        qt4-designer-plugin-webkit-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qtnetwork4-4.7.4-69.1mib2010.2.x86_64.rpm           qt4-devel-private-4.7.4-69.1mib2010.2.noarch.rpm
lib64qtopengl4-4.7.4-69.1mib2010.2.x86_64.rpmvi iniziali potrebbero comunque essere:            qt4-doc-4.7.4-69.1mib2010.2.noarch.rpm
lib64qtscript4-4.7.4-69.1mib2010.2.x86_64.rpm            qt4-examples-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qtscripttools4-4.7.4-69.1mib2010.2.x86_64.rpm       qt4-graphicssystems-plugin-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qtsql4-4.7.4-69.1mib2010.2.x86_64.rpm               qt4-linguist-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qtsvg4-4.7.4-69.1mib2010.2.x86_64.rpm               qt4-qdoc3-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qttest4-4.7.4-69.1mib2010.2.x86_64.rpm              qt4-qmlviewer-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qtwebkit4-4.7.4-69.1mib2010.2.x86_64.rpm            qt4-qtconfig-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qtxml4-4.7.4-69.1mib2010.2.x86_64.rpm               qt4-qtdbus-4.7.4-69.1mib2010.2.x86_64.rpm
lib64qtxmlpatterns4-4.7.4-69.1mib2010.2.x86_64.rpm       qt4-qvfb-4.7.4-69.1mib2010.2.x86_64.rpm
qt4-accessibility-plugin-4.7.4-69.1mib2010.2.x86_64.rpm  qt4-xmlpatterns-4.7.4-69.1mib2010.2.x86_64.rpm
alcuni pacchetti mancavano e li ho installati:

Code: Select all

qt4-assistant-4.7.4-69.1mib2010.2.x86_64.rpm
 qt4-graphicssystems-plugin-4.7.4-69.1mib2010.2.x86_64.rpm
qt4-linguist-4.7.4-69.1mib2010.2.x86_64.rpm
qt4-qmlviewer-4.7.4-69.1mib2010.2.x86_64.rpm
qt4-qtconfig-4.7.4-69.1mib2010.2.x86_64.rpm
qt4-qvfb-4.7.4-69.1mib2010.2.x86_64.rpm
qt4-accessibility-plugin-4.7.4-69.1mib2010.2.x86_64.rpm
 qt4-designer-plugin-qt3support-4.7.4-69.1mib2010.2.x86_64.rpm
qt4-designer-plugin-webkit-4.7.4-69.1mib2010.2.x86_64.rpm
qt4-database-plugin-tds-4.7.4-69.1mib2010.2.x86_64.rpm
qt4-demos-4.7.4-69.1mib2010.2.x86_64.rpm
altri non riesco (perché non è soddisfatto libOpenVG.so.1()(64bit))...

Code: Select all

lib64qt4-devel-4.7.4-69.1mib2010.2.x86_64 
qt4-designer-4.7.4-69.1mib2010.2.x86_64.rpm
qt4-devel-private-4.7.4-69.1mib2010.2.noarch.rpm

GvMariani wrote: Prima di fare diagnosi, serve qualche info in più:
* scheda e drive video usati
* contenuto di xorg.conf
* il file .xsession-errors
* l'output di dmesg
* il contenuto del file Xorg.0.log
* l'output di glxinfo.
uso i driver proprietari di nvidia (ho una gtx 460)

xorg.0.log

xorg.conf

Code: Select all

# File generated by XFdrake (rev )

Section "Monitor"
    Identifier "monitor1"
    VendorName "Samsung"
    ModelName "Samsung SyncMaster 931BF (DVI)"
    HorizSync 30-81
    VertRefresh 56-75
    
    # Monitor supported modeline (60.0 Hz vsync, 47.7 kHz hsync, ratio 16/9, 26 dpi)
    ModeLine "1360x768" 85.5 1360 1424 1536 1792 768 771 777 795 +hsync +vsync
    
    # Monitor preferred modeline (60.0 Hz vsync, 67.5 kHz hsync, ratio 16/9, 38 dpi)
    ModeLine "1920x1080" 148.5 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
    
    # TV fullscreen mode or DVD fullscreen output.
    # 768x576 @ 79 Hz, 50 kHz hsync
    ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630
    
    # 768x576 @ 100 Hz, 61.6 kHz hsync
    ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
    
    # modeline generated by gtf(1) [handled by XFdrake]
    ModeLine "1440x900_120"  229.75  1440 1552 1712 1984  900 901 904 965  -HSync +Vsync
    
    # modeline generated by gtf(1) [handled by XFdrake]
    ModeLine "1440x900_100"  187.55  1440 1544 1704 1968  900 901 904 953  -HSync +Vsync
    
    # modeline generated by gtf(1) [handled by XFdrake]
    ModeLine "1440x900_85"  156.79  1440 1536 1696 1952  900 901 904 945  -HSync +Vsync
    
    # modeline generated by gtf(1) [handled by XFdrake]
    ModeLine "1440x900_75"  136.49  1440 1536 1688 1936  900 901 904 940  -HSync +Vsync
    
    # modeline generated by gtf(1) [handled by XFdrake]
    ModeLine "1440x900_60"  106.47  1440 1520 1672 1904  900 901 904 932  -HSync +Vsync
    
    # modeline generated by gtf(1) [handled by XFdrake]
    ModeLine "1440x900_50"  87.41  1440 1512 1664 1888  900 901 904 926  -HSync +Vsync
    
    # modeline generated by gtf(1) [handled by XFdrake]
    ModeLine "1280x800_120"  181.21  1280 1376 1520 1760  800 801 804 858  -HSync +Vsync
    
    # modeline generated by gtf(1) [handled by XFdrake]
    ModeLine "1280x800_100"  147.89  1280 1376 1512 1744  800 801 804 848  -HSync +Vsync
    
    # modeline generated by gtf(1) [handled by XFdrake]
    ModeLine "1280x800_85"  123.38  1280 1368 1504 1728  800 801 804 840  -HSync +Vsync
    
    # modeline generated by gtf(1) [handled by XFdrake]
    ModeLine "1280x800_75"  107.21  1280 1360 1496 1712  800 801 804 835  -HSync +Vsync
    
    # modeline generated by gtf(1) [handled by XFdrake]
    ModeLine "1280x800_60"  83.46  1280 1344 1480 1680  800 801 804 828  -HSync +Vsync
    
    # modeline generated by gtf(1) [handled by XFdrake]
    ModeLine "1280x800_50"  68.56  1280 1336 1472 1664  800 801 804 824  -HSync +Vsync
EndSection

Section "Device"
    Identifier "device1"
    VendorName "nVidia Corporation"
    BoardName "NVIDIA GeForce 400 series and later"
    Driver "nvidia"
    Option "DPMS"
    Option "DynamicTwinView" "false"
    Option "AddARGBGLXVisuals"
EndSection

Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultColorDepth 24
    
    Subsection "Display"
        Depth 8
        Modes "1440x900" "1280x800"
    EndSubsection
    
    Subsection "Display"
        Depth 15
        Modes "1440x900" "1280x800"
    EndSubsection
    
    Subsection "Display"
        Depth 16
        Modes "1440x900" "1280x800"
    EndSubsection
    
    Subsection "Display"
        Depth 24
        Modes "1440x900" "1280x800"
    EndSubsection
EndSection
# File generated by XFdrake (rev )

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 270.41.06  (buildmeister@swio-display-x86-rhel47-08.nvidia.com)  Mon Apr 18 15:14:00 PDT 2011

# File generated by XFdrake (rev )
# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "ServerLayout"
    Identifier "layout1"
    InputDevice "Keyboard0" "CoreKeyboard"
    Screen "screen1"
EndSection

Section "Module"
    # Load "v4l" # Video for Linux
    Load "dbe" # Double-Buffering Extension
    Load "extmod"
    Load "glx" # 3D layer
EndSection

Section "ServerFlags"
    Option "DontZap" "False" # disable <Ctrl><Alt><BS> (server abort)
    
    # allows the server to start up even if the mouse does not work
    #DontZoom # disable <Ctrl><Alt><KP_+>/<KP_-> (resolution switching)
    Option "allowmouseopenfail"
EndSection

Section "InputDevice"
    # generated from default
    Identifier "Keyboard0"
    Driver "kbd"
EndSection
output di dmesg
file .xsession-errors


GvMariani wrote: Un paio di tentativi iniziali potrebbero comunque essere:
* resettare KWin: rimuovi o sposta o rinomina .kde4/share/config/kwinrc
* resettare la configurazione del Desktop KDE: rinomina la directory .kde4
Provati entrambi ma il problema rimane.
Winston Smith, Arthur Dent, Benjamin Malaussene,...
Mageia 6 x86_64

User avatar
azioga
Utente senior
Utente senior
Posts: 336
Joined: 8 December 2010, 22:06
ROSA: -
OpenMandriva: 2010.2 32bit
Kernel: 3.2.28-nrj-desktop-p
Desktop: kde 4.5.5
country: italy

Re: Problema installazione nuove qt4-4.7.4-69.1mib2010.2

Post by azioga »

GvMariani wrote: Tiriamone un altro paio nel buio:
* Hai provato a resettare la configurazione di KWin? (rimuovi o sposta o rinomina .kde4/share/config/kwinrc)

* Un kernel più recente (cioè un DRM molto più aggiornato dell'attuale) fa differenza?

* Se vai in Configure Your Desktop - Desktop effects e provi a selezionare Xrender e poi ancora OpenGL funge?
E, dopo aver fatto questo, in .xsession-errors che trovi a proposito di Kwin?
1) provato da xguest - stesso problema

2) con queste mesa non riesco a compilare il modulo nvidia: al momento del depmod esce con FAILED PCI unsaccodinumeri not found

3) fallisce nel ritorno a OpenGl con gli stessi errori in .xession-errors

Adesso sono tornato indietro e tutto sembra ok.

Ciao, Luca.

User avatar
GvMariani
Collaboratore
Collaboratore
Posts: 610
Joined: 27 July 2009, 11:31
ROSA: 2016.1 Fresh R10
OpenMandriva: -
Kernel: 4.19.13-nrj-desktop
Desktop: Plasma 5
country: Italy
Location: Cologno Monzese (MI) - Italia

Re: Problema installazione nuove qt4-4.7.4-69.1mib2010.2

Post by GvMariani »

azioga wrote:
GvMariani wrote: Adesso sono tornato indietro e tutto sembra ok.
Ciao, Luca.
Beh. direi che hai già fatto molto...
e sembra proprio che l'accoppiata driver proprietari - nuove Mesa non sia molto felice
(per questo abbiamo in produzione una versione di qt 4.7.4 rebuildata con la "vecchia" 7.8.1...).

Forse l'ultima cosa da provare era verificare che "OpenGLIsUnsafe" in kwinrc (sezione Compositing) fosse uguale a "False":
se posta a "True" questa voce disabilita il compositing in Kwin a prescindere dalla configurazione.

GvM

User avatar
GvMariani
Collaboratore
Collaboratore
Posts: 610
Joined: 27 July 2009, 11:31
ROSA: 2016.1 Fresh R10
OpenMandriva: -
Kernel: 4.19.13-nrj-desktop
Desktop: Plasma 5
country: Italy
Location: Cologno Monzese (MI) - Italia

Re: Problema installazione nuove qt4-4.7.4-69.1mib2010.2

Post by GvMariani »

akiro wrote: Provati entrambi ma il problema rimane.
Ho guardato i vari log che hai allegato ma non vedo ragioni evidenti per quel problema...
Vediamo se è connesso con gli effetti di Kwin: in kwinrc, sotto l'header "Compositing", metti prima la voce "Enabled" a "false"...
riavviando X, ora funziona?

Poi rimetti la voce precedente com'era prima e metti la voce "GLDirect" a "false" e riavvia:
funziona?

Visto che ci sei, verifica anche che la voce "OpenGLIsUnsafe" sia "false".

GvM

User avatar
akiro
Utente
Utente
Posts: 143
Joined: 6 August 2009, 0:06
ROSA: -
OpenMandriva: -
Kernel: 4.9.35-desktop-1.mga
Desktop: KDE 5.12.2
country: italia
Location: prov di MI
Contact:

Re: Problema installazione nuove qt4-4.7.4-69.1mib2010.2

Post by akiro »

GvMariani wrote:Ho guardato i vari log che hai allegato ma non vedo ragioni evidenti per quel problema...
Vediamo se è connesso con gli effetti di Kwin: in kwinrc, sotto l'header "Compositing", metti prima la voce "Enabled" a "false"...
riavviando X, ora funziona?

Poi rimetti la voce precedente com'era prima e metti la voce "GLDirect" a "false" e riavvia:
funziona?

Visto che ci sei, verifica anche che la voce "OpenGLIsUnsafe" sia "false".

GvM
in teoria in kwinrc è già tutto a false quello che mi dici di settare:

Code: Select all

[Compositing]
AnimationSpeed=3
Backend=OpenGL
CheckIsSafe=true
DisableChecks=false
[b]Enabled=false[/b]
[b]GLDirect=false[/b]
GLMode=TFP
GLTextureFilter=0
GLVSync=false
HiddenPreviews=5
XRenderSmoothScale=false

[Desktops]
Name_2=controllo
Number=2

[MouseBindings]
CommandActiveTitlebar1=Raise
CommandActiveTitlebar2=Lower
CommandActiveTitlebar3=Operations menu
CommandAll1=Move
CommandAll2=Toggle raise and lower
CommandAll3=Resize
CommandAllKey=Alt
CommandAllWheel=Nothing
CommandInactiveTitlebar1=Activate and raise
CommandInactiveTitlebar2=Activate and lower
CommandInactiveTitlebar3=Operations menu
CommandTitlebarWheel=Nothing
CommandWindow1=Activate, raise and pass click
CommandWindow2=Activate and pass click
CommandWindow3=Activate and pass click
CommandWindowWheel=Scroll

[Plugins]
kwin4_effect_blurEnabled=false
kwin4_effect_boxswitchEnabled=true
kwin4_effect_coverswitchEnabled=false
kwin4_effect_cubeEnabled=true
kwin4_effect_cubeslideEnabled=false
kwin4_effect_cylinderEnabled=false
kwin4_effect_desktopgridEnabled=true
kwin4_effect_dialogparentEnabled=true
kwin4_effect_diminactiveEnabled=false
kwin4_effect_dimscreenEnabled=false
kwin4_effect_explosionEnabled=false
kwin4_effect_fadeEnabled=true
kwin4_effect_fadedesktopEnabled=false
kwin4_effect_fallapartEnabled=false
kwin4_effect_flipswitchEnabled=false
kwin4_effect_highlightwindowEnabled=false
kwin4_effect_invertEnabled=false
kwin4_effect_loginEnabled=true
kwin4_effect_logoutEnabled=true
kwin4_effect_lookingglassEnabled=false
kwin4_effect_magiclampEnabled=false
kwin4_effect_magnifierEnabled=false
kwin4_effect_maketransparentEnabled=true
kwin4_effect_minimizeanimationEnabled=true
kwin4_effect_mousemarkEnabled=false
kwin4_effect_presentwindowsEnabled=true
kwin4_effect_scaleinEnabled=false
kwin4_effect_shadowEnabled=true
kwin4_effect_sharpenEnabled=false
kwin4_effect_sheetEnabled=false
kwin4_effect_showfpsEnabled=false
kwin4_effect_showpaintEnabled=false
kwin4_effect_slideEnabled=true
kwin4_effect_slidebackEnabled=false
kwin4_effect_snaphelperEnabled=false
kwin4_effect_snowEnabled=false
kwin4_effect_sphereEnabled=false
kwin4_effect_taskbarthumbnailEnabled=true
kwin4_effect_thumbnailasideEnabled=false
kwin4_effect_trackmouseEnabled=true
kwin4_effect_translucencyEnabled=true
kwin4_effect_wobblywindowsEnabled=false
kwin4_effect_zoomEnabled=true

[PopupInfo]
ShowPopup=false

[Style]
BorderSize=1

[TabBox]
ListMode=0
ShowTabBox=true
TraverseAll=false

[Windows]
ActiveMouseScreen=false
AltTabStyle=KDE
AutoRaise=false
AutoRaiseInterval=750
BorderSnapZone=3
CenterSnapZone=0
ClickRaise=true
DelayFocus=false
DelayFocusInterval=750
FocusPolicy=ClickToFocus
FocusStealingPreventionLevel=1
GeometryTip=false
HideUtilityWindowsForInactive=true
MaximizeButtonLeftClickCommand=Maximize
MaximizeButtonMiddleClickCommand=Maximize (vertical only)
MaximizeButtonRightClickCommand=Maximize (horizontal only)
MoveMode=Opaque
MoveResizeMaximizedWindows=false
Placement=Smart
ResizeMode=Opaque
RollOverDesktops=true
SeparateScreenFocus=false
ShadeHover=false
ShadeHoverInterval=250
SnapOnlyWhenOverlapping=false
TitlebarDoubleClickCommand=Maximize
WindowSnapZone=3
e OpenGLIsUnsafe non esiste.


edit:
ho provato comunque a settare i primi due parametri a true (prima uno poi l'altro) ma non è cambiato nulla.

il fatto che ci siano python-qt4-*-4.7.3 è corretto?

Code: Select all

python-qt4-network-4.7.3-2mdv2010.1
python-qt4-webkit-4.7.3-2mdv2010.1
python-qt4-4.7.3-2mdv2010.1
python-qt4-test-4.7.3-2mdv2010.1
python-qt4-xmlpatterns-4.7.3-2mdv2010.1
python-qt4-gui-4.7.3-2mdv2010.1
python-qt4-opengl-4.7.3-2mdv2010.1
python-qt4-sql-4.7.3-2mdv2010.1
python-qt4-assistant-4.7.3-2mdv2010.1
python-qt4-script-4.7.3-2mdv2010.1
python-qt4-core-4.7.3-2mdv2010.1
python-qt4-multimedia-4.7.3-2mdv2010.1
python-qt4-xml-4.7.3-2mdv2010.1
python-qt4-designer-4.7.3-2mdv2010.1
python-qt4-svg-4.7.3-2mdv2010.1
Last edited by akiro on 4 February 2012, 1:07, edited 1 time in total.
Winston Smith, Arthur Dent, Benjamin Malaussene,...
Mageia 6 x86_64

User avatar
GvMariani
Collaboratore
Collaboratore
Posts: 610
Joined: 27 July 2009, 11:31
ROSA: 2016.1 Fresh R10
OpenMandriva: -
Kernel: 4.19.13-nrj-desktop
Desktop: Plasma 5
country: Italy
Location: Cologno Monzese (MI) - Italia

Re: Problema installazione nuove qt4-4.7.4-69.1mib2010.2

Post by GvMariani »

akiro wrote: e OpenGLIsUnsafe non esiste.
Arg...
mi sono accorto adesso dal tuo profilo che hai ancora il KDE originale della 2010.2 (4.4.x):
eccicredo che non funziona...
quello era compilato con le QT 4.6.x, certamente non andrà con una versione molto più recente (potrebbe/dovrebbe funzionare per un passaggio di minor: 4.7.3 => 4.7.4;
quasi certamente no per un passaggio di major release number - 4.6.x => 4.7.x -, in ogni caso non senza un rebuild di KDE per le nuove QT).

Se le cose stanno così direi che ha due sole possibilità:
* rimettere le vecchie QT;
* passare al 4.5.5 MIB (che ti aggiornerà di suo le QT alla release 4.7.3) e poi eventualmente passare alle 4.7.4:
le istruzioni sono qui: http://mib.pianetalinux.org/mib/forum/v ... f=2&t=2554

GvM

User avatar
akiro
Utente
Utente
Posts: 143
Joined: 6 August 2009, 0:06
ROSA: -
OpenMandriva: -
Kernel: 4.9.35-desktop-1.mga
Desktop: KDE 5.12.2
country: italia
Location: prov di MI
Contact:

Re: Problema installazione nuove qt4-4.7.4-69.1mib2010.2

Post by akiro »

Grazie, per fortuna l'ho aggiornato oggi il profilo ^_^
ho già lanciato l'installazione e sono circa 465 pacchetti.. incrocio le dita.

ps. come mai stanno su un repository a parte?
Winston Smith, Arthur Dent, Benjamin Malaussene,...
Mageia 6 x86_64

User avatar
GvMariani
Collaboratore
Collaboratore
Posts: 610
Joined: 27 July 2009, 11:31
ROSA: 2016.1 Fresh R10
OpenMandriva: -
Kernel: 4.19.13-nrj-desktop
Desktop: Plasma 5
country: Italy
Location: Cologno Monzese (MI) - Italia

Re: Problema installazione nuove qt4-4.7.4-69.1mib2010.2

Post by GvMariani »

akiro wrote:Grazie, per fortuna l'ho aggiornato oggi il profilo ^_^
ho già lanciato l'installazione e sono circa 465 pacchetti.. incrocio le dita.

ps. come mai stanno su un repository a parte?

Prima per la dimensione della cosa, poi perché all'inizio erano in test e infine perché non tutti
sono passati subito al nuovo KDE (per bel un po' di mesi siamo andati avanti producendo doppi packages: per la standard 2010.2 e per la 2010.2 mibbizzata).
Ora come ora non credo che vi sia più nessuno dei packager MIB che sia ancora con la 2010.2 originale:
o sono sulla 2011.0 o con la 2010.2/KDE 4.5.5.

GvM

User avatar
akiro
Utente
Utente
Posts: 143
Joined: 6 August 2009, 0:06
ROSA: -
OpenMandriva: -
Kernel: 4.9.35-desktop-1.mga
Desktop: KDE 5.12.2
country: italia
Location: prov di MI
Contact:

Re: Problema installazione nuove qt4-4.7.4-69.1mib2010.2

Post by akiro »

Grazie mille dell'aiuto! Adesso è tutto ok.
Mi ero perso l'aggiornamento :oops:
Winston Smith, Arthur Dent, Benjamin Malaussene,...
Mageia 6 x86_64

User avatar
GvMariani
Collaboratore
Collaboratore
Posts: 610
Joined: 27 July 2009, 11:31
ROSA: 2016.1 Fresh R10
OpenMandriva: -
Kernel: 4.19.13-nrj-desktop
Desktop: Plasma 5
country: Italy
Location: Cologno Monzese (MI) - Italia

Re: Problema installazione nuove qt4-4.7.4-69.1mib2010.2

Post by GvMariani »

akiro wrote:Grazie mille dell'aiuto! Adesso è tutto ok.
Mi ero perso l'aggiornamento :oops:
Evviva! :D

GvM

User avatar
azioga
Utente senior
Utente senior
Posts: 336
Joined: 8 December 2010, 22:06
ROSA: -
OpenMandriva: 2010.2 32bit
Kernel: 3.2.28-nrj-desktop-p
Desktop: kde 4.5.5
country: italy

Re: Problema installazione nuove qt4-4.7.4-69.1mib2010.2

Post by azioga »

GvMariani wrote: ...sembra proprio che l'accoppiata driver proprietari - nuove Mesa non sia molto felice
(per questo abbiamo in produzione una versione di qt 4.7.4 rebuildata con la "vecchia" 7.8.1...).

Forse l'ultima cosa da provare era verificare che "OpenGLIsUnsafe" in kwinrc (sezione Compositing) fosse uguale a "False":
se posta a "True" questa voce disabilita il compositing in Kwin a prescindere dalla configurazione.

GvM
per la nuova versione concordo ;)

OpenGLIsUnsafe è = False

Ciao e buon fine settimana.

User avatar
NicCo
Amministratore
Amministratore
Posts: 4739
Joined: 6 December 2007, 19:54

Re: Problema installazione nuove qt4-4.7.4-69.1mib2010.2

Post by NicCo »

GvM wrote: > ho corretto il srpm (non basta un rebuild: senza OpenVg, EGL ecc ecc alcuni file non vengono proprio prodotti...)
> e buildare il risultante 69.2, ma per adesso solo per 64bit, se questo andrà bene seguirà a giorni anche il 32bit :
> dal mio test si installa senza più errori ed ha resistito ad un upgrade complessivo del vecchio 4.4.x al nostro 4.5.5.
GvM wrote: For mandriva 2010.2 64bit is available the update of QT 4.7.4 (rev 69.2), with some fixes and cleanup:
If this version is good enough, very soon there will be available the same porting even for 2010.2 32bit
From my test, QT install is without any dependency problems and also if you update kde 4.4.5 to 4.5.5

Here is my own (NicCo) feedback:
I finished all updates just now, i rebooted, everything seems to be fine on my 2010.2 x86_64 with Kde 4.5.5

My updates log

Code: Select all

[root@localhost ~]# urpmi --auto-select
Per soddisfare le dipendenze, saranno installati i seguenti pacchetti:
   Pacchetto                      Versione     Release       Arch.  
(supporto "Release_Main_64")
  lib64tidy0.99_0                20090904     2mdv2010.1    x86_64  
  tidy                           20090904     2mdv2010.1    x86_64                                                                                                                  
(supporto "Release_Contrib_64")                                                                                                                                                     
  ffmpeg2theora                  0.25         1mdv2010.1    x86_64                                                                                                                  
  python-xlib                    0.15         0.rc1.1mdv20> noarch                                                                                                                  
(supporto "Updates_Main_64")                                                                                                                                                        
  gnome-python-extras            2.25.3       18.19mdv2010> x86_64                                                                                                                  
  gnome-python-gtkmozembed       2.25.3       18.19mdv2010> x86_64                                                                                                                  
  gnome-python-gtkspell          2.25.3       18.19mdv2010> x86_64                                                                                                                  
  lib64apr-util1                 1.4.1        0.1mdv2010.2  x86_64                                                                                                                  
  lib64apr1                      1.4.5        0.1mdv2010.2  x86_64                                                                                                                  
  lib64mysql-devel               5.1.61       0.1mdv2010.2  x86_64                                                                                                                  
  lib64mysql16                   5.1.61       0.1mdv2010.2  x86_64                                                                                                                  
  lib64nm-glib2                  0.8.6.0      0.1mdv2010.2  x86_64                                                                                                                  
  lib64nm-util-devel             0.8.6.0      0.1mdv2010.2  x86_64                                                                                                                  
  lib64nm-util1                  0.8.6.0      0.1mdv2010.2  x86_64                                                                                                                  
  lib64openssl-engines1.0.0      1.0.0a       1.10mdv2010.2 x86_64                                                                                                                  
  lib64openssl1.0.0              1.0.0a       1.10mdv2010.2 x86_64                                                                                                                  
  lib64openssl1.0.0-devel        1.0.0a       1.10mdv2010.2 x86_64                                                                                                                  
  lib64xulrunner1.9.2.26         1.9.2.26     0.1mdv2010.2  x86_64                                                                                                                  
  mysql-client                   5.1.61       0.1mdv2010.2  x86_64                                                                                                                  
  mysql-common                   5.1.61       0.1mdv2010.2  x86_64                                                                                                                  
  mysql-common-core              5.1.61       0.1mdv2010.2  x86_64                                                                                                                  
  mysql-core                     5.1.61       0.1mdv2010.2  x86_64                                                                                                                  
  openssl                        1.0.0a       1.10mdv2010.2 x86_64                                                                                                                  
(supporto "Updates_Contrib_64")                                                                                                                                                     
  chromium-browser-stable        16.0.912.77  1mdv2010.2    x86_64  
(supporto "Backports_Main_64")
  bluefish                       2.2.1        1mdv2010.2    x86_64  
  drakguard                      0.7.7        4mdv2010.2    noarch  
  git                            1.7.9        1mdv2010.2    x86_64  
  git-arch                       1.7.9        1mdv2010.2    x86_64  
  git-core                       1.7.9        1mdv2010.2    x86_64  
  git-core-oldies                1.7.9        1mdv2010.2    x86_64  
  git-cvs                        1.7.9        1mdv2010.2    x86_64  
  git-email                      1.7.9        1mdv2010.2    x86_64  
  git-prompt                     1.7.9        1mdv2010.2    x86_64  
  git-svn                        1.7.9        1mdv2010.2    x86_64  
  gitk                           1.7.9        1mdv2010.2    x86_64  
  lib64vpx-devel                 0.9.7        3mdv2010.2    x86_64  
  lib64vpx0                      0.9.7        3mdv2010.2    x86_64  
  perl-Git                       1.7.9        1mdv2010.2    x86_64  
(supporto "Backports_Contrib_64")
  gmediafinder                   0.9.9.1      1mdv2010.2    noarch  
  mib-report                     0.7          1mdv2010.2    x86_64  
  smplayer                       0.7.0        1mdv2010.2    x86_64  
(supporto "Backports_NonFree_64")
  wine64-gecko                   1.2.0        1mdv2010.2    x86_64  (suggerito)
(supporto "Backports_MIB-basic_64")
  avidemux                       2.5.6        69.1mib2010.2 x86_64  
  avidemux-gtk                   2.5.6        69.1mib2010.2 x86_64  
  avidemux-qt                    2.5.6        69.1mib2010.2 x86_64  
  firefox-devel                  10.0         69.1mib2010.2 x86_64  
  lib64audiofile-devel           0.3.3        69.1mib2010.2 x86_64  
  lib64audiofile1                0.3.3        69.1mib2010.2 x86_64  
  lib64nss-devel                 3.13.1       69.2mib2010.2 x86_64  
  lib64nss-static-devel          3.13.1       69.2mib2010.2 x86_64  
  lib64nss3                      3.13.1       69.2mib2010.2 x86_64  
  lib64portaudio-devel           19           20            x86_64  
  lib64portaudio2                19           20            x86_64  
  lib64qt3support4               4.7.4        69.2mib2010.2 x86_64  
  lib64qt4-devel                 4.7.4        69.2mib2010.2 x86_64  
  lib64qtclucene4                4.7.4        69.2mib2010.2 x86_64  
  lib64qtcore4                   4.7.4        69.2mib2010.2 x86_64  
  lib64qtdbus4                   4.7.4        69.2mib2010.2 x86_64  
  lib64qtdeclarative4            4.7.4        69.2mib2010.2 x86_64  
  lib64qtdesigner4               4.7.4        69.2mib2010.2 x86_64  
  lib64qtgui4                    4.7.4        69.2mib2010.2 x86_64  
  lib64qthelp4                   4.7.4        69.2mib2010.2 x86_64  
  lib64qtmultimedia4             4.7.4        69.2mib2010.2 x86_64  
  lib64qtnetwork4                4.7.4        69.2mib2010.2 x86_64  
  lib64qtopengl4                 4.7.4        69.2mib2010.2 x86_64  
  lib64qtscript4                 4.7.4        69.2mib2010.2 x86_64  
  lib64qtscripttools4            4.7.4        69.2mib2010.2 x86_64  
  lib64qtsql4                    4.7.4        69.2mib2010.2 x86_64  
  lib64qtsvg4                    4.7.4        69.2mib2010.2 x86_64  
  lib64qttest4                   4.7.4        69.2mib2010.2 x86_64  
  lib64qtwebkit4                 4.7.4        69.2mib2010.2 x86_64  
  lib64qtxml4                    4.7.4        69.2mib2010.2 x86_64  
  lib64qtxmlpatterns4            4.7.4        69.2mib2010.2 x86_64  
  miro                           4.0.6        69mib2010.2   x86_64  
  mozilla-thunderbird            10.0         69.1mib2010.2 x86_64  
  mozilla-thunderbird-it         10.0         69.1mib2010.2 noarch  
  nss                            3.13.1       69.2mib2010.2 x86_64  
  nss-shlibsign                  3.13.1       69.2mib2010.2 x86_64  
  qt4-common                     4.7.4        69.2mib2010.2 x86_64  
  qt4-database-plugin-mysql      4.7.4        69.2mib2010.2 x86_64  
  qt4-database-plugin-sqlite     4.7.4        69.2mib2010.2 x86_64  
  qt4-designer                   4.7.4        69.2mib2010.2 x86_64  
  qt4-designer-plugin-qt3support 4.7.4        69.2mib2010.2 x86_64  
  qt4-designer-plugin-webkit     4.7.4        69.2mib2010.2 x86_64  
  qt4-doc                        4.7.4        69.2mib2010.2 noarch  
  qt4-examples                   4.7.4        69.2mib2010.2 x86_64  
  qt4-linguist                   4.7.4        69.2mib2010.2 x86_64  
  qt4-qtconfig                   4.7.4        69.2mib2010.2 x86_64  
  qt4-qtdbus                     4.7.4        69.2mib2010.2 x86_64  
  qt4-xmlpatterns                4.7.4        69.2mib2010.2 x86_64  
  rootcerts                      20120117.00  69.1mib2010.2 x86_64  
  rootcerts-java                 20120117.00  69.1mib2010.2 x86_64  
  seamonkey                      2.7          69.1mib2010.2 x86_64  
  wine32                         1.4          0.rc1.69.1mi> i686    
  wine64                         1.4          0.rc1.69.1mi> x86_64  
(supporto "Updates_Main_32")
  libopenssl-engines1.0.0        1.0.0a       1.10mdv2010.2 i586    
  libopenssl1.0.0                1.0.0a       1.10mdv2010.2 i586    
  libsqlite3_0                   3.7.7.1      0.1mdv2010.2  i586    
Altri 173MB di spazio disco saranno utilizzati.
Procedo con l'installazione di 98 pacchetti? (S/n) 
bye, NicCo
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

Post Reply