Changing brightness have no effect with kernel 3.15.10

About OpenMandriva
Post Reply
User avatar
viking
Utente junior
Utente junior
Posts: 80
Joined: 26 July 2012, 18:43
ROSA: Desktop Fresh R7 x64
OpenMandriva: -
Kernel: 4.1.18-nrjQL-desktop
Desktop: KDE Plasma 5.5.4
country: Serbia

Changing brightness have no effect with kernel 3.15.10

Post by viking »

I can not change backlight brightness when I boot with kernel 3.15.10. I can change the value without any problem, but nothing happens. Even keyboard shortcuts still work fine (Fn + Up arrow and Fn + Down arrow), but without effect on brightness.

After some experimenting I figured out that if I boot with 3.15.8, everything works fine.

If I remove acpi_backlight=vendor and boot with 3.15.10 I can change brightness again.

I can use changed boot line as workaround, but I think this should be fixed in some other way.

[viking@delta ~]$ uname -a
Linux delta.sbb.local 3.15.10-nrjQL-desktop-1omv #1 SMP PREEMPT Tue Sep 16 15:54:07 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Bug report can be found here

User avatar
NicCo
Amministratore
Amministratore
Posts: 4740
Joined: 6 December 2007, 19:54

Re: Changing brightness have no effect with kernel 3.15.10

Post by NicCo »

I have started a discussion on cooker ml
http://ml.openmandriva.org/pipermail/om ... 11692.html


the issue seems affecting many laptops

bye, NicCo
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
viking
Utente junior
Utente junior
Posts: 80
Joined: 26 July 2012, 18:43
ROSA: Desktop Fresh R7 x64
OpenMandriva: -
Kernel: 4.1.18-nrjQL-desktop
Desktop: KDE Plasma 5.5.4
country: Serbia

Re: Changing brightness have no effect with kernel 3.15.10

Post by viking »

NicCo wrote:I have started a discussion on cooker ml
http://ml.openmandriva.org/pipermail/om ... 11692.html


the issue seems affecting many laptops

bye, NicCo
I am confused with the fact that this happened after switching from 3.15.8 to 3.15.10. If this happened when switching from 3.14.x to 3.15.x then I would not be surprised at all.

I do not see any difference using video.use_native_backlight=1 or not. My system works with and without it as long as acpi_backlight=vendor is removed.

If you need any logs or something from my system, just ask.

Post Reply