[risolto] Impossibile upgrade

Community Pod OpenMandriva Italia
Post Reply
User avatar
Alex-G
Utente
Utente
Posts: 104
Joined: 19 September 2011, 11:49
ROSA: Rosa
OpenMandriva: OpenMandriva
Kernel: Vari
Desktop: Vari
country: IT

[risolto] Impossibile upgrade

Post by Alex-G »

OMA 2014.0 che si aggiornava costantemente, poi... non so cosa sia successo ma gli aggiornamenti non andavano più anche se mi appariva la notifica, il drakrpm non si avvia più e urpmi e rpm avviati da shell non fanno nulla... se ne stanno li buoni e femi senza combinare alcunché: non riesco più a installare ne i pacchetti correnti ne gli aggiornamenti dal sistema avviato

Sarebbe possibile aggiornare a OM 2014.2 da DVD? Ho provato a scaricare la iso, l' ho masterizzato ma dopo l' avvio non c'è nessuna opzione per l' aggiornamento di un sistema precedente preesistente, si può solo installare ex novo e potrei anche farlo ma vorrei mantenere tutti i pacchettri installati, in questo modo si perderebbero e mi toccherebbe reinstallare tutto di nuovo con grande perdita di tempo.

Alternativamwente se invece di riformattare la partizione / ci reinstallassi sopra la nuova versione? In teoria dovrebbe comunque sostituire tutto.... se va male tanto potrei riformattare e reinstallare ex novo, il rischio sarebbe relativo.

User avatar
andreas
Utente
Utente
Posts: 281
Joined: 1 November 2008, 20:03

Re: Impossibile upgrade

Post by andreas »

Premesso che non uso OMA e non so quanto profonde siano le differenze tra le versioni, io proverei a:

1) Fare una rebuild del datatabase di rpm (non ricordo i comandi, ma googlando dovresti trovarli facilmente: l'operazione è facile, ma lunghetta)
2) se non risolvi, provare a sostituire i repo con quelli della 2014.2, eventualmente scaricare manualmente il nuovo urpmi ed installarlo sempre manualmente con rpm -Uvh, usando la stessa procedura per installare eventuali dipendenze mancanti e provare ad aggiornare.

Non penso che potresti creare disastri peggiori di quelli che potresti farei provando a sovrascrivere l'installazione.
AndreaS

Procio Intel i7-4930k, mobo Asus X79-Deluxe, Adaptec raid 7805, Nvidia Quadro 6000 - Rosa Fresh R3 X64

User avatar
Alex-G
Utente
Utente
Posts: 104
Joined: 19 September 2011, 11:49
ROSA: Rosa
OpenMandriva: OpenMandriva
Kernel: Vari
Desktop: Vari
country: IT

Re: Impossibile upgrade [RISOLTO]

Post by Alex-G »

DUNQUE: pian piano sta tornando tutto a posto, a beneficio di tutti elenco i vari problemi (possibili cause dei malfunzionamenti) che ho trovato e risolto:

1) Un disco danneggiato da un distacco di corrente (c'è stato un periodo in cui erano purtropo frequenti e l' UPS si era guastato) e la partizione in cui risiedeva lo SWAP si era perduta.... infatti avevo un messaggio tipo "Dependency failed for Swap": sistemato il disco (fortunatamente il danno non era profondo e infatto lo SMART mi da sempre OK) e recuparata la partizione, anzi ho poi cambiato partizione di swap indicando un UUID diverso in fstab.

2) fatto chk di tutte le partizioni (smontate)

3) riparato il database dei pacchetti:
http://www.cyberciti.biz/tips/rebuildin ... abase.html

Code: Select all

 Method # 1 
Remove /var/lib/rpm/__db* files to avoid stale locks: 
# cd /var/lib # rm __db* 
Rebuild RPM database: 
# rpm --rebuilddb 
# rpmdb_verify Packages 

Method # 2 
If you are still getting errors, then try your luck with following commands: 
# mv Packages Packages-BAKUP # db_dump Packages-BAKUP | db_load Packages 
# rpm -qa 
# rpm --rebuilddb
__________________

Finalmente sono riuscito ad aggiornare da rete il sistema, l' unica cosa è che al boot mi indica sempre OpenMandriva 2014.0, mentre sulla barra superiore di drakconf appare 2014.2 ... vabbé...

Ora l' ultimo problema da risolvere è il funzionamento della gestione stampanti ma sarà oggetto di un altro messaggio.

Per il resto OMA funziona benissimo, anche su PC Obsoleti e con solo 768 MB Ram come quello in oggetto :)

User avatar
rugyada
Amministratore
Amministratore
Posts: 1545
Joined: 14 July 2008, 22:58
ROSA: ROSA.Fresh R8 64bit
OpenMandriva: OMLx 4.1 64bit
Kernel: kernel-relea current
Desktop: KDE tutta la vita
country: Italy

Re: [risolto] Impossibile upgrade

Post by rugyada »

Grazie per aver condiviso la soluzione.
Image
ciauu ciauu, ruru

MIB... e le stelle stanno a guardare.
«I grandi spiriti hanno sempre incontrato violenta opposizione da parte delle menti mediocri.»
(Albert Einstein)

Post Reply