[How to] use Flash Player contents > 11.2 in a Linux Browser

Guides, tutorials & docs
Post Reply
User avatar
NicCo
Amministratore
Amministratore
Posts: 4739
Joined: 6 December 2007, 19:54

[How to] use Flash Player contents > 11.2 in a Linux Browser

Post by NicCo »

Almost a year ago, Adobe announced it did not more support Flash Player on Linux:
and so 11.2 would be the last one, even if this version will be maintained for 5 years

Adobe announce
http://blogs.adobe.com/flashplayer/2012 ... linux.html

Image

We hoped that the first issues with Flash Player contents will be happened not so soon, but my son today said me:
Davide wrote:Hey Dad, some pages with games ask me for Flash Player greater than 11.2, the games dont play, what can I do?

I remembered that I had read an article about Google-Chrome describing a Pepper Plugin API (PPAPI):
this depends on Chrome NaCl, so even if we can copy it on Mozilla Firefox, this will not work with

FIrst Chrome using this Pepper Plugin API (PPAPI) was version 20 with Flash Player 11.3

Flash Plugin 11.3 and greater solves the problem of Blue video on YouTube resulted in nVidia GPU hardware acceleration, it was fixed and now it works perfectly well as integration of new fixes and improvements for safer and efficient viewing of multimedia content using Flash Adobe.

I remind you that Flash Player > 11.2 is only available in Chrome and not in Chromium or other spin-off

For Firefox, Opera, Reqonq and all other browsers:
Adobe would release a debug version of the plugin with which they can also use the new Flash Player plugin.
The new plugin should have asked anyway Pepper Plugin API (PPAPI) which depend on the NaCl Chrome then to use Flash Player on Firefox we need also install Google-Chrome.

but nowdays the situation seems like stalled, if I am not wrong...


I never believed it would hit users so soon... but new contents start to ask for 11.3 version as minimal requirements, so that's a real problem

Issues with old Flash Player version might become even worse with time passing, when some apps and pages could become unreadable...

I know that for many people says that flash player is crapped because it wastes too many cpu resources and freezes so many times, but we still need this crapped thing, at least until there will be something that we can replace with


I am trying the only solution that I can see now: I downloaded and installed Google Chrome

ROSA & Mandriva - 64bit

Code: Select all

urpmi https://dl.google.com/linux/direct/google-chrome-stable_current_x86_64.rpm
ROSA & Mandriva - 32bit

Code: Select all

urpmi https://dl.google.com/linux/direct/google-chrome-stable_current_i386.rpm
Checking the Chrome version:
> Chrome Versione 24.0.1312.52

in the address form I write
about:plugins
Adobe Flash Player (2 files) - Versione: 11.5.31.137
Shockwave Flash 11.5 r31
Nome: Shockwave Flash 11.5.31.137
while the same with Chromium-browser shows me
Adobe Flash Player - Versione: 11.2 r202
Shockwave Flash 11.2 r202

Final results: My son is happy!
Tested with http://www.gioco.it :
Crazy Penguin Wars, Race Track Rivals and many other new games
with flash player 11.2 dont play, now with 11.5 inside chrome it's OK


I wish hope that we will have the compatibility with the new Flash Player versions also with all other Internet Browser soon
In the meanwhile your chromium-browser can use that:

How to make Chromium use Flash Player from Chrome
http://www.webupd8.org/2012/09/how-to-m ... layer.html

This small Guide is dedicated to my son Davide, who revealed me this ugly issue
bye, NicCo
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
promeneur
Utente senior
Utente senior
Posts: 547
Joined: 6 February 2009, 17:47
ROSA: -
OpenMandriva: 2010.3 i586
Kernel: 3.5.7 nrj dsktp pae
Desktop: MIB kde 4.8.4
country: France

Re: [How to] use Flash Player contents > 11.2 in a Linux Bro

Post by promeneur »

yes i use chrome in some case

note :if you display menu bar (this is not my case) then in the menu bar in the "display" menu you can launch other browsers
if not add the addon "open with" according to to launch chrome (or other) on the current firefox page
Asus M2N, AMD Athlon 64 X2 5000+, 8 GB, Asus Nvidia 210 silent, Linksys WMP600N, Plugable USB-BT4LE Bluetooth 4.0 Adapter, lecteur multicarte Addonics AEIDDSAU, HP LaserJet 1220

User avatar
astragalo
Collaboratore
Collaboratore
Posts: 643
Joined: 7 December 2007, 18:29
ROSA: Rosa R11
OpenMandriva: -
Kernel: 4.9.155
Desktop: Plasma5
country: Italia

Re: [How to] use Flash Player contents > 11.2 in a Linux Bro

Post by astragalo »

La risposta di Mozilla è shumway.

Un articolo che ne parla:
http://www.ilsoftware.it/articoli.asp?t ... lugin_9353

il link Mozilla:

http://mozilla.github.com/shumway/

Bye
L'erba cattiva non muore mai!!! ;)
:D :D :D

Post Reply