[SOLVED] Firefox and Thunderbird fail to upd due lib64nss3

Discussioni e feedback su pacchetti e repository MIB
Post Reply
User avatar
Mayavimmer
Utente junior
Utente junior
Posts: 50
Joined: 21 November 2012, 11:06
ROSA: ROSA Desktp Frsh R2
OpenMandriva: -
Kernel: 3.11.10-nrjQL-deskto
Desktop: KDE
country: Italy

[SOLVED] Firefox and Thunderbird fail to upd due lib64nss3

Post by Mayavimmer »

Firefox and Thunderbird failed to update today due to unsatisfied lib64nss3 on my MIB box. First I ensured all repositories are up to date by forcing a manual update (there are still some that do not autoupdate for some reason). The I run:

Code: Select all

$ LC_ALL=C MandrivaUpdate --no-media-update --no-confirmation --no-splash
...which gives the following error:

Code: Select all

Sorry, the following packages cannot be selected:

- firefox-25.0.1-69.1-mib2012.1.x86_64 (due to unsatisfied lib64nss3[>= 2:3.15.3])
- mozilla-thunderbird-24.1.1-69-mib2012.1.x86_64 (due to unsatisfied lib64nss3[>= 2:3.15.3])
Note that Firefox and Thunderbird are the only packages left to be updated after updating all the others manually by individually selecting them.

The lib64nss3 libraries in question are:

Code: Select all

$ rpm -qa |grep lib64nss
lib64nss3-3.15.2-69-mib2012.1.x86_64
lib64nss-devel-3.15.2-69-mib2012.1.x86_64
UPDATE: SOLVED in the latest updates.
(Wow, I had to CHANGE THE TITLE and shorten it to add the [SOLVED] keyword -- I hope this won't mess up something else. Perhaps we should rethink the whole informal and only partly followed keyword strategy and bring it under programmatic control (in other words just click in a blasted "SOLVED" checkbox and have a matching greenish icon show up next to the solved topic))
Last edited by Mayavimmer on 7 December 2013, 14:10, edited 1 time in total.

User avatar
longlegs
Utente junior
Utente junior
Posts: 28
Joined: 24 February 2010, 17:29
ROSA: 2012.1 R2
OpenMandriva: -
Kernel: 3.10.19-nrj-desktop-
Desktop: kde
country: IT

Re: Firefox and Thunderbird fail to update due to lib64nss3

Post by longlegs »

Same thing here.

Waiting for the correction, i've used the usual workaround:

I've removed old firefox and then was not possible to install normally.
To re-install I've used urpmi in "konsole" with the option --allow-force and now everything is ok.

Angelo

User avatar
NicCo
Amministratore
Amministratore
Posts: 4739
Joined: 6 December 2007, 19:54

Re: Firefox and Thunderbird fail to update due to lib64nss3

Post by NicCo »

the right nss is now on the MIB /basic repo,
but the media_info ists are not updated

you can try to install new NSS manually
or wait the new list update for this night
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
ninarello19
Utente
Utente
Posts: 222
Joined: 4 March 2009, 15:56
OpenMandriva: 2010.2
Kernel: 2.6.38.2-desktop-nrj
Desktop: KDE 4.5.5

Re: Firefox and Thunderbird fail to update due to lib64nss3

Post by ninarello19 »

Ho lo stesso errore :

Code: Select all

[utente@localhost ~]$ su
Password: 
[root@localhost utente]# urpmi --auto-update
il supporto "Main_64_release" risulta già aggiornato
il supporto "Main_64_updates" risulta già aggiornato
il supporto "Contrib_64_release" risulta già aggiornato
il supporto "Contrib_64_updates" risulta già aggiornato
il supporto "NonFree_64_release" risulta già aggiornato
il supporto "NonFree_64_updates" risulta già aggiornato
il supporto "Restricted_64_release" risulta già aggiornato
il supporto "Restricted_64_updates" risulta già aggiornato
il supporto "MIB-basic_64" risulta già aggiornato
il supporto "MIB-experts_64" risulta già aggiornato
il supporto "Main_32_release" risulta già aggiornato
il supporto "Main_32_updates" risulta già aggiornato
il supporto "Contrib_32_release" risulta già aggiornato
il supporto "Contrib_32_updates" risulta già aggiornato
il supporto "NonFree_32_release" risulta già aggiornato
il supporto "NonFree_32_updates" risulta già aggiornato
il supporto "Restricted_32_release" risulta già aggiornato
il supporto "Restricted_32_updates" risulta già aggiornato
il supporto "MIB-basic_32" risulta già aggiornato
il supporto "KDE_4.10_x64" risulta già aggiornato
il supporto "KDE_4.10_x32" risulta già aggiornato
I pacchetti glibc-2.15-8-rosa2012.1.x86_64, rpm-helper-0.24.1-3-rosa2012.1.noarch, lib64nss3-3.15.2-69-mib2012.1.x86_64, lib64gdk_pixbuf2.0_0-2.28.2-1-rosa2012.1.x86_64, lib64proxy1-0.4.7-2-rosa2012.1.x86_64, lib64gcc1-4.7.3_2012.10-3.1-rosa2012.1.x86_64, lib64freetype6-2.4.12-1plf-plf2012.1.x86_64, lib64pango1.0_0-1.34.1-1-rosa2012.1.x86_64, lib64gtk+2.0_0-2.24.20-1-rosa2012.1.x86_64, lib64sqlite3_0-3.8.1-69-mib2012.1.x86_64, lib64dbus-glib-1_2-0.98-6-rosa2012.1.x86_64, lib64fontconfig1-2.10.93-2plf-plf2012.1.x86_64, lib64startup-notification-1_0-0.12-5-rosa2012.1.x86_64, lib64gio2.0_0-2.36.3-4-rosa2012.1.x86_64, lib64stdc++6-4.7.3_2012.10-3.1-rosa2012.1.x86_64, lib64atk1.0_0-2.8.0-1-rosa2012.1.x86_64, lib64z1-1.2.8-1-rosa2012.1.x86_64, lib64png15-1.5.17-1-rosa2012.1.x86_64, lib64gobject2.0_0-2.36.3-4-rosa2012.1.x86_64, desktop-file-utils-0.21-1-rosa2012.1.x86_64, lib64jpeg8-1.3.0-6-rosa2012.1.x86_64, lib64event5-2.0.21-2-rosa2012.1.x86_64, perl-base-5.14.2-8-rosa2012.1.x86_64, lib64hunspell1.3_0-1.3.2-4-rosa2012.1.x86_64, xdg-utils-1.1.0-0.20130218.1-rosa2012.1.noarch, lib64asound2-1.0.27.2-1-rosa2012.1.x86_64, lib64glib2.0_0-2.36.3-4-rosa2012.1.x86_64, lib64cairo2-1.12.16-1-rosa2012.1.x86_64, coreutils-8.19-6-rosa2012.1.x86_64, lib64vpx1-1.3.0-1.20131127-rosa2012.1.x86_64, lib64nspr4-4.10.2-1-rosa2012.1.x86_64 sono già installati
Alcuni dei pacchetti richiesti non possono essere installati:
firefox-25.0.1-69.1-mib2012.1.x86_64 (perché non è soddisfatto lib64nss3[>= 2:3.15.3])
mozilla-thunderbird-24.1.1-69-mib2012.1.x86_64 (perché non è soddisfatto lib64nss3[>= 2:3.15.3])
mozilla-thunderbird-it-24.1.1-69-mib2012.1.noarch (perché non è soddisfatto mozilla-thunderbird-24.1.1-3-rosa2012.1.x86_64)                                                                                                 
Continuo comunque l'Installazione? (S/n) s
Questi pacchetti devono essere rimossi per poterne aggiornare altri:
firefox-it-25.0.1-69.1-mib2012.1.noarch
 (perché non è soddisfatto firefox == 25.0.1)
mozilla-thunderbird-en_GB-17.0.9-69.1-mib2012.1.noarch
 (perché non è soddisfatto mozilla-thunderbird == 0:17.0.9)
mozilla-thunderbird-it-17.0.9-69.1-mib2012.1.noarch
 (perché non è soddisfatto mozilla-thunderbird == 0:17.0.9) (s/N) s
While some packages may have been installed, there were failures.
Alcuni dei pacchetti richiesti non possono essere installati:
firefox-25.0.1-69.1-mib2012.1.x86_64 (perché non è soddisfatto lib64nss3[>= 2:3.15.3])
mozilla-thunderbird-24.1.1-69-mib2012.1.x86_64 (perché non è soddisfatto lib64nss3[>= 2:3.15.3])
mozilla-thunderbird-it-24.1.1-69-mib2012.1.noarch (perché non è soddisfatto mozilla-thunderbird-24.1.1-3-rosa2012.1.x86_64)
[root@localhost utente]# urpmi lib64nss3
Il pacchetto lib64nss3-3.15.2-69-mib2012.1.x86_64 è già installato
[root@localhost utente]
A quanto pare le liste che dovevano essere aggiornate stanotte non sono state ancora aggiornate e l'errore permane.
Come si fa ad installare manualmente la lib64nss3 perchè mi risponde che : "Il pacchetto lib64nss3-3.15.2-69-mib2012.1.x86_64 è già installato."
Grazie
ninarello 19
ninarello19
=========
RosaDesktop.Fresh 2012.1 R1 - arch. x86_64 - KDE 4.10.4 MIB - Kernel 3.10.15-nrjQL-desktop-69rosa #1 SMP PREEMPT
O.S. alternativi su VMware workstation 10.0.0>>> Ubuntu, Windows XP Pro, Windows Seven e Mac come Macchine VIrtuali

User avatar
Mayavimmer
Utente junior
Utente junior
Posts: 50
Joined: 21 November 2012, 11:06
ROSA: ROSA Desktp Frsh R2
OpenMandriva: -
Kernel: 3.11.10-nrjQL-deskto
Desktop: KDE
country: Italy

Re: Firefox and Thunderbird fail to update due to lib64nss3

Post by Mayavimmer »

It works now. Setting topic to SOLVED.

Post Reply