[Spring 2009.1 MIB] kdetv non parte

Richieste generiche di aiuto
Post Reply
User avatar
mykol
Utente senior
Utente senior
Posts: 301
Joined: 14 January 2008, 12:13

[Spring 2009.1 MIB] kdetv non parte

Post by mykol »

Ciao,

sulla 2009.1 spring con MIB aggiornata, kdetv non parte e mi da questi messaggi:

[giorgio@localhost ~]$ kdetv
kdetv: error while loading shared libraries: libkdetv.so.1: cannot open shared object file: No such file or directory

cercando di installare libkdetv.so.1

[root@localhost giorgio]# urpmi -y libkdetv.so.1
Il pacchetto libkdevideo1-0.8.9-7mdv2009.1.i586 è già installato

e poi

[root@localhost giorgio]# urpmi -y kdetv -a
I pacchetti libkdevideo-devel-0.8.9-7mdv2009.1.i586, kdetv-0.8.9-7mdv2009.1.i586, libkdevideo1-0.8.9-7mdv2009.1.i586 sono già installati
[root@localhost giorgio]#

Cosa mi consigliate ?

Grazie
Mandriva 2009.1 i686 32 bit MIB, x86_64.
Mandriva 2010.0 i686 32 bit MIB

User avatar
astragalo
Collaboratore
Collaboratore
Posts: 653
Joined: 7 December 2007, 18:29
ROSA: Rosa R11.1
OpenMandriva: -
Kernel: 4.15.xx
Desktop: Plasma5
country: Italia

Re: [Spring 2009.1 MIB] kdetv non parte

Post by astragalo »

Ciao partiamo con le domande in quale occasione si è presentato il problema? Hai per caso aggiornato qualcos'altro? Era da tanto che non lo usavi?

Potresti provare a disinstallarlo e reinstallarlo.

Eventualmente potremo provare a rebuildarlo con l'attuale infrastruttura, che kde stai usando?

Ciao.

Astragalo.
L'erba cattiva non muore mai!!! ;)
:D :D :D

User avatar
mykol
Utente senior
Utente senior
Posts: 301
Joined: 14 January 2008, 12:13

Re: [Spring 2009.1 MIB] kdetv non parte

Post by mykol »

scusate, non ho più potuto proseguire ... ora riprendo

Ho la 2009.1 spring con i repo del mib ed aggiornata.

ecco i repo attivi:

[root@localhost giorgio]# urpmi.update -a
il supporto "MIB-FREE_i686" è aggiornato
il supporto "MIB-NOFREE_i686" è aggiornato
il supporto "Main" è aggiornato
il supporto "Main Updates" è aggiornato
il supporto "Main Backports" è aggiornato
il supporto "Contrib" è aggiornato
il supporto "Contrib Updates" è aggiornato
il supporto "Contrib Backports" è aggiornato
il supporto "Non-free" è aggiornato
il supporto "Non-free Updates" è aggiornato
il supporto "Non-free Testing" è aggiornato
il supporto "Non-free Backports" è aggiornato
il supporto "PLF Free" è aggiornato
il supporto "PLF Free backports" è aggiornato
il supporto "PLF Non-free" è aggiornato
il supporto "PLF Non-free backports" è aggiornato
il supporto "FireFox3.5.3" è aggiornato
[root@localhost giorgio]#

ciononostante certi soft non si installano perchè manca qualche dipendenza oppure poi non funzionano.

Rimanendo a kdetv, ottengo questo errore:

[giorgio@localhost ~]$ kdetv
kdetv: error while loading shared libraries: libkdetv.so.1: cannot open shared object file: No such file or directory
[giorgio@localhost ~]$

ma se cerco di installare libkdetv.so.1

[root@localhost giorgio]# urpmi libkdetv.so.1
Il pacchetto libkdevideo1-0.8.9-7mdv2009.1.i586 è già installato
[root@localhost giorgio]#

ma anche

[root@localhost giorgio]# urpme libkdetv.so.1
pacchetto sconosciuto: libkdetv.so.1
[root@localhost giorgio]#

poi ho disintallato kdetv e l'ho reinstallato da gestione soft (non mette nè toglie dipendenze) ma continua a non funzionare

Infine ho provato con urpmi

[root@localhost giorgio]# urpmi kdetv
Per soddisfare le dipendenze, saranno installati i seguenti pacchetti:
Pacchetto Versione Release Arch.
(supporto "Contrib")
kdetv 0.8.9 7mdv2009.1 i586
libkdevideo1 0.8.9 7mdv2009.1 i586
Altri 4MB di spazio disco saranno utilizzati.
verranno scaricati 931KB di pacchetti.
Procedo con l'installazione di 2 pacchetti? (S/n)

$MIRRORLIST: media/contrib/release/libkdevideo1-0.8.9-7mdv2009.1.i586.rpm
$MIRRORLIST: media/contrib/release/kdetv-0.8.9-7mdv2009.1.i586.rpm
installazione di libkdevideo1-0.8.9-7mdv2009.1.i586.rpm kdetv-0.8.9-7mdv2009.1.i586.rpm da /var/cache/urpmi/rpms
In preparazione... ###############################################
1/2: libkdevideo1 ###############################################
2/2: kdetv ###############################################
gtk-update-icon-cache: No theme index file.[root@localhost giorgio]#
[root@localhost giorgio]#

[giorgio@localhost ~]$ kdetv
kdetv: error while loading shared libraries: libkio.so.4: cannot open shared object file: No such file or directory
[giorgio@localhost ~]$

Suggerimenti ?

Grazie

(per altri prob analoghi aprirò un altro post).
Mandriva 2009.1 i686 32 bit MIB, x86_64.
Mandriva 2010.0 i686 32 bit MIB

User avatar
SymbianFlo
Utente sostenitore
Utente sostenitore
Posts: 1493
Joined: 7 December 2007, 20:07
OpenMandriva: 2010.1 x86_64
Kernel: 2.6.33.5-nrj-69mib
Desktop: kde4.5.rc1
Location: Pordenone
Contact:

Re: [Spring 2009.1 MIB] kdetv non parte

Post by SymbianFlo »

mi dispiace dirlo ma non sai usare ne urpmi ne urpme ,
urpmi/e nome_pacchetto e non nome_lib-generata.so o .h etc.
può anche capitare che ti venga riconosciuta la libreria cercando il header .h o .so del provides
ma sono solo coincidenze , urpmi/e si usano con il nome della libreria o pure con il alias:

Code: Select all

[symbianflo@symbianflo ~]$ sudo urpmi --help
urpmi versione 6.25.6                       
Copyright (C) 1999-2008 Mandriva.           
Questo è software libero e può essere ridistribuito secondo i termini della licenza GNU GPL.

uso:
  --help         - stampa questo messaggio di aiuto.
  --media        - usa solo i supporti nella lista, separati da virgole.
  --excludemedia - non usa i supporti elencati, separati da virgole.    
--update       - usa solo supporti di aggiornamento.                    
  --searchmedia        - usa solo i supporti indicati per cercare i pacchetti richiesti
  --sortmedia    - ordina i supporti in base alle sotto-stringhe separate da virgole   
  --synthesis    - utilizza la synthesis specificata invece del db urpmi.              
--auto       - modalità automatica, usa la risposta predefinita per tutte le domande   
  --auto-select  - seleziona automaticamente i pacchetti per aggiornare il sistema.    
  --auto-update  - aggiorna i supporti prima di aggiornare il sistema.                 
    --no-md5sum    - disabilita il controllo MD5SUM.                                   
    --force-key    - forza l'aggiornamento della chiave gpg.                           
  --auto-orphans - rimuove orfani senza chiedere conferma                              
  --no-suggests     - non seleziona automaticamente i pacchetti "suggeriti"            
  --no-uninstall - non chiedere mai di rimuovere un pacchetto, ferma l'installazione   
  --no-install  - non installa i pacchetti, esegue solo il download                    
  --keep         - usa i pacchetti esistenti se possibile, rifiuta                     
                   i pacchetti richiesti se sono da rimuovere.                         
  --split-level  - divide l'operazione in piccole transazioni se più di                
                   un pacchetto sta per essere installato o                            
                   aggiornato, il valore predefinito è 1.                              
  --split-length - per avere transazione più corte, il valore predefinito è 8.         
  --fuzzy, -y        - impone una ricerca fuzzy.                                       
  --buildrequires      - installa quanto richiesto (buildrequires) per il pacchetto    
  --install-src  - installa solo il pacchetto dei sorgenti (non i binari).             
  --clean        - rimuove gli rpm dalla cache prima di fare qualsiasi altra cosa.     
  --noclean      - tieni in cache gli rpm inutilizzati.                                
  --update       - aggiorna solo il DB degli rpm, non il filesystem.                   
  --replacepkgs  - forza l'installazione dei pacchetti già installati.                                                        
  --force        - forza l'esecuzione anche se alcuni pacchetti non esistono.                                                 
  --allow-nodeps - permette di chiedere all'utente se desidera installare                                                     
                   dei pacchetti senza controllare le dipendenze.                                                             
  --allow-force  - permette di chiedere all'utente se desidera installare                                                     
                   dei pacchetti senza controllare dipendenze e integrità.                                                    
  --allow-suggests - seleziona automaticamente i pacchetti "suggeriti"                                                        
  --parallel     - urpmi distribuito fra varie macchine dell'alias.                                                           
  --root         - cambia la directory di root per installare i file rpm "chrooted".                                          
  --root         - cambia la directory radice per installare i file rpm e per il db di urpmi.                                 
..--use-distrib  - configura urpmi "al volo" da un albero distribuito, utile                                                  
                       per installare un pacchetto chroot con l'opzione --root.
  --metalink     - genera e usa un metalink locale.
  --downloader   - programma da usare per scaricare i file remoti.
                   programmi noti: curl, wget, prozilla, aria2
--curl-options - opzioni aggiuntive da passare a curl
--rsync-options - opzioni da passare ad rsync
--wget-options - opzioni da passare a wget
--prozilla-options - opzioni da passare a prozilla
  --aria2-options - opzioni aggiuntive da passare ad aria2
  --limit-rate   - limita la velocità del download.
..--resume       - riprende il trasferimento dei file parzialmente scaricati
                     (--no-resume lo disabilita, solitamente è disabilitato).
  --proxy        - usa il proxy HTTP specificato, il numero di porta
                    predefinito è1080 (formato: <proxyhost[:port]>).
  --proxy-user   - specifica utente e password da utilizzare per
                   l'autenticazione col proxy (formato: <utente:password>).
  --bug          - produce un bug report nella directory indicata con
                   l'argomento successivo.
  --env          - usa un ambiente specifico (tipicamente un bug report).
  --verify-rpm   - verifica la firma del pacchetto prima dell'installazione
                   (--no-verify-rpm la disabilita, solitamente è abilitata).
  --test         - verifica che l'installazione possa avvenire correttamente.
  --excludepath  - percorsi da escludere, separati da virgole.
  --excludedocs  - esclude i file di documentazione.
  --ignoresize -non verifica lo spazio disponibile prima dell'installazione
--ignore-arch...- permette di installare pacchetti di altre architetture.
--noscripts    - non esegue gli script contenuti nei pacchetti
  --replacefiles - ignora i conflitti tra file.
  --repackage     - Ri-pacchetta i file prima della cancellazione.
  --skip         - pacchetti da saltare durante l'installazione.
  --prefer       - pacchetti da preferire
  --more-choices - qualora si trovassero più pacchetti propone più scelte
                     che quelle predefinite.
--nolock       - non bloccare il db degli rpm
  --strict-arch  - aggiorna solo i pacchetti della stessa architettura.
  -a             - seleziona tutte le corrispondenze da riga di comando.
  -p             - abilita la ricerca tra i provides del pacchetto.
  -P             - non cercare tra i provides per trovare il pacchetto.
  --quiet, -q    - modalità silenziosa.
  --verbose, -v  - modalità prolissa.
  --debug        - modalità molto prolissa.

  [b]i nomi o file rpm[/b] passati da riga di comando verranno installati.
per il libkio.so4:

Code: Select all

[symbianflo@symbianflo ~]$ urpmf libkio.so
kdelibs4-devel:/usr/lib64/libkio.so
lib64kio5:/usr/lib64/libkio.so.5
se tu hai i repo mib aggiornati avrai anche kde4.3.5 e quindi

Code: Select all

[symbianflo@symbianflo ~]$ rpm -q -i lib64kio5
Name        : lib64kio5                    Relocations: (not relocatable)
Version     : 4.3.5                             Vendor: MIB - Mandriva Italia Backports - http://mib.pianetalinux.org/
Release     : 69.1mib2009.1                 Build Date: gio 28 gen 2010 16:25:00 CET
Install Date: dom 31 gen 2010 15:46:45 CET      Build Host: symbianflo
Group       : System/Libraries              Source RPM: kdelibs4-4.3.5-69.1mib2009.1.src.rpm
Size        : 2905248                          License: ARTISTIC BSD GPL_V2 LGPL_V2 QPL_V1.0
Signature   : (none)
Packager    : Andrey Bondrov <bondrov@math.dvgu.ru>
URL         : http://www.kde.org
Summary     : KDE 4 core library
Description :
KDE 4 core library.
[symbianflo@symbianflo ~]$
allora essendo una 2009.1 32 bit e il kdetv pacchetto contrib e quindi buildato su kde3.5.10 , che ce
tuttora sulla 2009.1.
quindi ovvio che non puo caricare kio.so.4 perche tu hai solo kio.so.5.
Cosa fare ? Installare lib64kdecore4 ( nel tuo caso cercati la lib a 32 bit)
ovvero:

Code: Select all

[symbianflo@symbianflo ~]$ rpm -q -i lib64kdecore4 --provides
Name        : lib64kdecore4                Relocations: (not relocatable)
Version     : 3.5.10                            Vendor: Mandriva         
Release     : 11mdv2009.1                   Build Date: lun 30 mar 2009 18:55:57 CEST
Install Date: sab 24 ott 2009 03:12:33 CEST      Build Host: deborah.mandriva.com    
Group       : Development/KDE and Qt        Source RPM: kdelibs3-3.5.10-11mdv2009.1.src.rpm
Size        : 34051841                         License: LGPL_V2                            
Signature   : DSA/SHA1, gio 23 apr 2009 20:39:15 CEST, Key ID 445935f878d019f5             
Packager    : Helio Chissini de Castro <helio@mandriva.com>                                
URL         : http://www.kde.org                                                           
Summary     : Core libraries for KDE                                                       
Description :                                                                              
Libraries for the K Desktop Environment.                                                   
kdelibs = 30000000:3.5.10-11mdv2009.1                                                      
libkdecore = 30000000:3.5.10-11mdv2009.1                                                   
cupsdconf.so()(64bit)                                                                      
dcopserver.so()(64bit)                                                                     
highcolor.so()(64bit)                                                                      
highcontrast.so()(64bit)                                                                   
kabc_dir.so()(64bit)                                                                       
kabc_file.so()(64bit)                                                                      
kabc_ldapkio.so()(64bit)                                                                   
kabcformat_binary.so()(64bit)                                                              
kaddprinterwizard.so()(64bit)                                                              
kbuildsycoca.so()(64bit)                                                                   
kbzip2filter.so()(64bit)                                                                   
kcm_kresources.so()(64bit)                                                                 
kcmshell.so()(64bit)                                                                       
kconf_update.so()(64bit)                                                                   
kcookiejar.so()(64bit)                                                                     
kded.so()(64bit)                                                                           
kded_kcookiejar.so()(64bit)                                                                
kded_kdeprintd.so()(64bit)                                                                 
kded_kdetrayproxy.so()(64bit)                                                              
kded_kpasswdserver.so()(64bit)                                                             
kded_kssld.so()(64bit)                                                                     
kded_kwalletd.so()(64bit)                                                                  
kded_proxyscout.so()(64bit)                                                                
kdeprint_cups.so()(64bit)                                                                  
kdeprint_ext.so()(64bit)                                                                   
kdeprint_lpdunix.so()(64bit)                                                                                                 
kdeprint_lpr.so()(64bit)                                                                                                     
kdeprint_rlpr.so()(64bit)                                                                                                    
kdeprint_tool_escputil.so()(64bit)                                                                                           
kdewidgets.so()(64bit)                                                                                                       
keramik.so()(64bit)                                                                                                          
kfileaudiopreview.so()(64bit)                                                                                                
kgzipfilter.so()(64bit)                                                                                                      
khtmlimagepart.so()(64bit)                                                                                                   
kimg_dds.so()(64bit)                                                                                                         
kimg_eps.so()(64bit)                                                                                                         
kimg_exr.so()(64bit)                                                                                                         
kimg_hdr.so()(64bit)                                                                                                         
kimg_ico.so()(64bit)                                                                                                         
kimg_jp2.so()(64bit)                                                                                                         
kimg_pcx.so()(64bit)                                                                                                         
kimg_psd.so()(64bit)                                                                                                         
kimg_rgb.so()(64bit)                                                                                                         
kimg_tga.so()(64bit)                                                                                                         
kimg_tiff.so()(64bit)                                                                                                        
kimg_xcf.so()(64bit)                                                                                                         
kimg_xview.so()(64bit)                                                                                                       
kio_file.so()(64bit)                                                                                                         
kio_ftp.so()(64bit)                                                                                                          
kio_ghelp.so()(64bit)                                                                                                        
kio_help.so()(64bit)                                                                                                         
kio_http.so()(64bit)                                                                                                         
kio_http_cache_cleaner.so()(64bit)                                                                                           
kio_metainfo.so()(64bit)                                                                                                     
kio_uiserver.so()(64bit)                                                                                                     
kjavaappletviewer.so()(64bit)                                                                                                
klauncher.so()(64bit)                                                                                                        
klzmafilter.so()(64bit)                                                                                                      
knotify.so()(64bit)                                                                                                          
kspell_aspell.so()(64bit)                                                                                                    
kspell_hspell.so()(64bit)                                                                                                    
kspell_ispell.so()(64bit)                                                                                                    
kstyle_highcontrast_config.so()(64bit)                                                                                       
kstyle_plastik_config.so()(64bit)                                                                                            
ktexteditor_docwordcompletion.so()(64bit)                                                                                    
ktexteditor_insertfile.so()(64bit)                                                                                           
ktexteditor_isearch.so()(64bit)                                                                                              
ktexteditor_kdatatool.so()(64bit)                                                                                            
kthemestyle.so()(64bit)                                                                                                      
libDCOP.so.4()(64bit)                                                                                                        
libartskde.so.1()(64bit)                                                                                                     
libkabc.so.1()(64bit)                                                                                                        
libkabc_dir.so.1()(64bit)                                                                                                    
libkabc_file.so.1()(64bit)                                                                                                   
libkabc_ldapkio.so.1()(64bit)                                                                                                
libkatepart.so()(64bit)                                                                                                      
libkatepartinterfaces.so.0()(64bit)                                                                                          
libkcertpart.so()(64bit)                                                                                                     
libkdecore.so.4()(64bit)                                                                                                     
libkdefakes.so.4()(64bit)                                                                                                    
libkdefx.so.4()(64bit)                                                                                                       
libkdeinit_cupsdconf.so()(64bit)                                                                                             
libkdeinit_dcopserver.so()(64bit)                                                                                            
libkdeinit_kaddprinterwizard.so()(64bit)                                                                                     
libkdeinit_kbuildsycoca.so()(64bit)                                                                                          
libkdeinit_kcmshell.so()(64bit)                                                                                              
libkdeinit_kconf_update.so()(64bit)
libkdeinit_kcookiejar.so()(64bit)
libkdeinit_kded.so()(64bit)
libkdeinit_kio_http_cache_cleaner.so()(64bit)
libkdeinit_kio_uiserver.so()(64bit)
libkdeinit_klauncher.so()(64bit)
libkdeprint.so.4()(64bit)
libkdeprint_management.so.4()(64bit)
libkdeprint_management_module.so()(64bit)
libkdesasl.so.1()(64bit)
libkdesu.so.4()(64bit)
libkdeui.so.4()(64bit)
libkdnssd.so.1()(64bit)
libkhtml.so.4()(64bit)
libkhtmlpart.so()(64bit)
libkimproxy.so.0()(64bit)
[size=150]libkio.so.4()(64bit)[/size]
libkjava.so.1()(64bit)
libkjs.so.1()(64bit)
libkmdi.so.1()(64bit)
libkmdi2.so.1()(64bit)
libkmediaplayer.so.0()(64bit)
libkmid.so.0()(64bit)
libkmultipart.so()(64bit)
libknewstuff.so.1()(64bit)
libkntlm.so.0()(64bit)
libkparts.so.2()(64bit)
libkresources.so.1()(64bit)
libkscreensaver.so.4()(64bit)
libkscript.so.0()(64bit)
libkspell.so.4()(64bit)
libkspell2.so.1()(64bit)
libktexteditor.so.0()(64bit)
libkunittest.so.1()(64bit)
libkutils.so.1()(64bit)
libkwalletbackend.so.1()(64bit)
libkwalletclient.so.1()(64bit)
libshellscript.so()(64bit)
libvcard.so.0()(64bit)
light.so()(64bit)
plastik.so()(64bit)
lib64kdecore4 = 30000000:3.5.10-11mdv2009.1
lib64kdecore4(x86-64) = 30000000:3.5.10-11mdv2009.1
NB: Tutti esempi sopra sono 2009.1 x86_64 a te servono le lib simili a 32 bit.
PS. se vuoi cercare file dati da provides di una libreria o/e alias usa

Code: Select all

urpmf
esempio.

Code: Select all

[symbianflo@symbianflo ~]$ urpmf libkio.so.4
    http://mib.pianetalinux.org/2009.1/x86_64/MIB-free/media_info/hdlist.cz
    http://mib.pianetalinux.org/2009.1/x86_64/MIB-nonfree/media_info/hdlist.cz
    http://urpmi.mandriva.ru/lists/ru/basic.2009.1.x86_64.list: media/main/updates/media_info/20100306-194449-files.xml.lzma
    http://urpmi.mandriva.ru/lists/ru/basic.2009.1.x86_64.list: media/main/backports/media_info/20100309-024523-files.xml.lzma
lib64kdecore4:/opt/kde3/lib64/libkio.so.4
lib64kdecore4:/opt/kde3/lib64/libkio.so.4.2.0
PPS: ovviamente questi problemi dovevano essere risolti dal packager tramite la sezione Requires
dello spec , ma essendo un contrib , c'era d'aspettarsi
(scusate ma non posso dimenticare ,come avete fatto voi altri ,che ci hanno dato dei incompetenti a NOI)
CHIEDO SCUSA SE E OFFENSIVO IL MIO POST MA LO FATTO APPOSTA .
:D ciao ciao SymbianFlo :D
Image
Linus Torvalds only has to enter a room, and every Windows computer in it segfaults instantly.
http://video.linuxfoundation.org/video/1057

User avatar
mykol
Utente senior
Utente senior
Posts: 301
Joined: 14 January 2008, 12:13

Re: [Spring 2009.1 MIB] kdetv non parte

Post by mykol »

grazie
Mandriva 2009.1 i686 32 bit MIB, x86_64.
Mandriva 2010.0 i686 32 bit MIB

User avatar
Moreno
Utente junior
Utente junior
Posts: 73
Joined: 25 February 2010, 8:26
OpenMandriva: Cooker
Kernel: 2.6.33
Desktop: Tutti

Re: [Spring 2009.1 MIB] kdetv non parte

Post by Moreno »

Ciao
SymbianFlo wrote:mi dispiace dirlo ma non sai usare ne urpmi ne urpme ,
urpmi/e nome_pacchetto e non nome_lib-generata.so o .h etc.
può anche capitare che ti venga riconosciuta la libreria cercando il header .h o .so provides
ma sono solo coincidenze , urpmi/e si usano con il nome della libreria o pure con il alias:
Uomo di poca fede nelle taumaturgiche funzionalità di urpmi 8<))))))))

Direi che Mykol ha appena scoperto una funzione, a noi tutti sconosciuta, di urpmi davvero spettacolare e che funziona BENISSIMO!!

Code: Select all

# urpmi liblibkdetv.so.1


installazione di libkdevideo1-0.9.0-0.986125.1mdv2010.0.i586.rpm da /public/Linux/Mandriva/i586/Cooker/contrib
In preparazione...               #############################################
      1/1: libkdevideo1          #############################################
Effettivamente la stessa cosa non vale per urpme, un vero peccato


Ciao Ciao, Moreno

User avatar
SymbianFlo
Utente sostenitore
Utente sostenitore
Posts: 1493
Joined: 7 December 2007, 20:07
OpenMandriva: 2010.1 x86_64
Kernel: 2.6.33.5-nrj-69mib
Desktop: kde4.5.rc1
Location: Pordenone
Contact:

Re: [Spring 2009.1 MIB] kdetv non parte

Post by SymbianFlo »

Moreno wrote:Ciao
SymbianFlo wrote:mi dispiace dirlo ma non sai usare ne urpmi ne urpme ,
urpmi/e nome_pacchetto e non nome_lib-generata.so o .h etc.
può anche capitare che ti venga riconosciuta la libreria cercando il header .h o .so provides
ma sono solo coincidenze , urpmi/e si usano con il nome della libreria o pure con il alias:
Uomo di poca fede nelle taumaturgiche funzionalità di urpmi 8<))))))))

Direi che Mykol ha appena scoperto una funzione, a noi tutti sconosciuta, di urpmi davvero spettacolare e che funziona BENISSIMO!!

Code: Select all

# urpmi liblibkdetv.so.1


installazione di libkdevideo1-0.9.0-0.986125.1mdv2010.0.i586.rpm da /public/Linux/Mandriva/i586/Cooker/contrib
In preparazione...               #############################################
      1/1: libkdevideo1          #############################################
Effettivamente la stessa cosa non vale per urpme, un vero peccato


Ciao Ciao, Moreno

Ascolta moreno nessuno vuole toglierti quello che e tuo di diritto , ma vacci piano
ho detto sopra :
può anche capitare che ti venga riconosciuta la libreria cercando il header .h o .so del provides
ma sono solo coincidenze
e ribadisco che e cosi.Ma se tu hai rescritto urpmi e sai che va
BENISSIMO
chiedo scusa ( ma di quello che mi risulta , ho perfino segnalazioni bug per urpmi , direttamente a security@mandriva.com e non solo io ce una comunità intera che mi ha fatto dei test e bug report, alternative perl, pezzi di codice da proporre, etc. ), mykol non ha fatto altro che ha scoperto un'altra anomalia del urpmi .
Che funziona benissimo lo dici tu io ti posso portare kilometri de log che non e cosi , se vuoi
promuovere anche le cazzate che li fa mandriva anche qui ti dico che non ti farò fare queste cose , anche perche MIB
(almeno di quello che so io ) cerca di risolvere le rogne fatte da loro e integrare i nostri lavori nel mandriva
( che ti posso assicurare non e facile ), nascondersi dietro il " VA BENISSIMO" non si risolvono le mancanze o
le rogne , e se ho detto che kdetv e pacchettizzato a ca**o de cane e cosi , punto.
Lo so che tu sei dio moreno , e vedo con dispiacere che tutti quanti del mib hanno la memoria
che spande , ti stimo come avversario perche sei l'unico di "la" che ha sempre dichiarato
apertamente di odiare il MIB ma tutto qui.
Quindi per cortesia promoviamo le cose vere e fatte bene e cerchiamo di sistemare le rogne LOCO
perche un bugfix venuto da MIB non sarà mai preso in considerazione.

Code: Select all

my $restart_itself;
if ($options{replacepkgs}) {
    urpm::select::select_replace($urpm, $state, \%requested);
} else {
    $restart_itself = urpm::select::resolve_dependencies($urpm,
    $state,
    \%requested,
    rpmdb => $env && "$env/rpmdb.cz",
    auto_select => $auto_select,
    callback_choices => \&ask_choice,
    install_src => $install_src,
    keep => $urpm->{options}{keep},
    nodeps => $urpm->{options}{'allow-nodeps'} || $urpm->{options}{'allow-force'},
    no_suggests => $urpm->{options}{'no-suggests'},
    priority_upgrade => $test || $env ? '' : $urpm->{options}{'priority-upgrade'},
    );
}
Io non sono ne Moreno ne esperta in perl ma dico ,
restart_itself /upgrade o pure replacepkgs, e la soluzione di tutti problemi di urpmi ?
e questi parametri vengono chiamati in loop su tutte le condizioni ambietali di urpmi,
basta guardarlo.....
Andiamo sulla pkgs:suffix ? che va sempre beissimo?
mah....
:D ciao ciao SymbianFlo :D
Image
Linus Torvalds only has to enter a room, and every Windows computer in it segfaults instantly.
http://video.linuxfoundation.org/video/1057

User avatar
NicCo
Amministratore
Amministratore
Posts: 4752
Joined: 6 December 2007, 19:54

Re: [Spring 2009.1 MIB] kdetv non parte

Post by NicCo »

Da tutta questa discussione penso che alla fine si possa trarre solo una conclusione pratica:
la cosa migliore sarebbe fare un backport del kdetv fatto come si deve, sopratutto che funzioni!

Propongo che appena qualcuno dei packager MIB ha del tempo a disposizione, mettere in cantiere il pacchetto!

alla fine lo scopo principale del MIB è di cercare di accontentare e rendere soddisfatti gli Utenti della Comunita' Mandriva, e risolvere le cose che non vanno bene, o non funzionanti del tutto, quando e come si riesce meglio, tempo permettendo

Il primo che si propone, si ricordi di mettere la sua attività di inizio porting/testing dentro il RPMS Events
http://mib.pianetalinux.org/mib/rpms-events


ciao,
NicCo
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
SymbianFlo
Utente sostenitore
Utente sostenitore
Posts: 1493
Joined: 7 December 2007, 20:07
OpenMandriva: 2010.1 x86_64
Kernel: 2.6.33.5-nrj-69mib
Desktop: kde4.5.rc1
Location: Pordenone
Contact:

Re: [Spring 2009.1 MIB] kdetv non parte

Post by SymbianFlo »

fresco fresco da 5 secondi fa :

Code: Select all

[root@symbianflo SRPMS]# urpmi libiberty.h
Nessun pacchetto denominato libiberty.h
[root@symbianflo SRPMS]# urpmf libiberty.h
lib64binutils2-devel:/usr/include/libiberty.h
BENISSIMO DICI ???? ma va......
:D ciao ciao SymbianFlo :D
Image
Linus Torvalds only has to enter a room, and every Windows computer in it segfaults instantly.
http://video.linuxfoundation.org/video/1057

User avatar
Moreno
Utente junior
Utente junior
Posts: 73
Joined: 25 February 2010, 8:26
OpenMandriva: Cooker
Kernel: 2.6.33
Desktop: Tutti

Re: [Spring 2009.1 MIB] kdetv non parte

Post by Moreno »

Ciao

Sempre nervosetto vedo.

Mi erano sfuggite le righe a cui ti riferivi e te ne chiedo scusa.

Penso di aver capito come funziona la magic feature di urpmi, i nomi che accetta non sono i nomi dei file ma bensì i RPMTAG_PROVIDENAME dei pacchetti.

Es.

Il pacchetto zzuf fornisce i seguenti oggetti:

Code: Select all

## RPMTAG_PROVIDENAME
libzzuf.so
zzuf = 0.13-1mdv2010.1
zzuf(x86-32) = 0.13-1mdv2010.1

Quindi posso fare urpmi 'zzuf(x86-32)' (gli apostrofi sono essenziali dato che altrimenti viene segnalato un errore di formattazione)

ed infatti

Code: Select all

# urpmi 'zzuf(x86-32)'


installazione di zzuf-0.13-1mdv2010.1.i586.rpm da /public/Linux/Mandriva/i586/Cooker/contrib
In preparazione...               ###########################################################################################################################################################
      1/1: zzuf                  ###########################################################################################################################################################
#

e per conferma

# urpmi libzzuf.so
Il pacchetto zzuf-0.13-1mdv2010.1.i586 è già installato
#


Se questo è un Bug vorrei che scrivessero ogni giorno Bug del genere invece di impedirmi di installare la 2010.1 Alpha 3.


Ciao Ciao, Moreno

User avatar
Dago68
Collaboratore
Collaboratore
Posts: 526
Joined: 7 December 2007, 0:40

Re: [Spring 2009.1 MIB] kdetv non parte

Post by Dago68 »

Salve Mykol,

grazie per la tua segnalazione,

questo weekend cercherò di reimpacchettare kdetv in modo che possa funzionare sulla tua 2009.1.

Ti consiglio di vedere arte non male come canale tv :-)

Un saluto

Dago68

User avatar
mykol
Utente senior
Utente senior
Posts: 301
Joined: 14 January 2008, 12:13

Re: [Spring 2009.1 MIB] kdetv non parte

Post by mykol »

Grazie Dago68,

Non ho capito a cosa ti riferisci
Ti consiglio di vedere arte non male come canale tv
"arte" è un canale tv ?
Mandriva 2009.1 i686 32 bit MIB, x86_64.
Mandriva 2010.0 i686 32 bit MIB

User avatar
Dago68
Collaboratore
Collaboratore
Posts: 526
Joined: 7 December 2007, 0:40

Re: [Spring 2009.1 MIB] kdetv non parte

Post by Dago68 »

Ciao mykol

ho ricompilato il pacchetto vedi se va:

http://mib.pianetalinux.org/2009.1/i686 ... 1.i686.rpm
http://mib.pianetalinux.org/2009.1/i686 ... 1.i686.rpm
http://mib.pianetalinux.org/2009.1/i686 ... 1.i686.rpm
mykol wrote: "arte" è un canale tv ?
si :-)

un saluto

Dago68

User avatar
mykol
Utente senior
Utente senior
Posts: 301
Joined: 14 January 2008, 12:13

Re: [Spring 2009.1 MIB] kdetv non parte

Post by mykol »

grazie ma non posso provare perché su quel pc ho messo la 2010, spero che il tuo lavoro serva a qualcun altro !

Posso vedere se si avvia sul portatile con la 2009.1 mib, ma li non ho la scheda tv e quindi non posso provarlo per bene.

Kdetv per la 2010 si avvia, ma fa pena (come aspetto), non l'ho nancora provato bene e non posso dirti se funziona.
Mandriva 2009.1 i686 32 bit MIB, x86_64.
Mandriva 2010.0 i686 32 bit MIB

Post Reply