Problemi con Xorg e GRUB con GPU AMD - RISOLTO

Discussioni sul progetto ROSA e aiuto agli utenti
Post Reply
User avatar
Alex-G
Utente
Utente
Posts: 103
Joined: 19 September 2011, 11:49
ROSA: Rosa
OpenMandriva: OpenMandriva
Kernel: Vari
Desktop: Vari
country: IT

Problemi con Xorg e GRUB con GPU AMD - RISOLTO

Post by Alex-G »

SISTEMA: ASRock AB350M-HDV, AM4, 4xSATA3, DDR4, USB 3.0 + APU AMD A6 9500E GPU R5 / S.O. ROSA Desktop Fresh R10 con gli ultimi aggiornamenti alla data odierna.

Dunque... tutto è cominciato quando ho provato ad usare grub-customizer per modificare dei parametri di avvio del kernel (di solito lo faccio editando il conf ma stavolta ho voluto provare questo) da allora Xorg non si avvia più nemmeno ripristinando grub.conf originale inoltre se provo a riconfigurare con XFdrake praticamente si cancella tutto il contenuto di grub.conf e il sistema ovviamente non parte, ho il backup ma Xorg non si avvia comunque
Last edited by Alex-G on 20 November 2018, 6:45, edited 4 times in total.

User avatar
Alex-G
Utente
Utente
Posts: 103
Joined: 19 September 2011, 11:49
ROSA: Rosa
OpenMandriva: OpenMandriva
Kernel: Vari
Desktop: Vari
country: IT

Re: Problemi con Xorg e GRUB con GPU AMD - RISOLTO

Post by Alex-G »

Dopo svariati tentativi alla fine ho optato per la riformattazione e reinstallazione di tutto, tanto era solo un test per cui non c'era nulla di importante da conservare.

MA almeno una cosa l'ho imparata: con grub2-efi MAI usare il Tool grub-customizer perchè scombina completamente la configurazione di GRUB rendendola inservibile e irrecuperabile.

Il sistema viene installato di default con il tool
- drakconf-kde4-2016.1-11-rosa2016.1.noarch
- kcm-grub2-0.5.8-14-rosa2016.1.i586

Se si usa Plasma, questo va disinstallato e sostituito con plasma5-kcm-grub2 , perfettamente compatibile con la configuirazione di GRUB2-EFI.

E almeno questo problema è risolto.

Ora bisogna vedere se il problema della GPU permane o si risolve anche questo.
Last edited by Alex-G on 19 November 2018, 15:28, edited 3 times in total.

User avatar
Alex-G
Utente
Utente
Posts: 103
Joined: 19 September 2011, 11:49
ROSA: Rosa
OpenMandriva: OpenMandriva
Kernel: Vari
Desktop: Vari
country: IT

Re: Problemi con Xorg e GRUB con GPU AMD - RISOLTO

Post by Alex-G »

Alex-G wrote:Dopo svariati tentativi alla fine ho optato per la riformattazione e reinstallazione di tutto, tanto era solo un test per cui non cì' era nulla di importante.

MA almeno una cosa l'ho imparata: con grub2-efi MAI usare il Tool grub-customizer perchè scombina completamente la configurazione di GRUB rendendola inservibile e irrecuperabile.

Il sistema viene installato di default con il tool
- drakconf-kde4-2016.1-11-rosa2016.1.noarch
- kcm-grub2-0.5.8-14-rosa2016.1.i586

Se si usa Plasma, questo va disinstallato e sostituito con plasma5-kcm-grub2 , perfettamente compatibile con la configuirazione di GRUB2-EFI.

E almeno questo problema è risolto.

Ora bisogna vedere se il problema della GPU permane o si risolve anche questo
In effetti c'era un ulteriore problema aggiuntivo: i sistemi con APU AMD hanno una GPU Radeon, R5/R7, integrata con la CPU e il driver dev' essere *amdgpu*, invece per qualche strano motivo si era successivamente installato il driver RADEON (probabilmente quando avevo installato Adobe acrobat Reader che per qualche motivo a me sconosciuto, richiede tra le dipendenze obbligatoriamente il driver radeon) per cui basta modificare il file di configurazione in /etc/X11/xorg.conf.d commentando le righe in cui è presente il driver errato, riavviare e tutto torna al suo posto. PROBLEMA RISOLTO. NOTA: il radeon si era nstallato prima del riavvio per cui il problema della GPU non l' avevo notato prima e l' avevo erroneamente associato a quello di grub.

Aggiungo una valutazione complessiva: con questa configurazione HW ci sono alcune periferiche che harddrake classifica come "non riconosciute" (entrerò nei dettagli in un altro messaggio) tuttavia il sistema pare comunque funzionare perfettamente ed è molto veloce e responsivo.

Post Reply