Firefox 3.0.5

Firefox 3.0.5 for Mandriva Linux 2007.1, 2008.1 and 2009.0

L’ultima versione del notissimo browser.

Sito web: http://www.mozilla.org/

Le novità di Firefox v3.0.5:

Firefox 3.0.5 risolve diversi problemi individuati in Firefox 3.0.4

* Risolti diversi problemi di sicurezza.
* Sono disponibili i pacchetti ufficiali in bengalese, esperanto, galiziano, hindi e lituano.
* Corretti diversi problemi legati alla stabilità dell’applicazione.
* Sostituita la licenza per l’utente finale (EULA) con una nuova barra informativa “Conosci i tuoi diritti”, visualizzata in caso di prima installazione.
* Risolto un problema delle precedenti versioni di Firefox legato all’installazione simultanea di più pacchetti XPI firmati digitalmente.
* Sistemati diversi problemi legati all’implementazione delle funzioni di accessibilità.
* Aggiunta all’applicazione per la segnalazione dei crash la possibilità di inviare note specifiche per il sistema operativo in uso.

Qui è disponibile l’elenco completo dei bug risolti: https://bugzilla.mozilla.org

Pacchetti preparati da NicCo, grissino e symbianflo

  • english
  • italian

20 Responses to “Firefox 3.0.5”


  1. 1 Alessandro

    Dopo aver installato firefox dal repo mib firefox non parte più, mi da questo errore:
    Could not find compatible GRE between version 1.9.0.4 and 1.9.0.4.

    togliendolo ed installandolo dai pacchetti ufficiali riparte correttamente

  2. 2 Leonardo

    Lo stesso problema è appena successo anche a me con l’aggiornamento del mib, si risolve reinstallando il pacchetto ufficiale

  3. 3 nicco

    x Alessandro e Leonardo:

    Per quale Distro avete provato il pacchetto?
    [b]2009.0, 2008.1 o 2007.1 ???[/b]

    Io ho installato sul mio Pc con 2009.0
    la versione i686 e la x86_64 di FF305
    e da me vanno magnificamente…

    E poi come le avete installato, manualmente, o via urpmi:?
    Chiedo questo perche’ le liste aggiornate da stamattina,
    e sono attive solamente
    dalle ore 10:45 circa per la 2009.0
    dalle ore 12:30 circa per la 2008.1
    Ieri notte sono state ad aggiornarsi e solo adesso online.

    Se le avete installate manualmente e’ possibile che abbiate dimenticato
    di installare qualcosa.

  4. 4 Leonardo

    Vorrei scusarmi non ricordo mai di inserire i dati della versione installata: firefox 3.0.5 69.1 mib 2009.0 i686

  5. 5 nicco

    Ma hai installato da repo, via urpmi o a mano?

    Avrebbe dovuto installare il file della lingua italiana e poi il programma in se stesso.

  6. 6 nicco

    E’ strano, ho appena aggiornato un PC, e mi da lo stesso probelma:
    Ma sul mio PC funziona tutto correttamente

    BINGO: ho compilato con xulrunner, che implementa nuove funzionalita’,
    ma il pacchetto non richiede esso come dipendenza in aggiornamento

    Adesso controllo meglio, per cui ho si toglie lo xulrunner
    oppure … un attimo e vi diro’

  7. 7 Leonardo

    grazie nicco ti stavo mandando il post relativo a
    libxulrunner1.9 - Dynamic libraries for xulrunner? la versione installata è la 1.9.0.5 che la versione ufficiale riconosce o non considera come libreria importante per l’installazione di firefox 3.0.5 mentre la versione del mib richiede la versione precedente la 1.9.0.4

  8. 8 nicco

    Io avevo gia provato questa procedura e funziona:

    urpmi –allow-force xulrunner

    Anche se vi dira che ci sono conflitti vari:
    che disturberebbero il funzionamento di tre precedenti programmi ed esattamente:

    epiphany, yelp, e gnome-python-gtkmozembed

    e’ sufficiente forzare l’installazione dicendo si, cosi verra’ installato
    lo xulrunner necessario, il nuovo firefox funzionera’ ed anche i vecchi
    programmi epiphany e altri, citati sopra.

    Adesso provero’ a rivedere il programma ff per cercare la versione 1.9.0.5:
    e poi quanto meno strano che la 1.9.0.4 venga considerata un aggiornamento se si da il comando urpmi,

    devono aver combinato qualche casino in Mandriva con le versioni dei pacchetti


    ========================================================
    ASPETTATE un po’ che sto ricompilando il programma con la versione 1.9.0.5
    ========================================================

  9. 9 nicco

    Problema individuato e risolto:
    Sul mio Pc dove ho preparato e testato il programma era installata per errore la libxulrunner, in versione precedente, ovvero la 1.9.0.4

    Mentre la maggior parte delle installazioni ha la versione 1.9.0.5

    Per qualche strana ragione di qualche aggiornamento andato a male, o altro, quando ho installato la libreria di sviluppo con:
    urpmi libxulrunner-devel,
    Mi ha installato proprio a versione 1.9.0.4 invece della nuova 1.9.0.5

    Quando ho testato il programma da me, sia 32bit sia 64bit, funzionava tutto perfettamente, era stata compilata con la versione 1.9.0.4, quella libreria c’era, ma di quella versione 1.9.0.4, i files forse li avevo solo io…

    Dal momento che il programma per funzionare cercava la versione installata sul mio PC da me funzionava, mentre non funzionava a coloro i quali avevano la nuova 1.9.0.5.

    Scoperto l’inghippo, ho provveduto immediatamente a cancellare tutti i file e librerie varie numerate xulrunner 1.9.0.4 e le ho poi sostituite con le corrispettive versioni 1.9.0.5

    Ho quindi cercato di ricompilare tutto e fixare il problema a tempo di record:

    2009.0 - x64 - gli rpm corretti sono gia’ sul server
    2009.0 - i686 - gli rpm corretti sono gia’ sul server
    2009.0 - i586 - gli rpm corretti sono gia’ sul server

    I pacchetti nuovi sono riconoscibili dal numero di release finale “2mib2009.0..”

    Nel frattempo ho anche sostituito, per chi non avesse ancora fatto l’aggiornamento e lo stia facendo proprio in questo momento, anche quelli con la parte finale “1mib2009.0..”, che sono adesso funzionanti, o almeno lo dovrebbero essere,

    Tra qualche ora che le liste saranno pronte, la versione proposta sara’ direttamente la .2 corretta

    Intanto le liste sono in aggiornamento:
    Per tutti coloro che hanno la versione 1mib non funzionante, possono adesso:

    Scaricare ed installare a mano la versione con il numeretto “2mib” finale, dalla cartella /progs

    o aspettare un po’ le liste corrette, che aggiorneranno il tutto alla versione .2mib

    firefox-3.0.5-69.1mib2009.0.i686.rpm
    firefox-3.0.5-69.2mib2009.0.i686.rpm

    Entrambi funzionanti adesso, e lo stesso vale per le architetture x86_64 e i586

  10. 10 Stefano

    Ragazzi, che casino, non funziona nulla neppure con l’aggiornamento 2mib. Da terminale continua a darmi lo stesso errore di xulrunner..come risolvo?? eppure è tutto aggiornatissimo!

  11. 11 Stefano

    Aggiungo che a me l’errore è con la versione 1.9.0.5 ma io tra i pacchetti installati ho solo la 1.9.0.4!

  12. 12 nicco

    ti occorre la
    xulrunner 1.9.0.5

    dal momento che la versione ultima per tutti dovrebbe essere quella
    e
    dal momento che faceva casini, ho prima eliminato ogni ricorrenza di rpm xulrunner, attraverso “kpackage”,
    e poi ho reinstallato di nuovo xulrunner e mi ha installato proprio la 1.9.0.5

    Si fa notare che stranamente alcuni mirror non contengono ancora tale versione, ma quella vecchia, e’ stato cio’ a creare tutti questi problemi:
    Se continua cosi forse copiero’ la versione 1.9.0.5 sul server MIB cosi’ non ci sarebbero problemi se i repo mandriva non aggiornassero essa proprio a tale versione.

    Ma di sicuramente lo faro la prossima volta, con il prossimo FIrefox, mibizzero anche tali librerie, e le mettero sul server…

  13. 13 Jo

    Ciao a tutti.
    Volevo segnalare che per Mandriva 2008.1 il pacchetto di FF3.0.5 non si installa.
    L’errore riportato (sia dal tool grafico che dalla riga di comando) è il seguente:

    Spiacente, questo pacchetto non può essere selezionato:

    - firefox-it-3.0.5-69.1mib2008.1.i686 (perché non è soddisfatto firefox[== 3.0.5])

    Ciao e grazie di tutto

  14. 14 nicco

    x Jo

    Riprova, e sarai piu’ fortunato!

  15. 15 bat86

    on 2008.1 i686 works fine! thanks!

  16. 16 albpanig

    con Mandriva 2009.0 ho provato a disinstallare xulrunner 1.9.0.3 e installare 1.9.0.5
    A questo punto non ho più potuto reinstallare gnucash (neanche le versioni successive alla 2.26)
    ciao e comunque grazie

  17. 17 nicco

    x albpanig

    Se ti occorre, sarebbe possibile fare un rebuild del gnucash, per farlo funzionare con la 1.9.0.5 di xulrunner:
    fammi sapere…

  18. 18 astragalo

    Ciao ho aggiornato dalla versione precedente sulla 2008.1 versione 32 bit i686 con il pacchetto firefox-3.0.5-69.1mib2008.1, tutto ok.

    Ciao Astragalo.

  19. 19 othoth-tux

    installato come aggiornamento su 2008.1 i686, perfetto!!!

  20. 20 albpanig

    x nicco

    gnucash mi servirebbe. se vuoi fare una rebuild (anche versioni successive alla 2.26) ti ringrazio in anticipo. L’unica cosa che non capisco è: perché questo cambio di release di xulrunner non diventa ufficiale (visto i problemi che da)? Ciao

Leave a Reply