Broadcom drivers 5.10.27.11

Broadcom drivers 5.10.27.11 for Mandriva Linux 2008.1 and 2009.0

Driver per le schede wi-fi o wlan per moltissimi portatili che purtroppo da sempre hanno hanno dato filo da torcere. Spesso, in emulazione con ndiswrapper funzionavano male, e con i driver sul kernel ottenuti da reverse engineering non ne volevano sapere.

Gli utenti, quindi, non potendo utilizzare la loro scheda di rete wi-fi e non volendo rinunciare a Linux, erano costretti a comperare un pennino wi-fi esterno compatibile.

Adesso la Broadcom ha rilasciato un driver per kernel ufficiale che è parso opportuno e conveniente portarlo in dkms, per una semplice installazione.
A differenza dei pacchetti in cooker, il MIB ha preparato un pacchetto che considera anche le blacklist, e quindi non dovrebbe presentare i problemi che si riscontrano sul pacchetto cooker.

Ribadiamo che non avendo l’hardware necessario non abbiamo potuto testarli.

I pacchetti sono presenti nei nostri repo /non-free:

per 2008.1 gia’ disponibili per i586 e i686.
per 2009.0 sono disponibili in tutte le tre architetture.

Pacchetti:
dkms-broadcom-wl-5.10.27.11-1.2mib2008.1.i686.rpm
dkms-broadcom-wl-5.10.27.11-1.2mib2008.1.i586.rpm

dkms-broadcom-wl-5.10.27.11-1.1mib2009.0.x86_64.rpm
dkms-broadcom-wl-5.10.27.11-1.1mib2009.0.i686.rpm
dkms-broadcom-wl-5.10.27.11-1.1mib2009.0.i586.rpm

Porting di grissino.
Preparati da grissino e NicCo.

  • english
  • italian

8 Responses to “Broadcom drivers 5.10.27.11”


  1. 1 astragalo

    Ciao Nicco… ed Astragaletto tuo cosa sta a farci nel MIB ho giusto una scheda (Belkin)che risponde così a lspci:

    03:00.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)

    Per un test dovrebbe andar bene giusto?

    Al momento non ho un wireless ma per fare una prova qualcosa da qualche amico la trovo, appena pronti per la 2008.1 ci sentiamo per fare un test.

    Ciao e buone feste sia a te che a Grissino.

    Astragalo.

    P.S. se qualcuno li prova prima lasci per favore un feedback, grazie.

  2. 2 grissino

    Ciao astragalo,
    erano gia’ pronte solo per un problema di connessione non le avevo mandate.

    Prova(te)le e fammi/fatemi sapere.

    Grazie ricambio.

    ciao.
    grissino.

  3. 3 astragalo

    Rieccomi qua dopo un po di prove ed un aggiornamento del pacchetto credo di poter dire che la mia scheda non è supportata dal driver.

    Pensavo/speravo supportasse tutta la serie bcm43xx invece il mio 4318 non lavora.

    Il driver comunque sembra fare il suo lavoro la blacklist evita il caricamento dei moduli indesiderati ed il caricamento manuale del modulo va a buon fine.

    Ora speriamo che qualche anima pia lo provi e lasci un feedback.

    Ciao Astragalo.

  4. 4 vmalav

    io ho una belkin con lspci
    bcm4306.
    mi caricava un modulo ssb che andava da schifo e con ndis invece è ok.
    ho installato il driver mib, ma continua a caricarmi la wifi con ndiswrapper.
    come posso fare a provare il driver?
    volevo anche far presente che dal sito della broadcom specificano i chip che funzionano con quel driver.
    il mio nn c’è, ma mi pare nemmeno quello di astragalo

  5. 5 astragalo

    Ciao infatti col mio non funziona!

    Mi spiace, ma mi sa che dovremo aspettare e sperare che supportino anche i nostri chipset.

    Aspettiamo il test di un possessore dei chipset supportati, dai chi ha una di quelle schede faccia uno sforzo per favore!

    Ciao Astragalo.

  6. 6 mangiagnomi

    appena installati funzionano perfetti ha richiesto 47 mb di pacchetti dopo il secondo riavvio si sono messi a funzionare tutto ok

  7. 7 vmalav

    allora, come da post sopra ho un chip bcm4306.
    ho installato il driver broadcom e al cambio kernel (ora l’ultimo mib, aggiornamento oggi) mi ha caricato il dfriver al boot senza dir niente.
    wi-fi funzionante e bene, in mcc hardware mi da il modulo ssb.
    tutto funziona, anche se nn so se siano i driver nuovi mib ad andare o che.
    comunque è perfetto

  8. 8 MauRice

    Ho un BCM4318 en non funziona.
    Verzione actuale e 5.10.27.14, e se leggi il sito orginale funziona sollo con BCM 4311-, 4312-, 4321- e 4322-.
    http://www.broadcom.com/support/802.11/linux_sta.php

    Per le alte Broadcom deve avere kernel-module B43 + firmware
    ftp://ftp.surfnet.nl/pub/os/Linux/distr/mandrakeclubnl/2009.0/i586/release/B43-firmware-4.150.10.5-1mcnl2009.0.noarch.rpm

    MauRice

Leave a Reply